E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > ABS, Traction Control and Run Flat lights on all at the same time.



Reply
 
Thread Tools Search this Thread
      01-17-2009, 01:06 PM   #1
MIC328i
Captain
 
MIC328i's Avatar
 
Drives: E90 M3
Join Date: May 2007
Location: Markham

Posts: 784
iTrader: (18)

ABS, Traction Control and Run Flat lights on all at the same time.

While I was driving to work yesterday, a couple of warning lights went on and were cycling on my dash. It started with the ABS warning, then traction control warning along with the run-flat tires one after another.

I'm wondering if any of you experts out there had the same experience and know what's costing it. I thought my brakes were done so I went to my mechanic to get a brake pad change but he told me it was actually my ABS failing. These warnings light just keep beeping every 5 mins and is annoying as hell. So if anyone can chime in with their experiences or any solution would be appreciated.

Anyhow I have already booked an appointment with my dealership this Thursday so I'll keep you guys updated.
MIC328i is offline   Canada
0
Reply With Quote
      01-17-2009, 05:02 PM   #2
cobradac
First Lieutenant
 
cobradac's Avatar
 
Drives: '05 645Ci Coupe
Join Date: Oct 2005
Location: Titusville, FLA

Posts: 374
iTrader: (0)

Garage List
2005 645Ci  [0.00]
Sounds like electrical fault such as low battery or alternator is putting out spikes.
__________________
Member - Knights of the Roundel (bimmerdriver s.com)
Over 58 runs of the ToD (or 18,444+ curves)
cobradac is offline  
0
Reply With Quote
      01-10-2010, 02:54 PM   #3
shipill
Major
 
Drives: E350 Coupe
Join Date: Jan 2007
Location: Toronto

Posts: 1,285
iTrader: (7)

Hi , same this happend to my car yesterday !!! any updates OP ???
shipill is offline   Canada
0
Reply With Quote
      01-10-2010, 05:16 PM   #4
volkswackin
Lieutenant Colonel
 
Drives: too broke for a BMW
Join Date: Jan 2008
Location: i get around..

Posts: 1,911
iTrader: (1)

likely a steering angle sensor error..
volkswackin is offline   United_States
0
Reply With Quote
      01-10-2010, 08:00 PM   #5
Rekla
Hug the road... Carpe Asphalt
 
Rekla's Avatar
 
Drives: 2007 ///M Coupe
Join Date: Sep 2006
Location: Greater Seattle area - WA

Posts: 595
iTrader: (18)

This is what I experienced:
http://www.e90post.com/forums/showthread.php?t=302383
__________________
2013 X5-35d - Platinum Grey / Oyster; Premium - Sport
2007 BMW ///M Coupe
RETIRED 2006 TiAg E90 330i - Black leather - Alu Trim - Prem - Sport - NAV - Step - CA - Heated Seats
Rekla is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST