E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Reset brake pad warning light on 335i?



Reply
 
Thread Tools Search this Thread
      03-09-2007, 12:42 PM   #1
dolby
Second Lieutenant
dolby's Avatar
12
Rep
262
Posts

 
Drives: 2009 e90 M3
Join Date: Oct 2006
Location: Charlotte, NC

iTrader: (0)

Reset brake pad warning light on 335i?

Anyone know the procedure for this?

dolby
__________________
- 1998 E36M3/4 (retired)
- 2005 E46 330i ZHP (totaled)
- 2007 E90 335i Black/Blk/Alu Trim (retired)
- 2009 E90 M3 - Jet Blk on Blk mDCT
- 1987 E30 325is - track car conversion in progress
Appreciate 0
      03-09-2007, 01:05 PM   #2
Jaws
Lieutenant Colonel
Jaws's Avatar
Canada
21
Rep
1,736
Posts

 
Drives: 2006 325i mt
Join Date: Aug 2006
Location: Edmonton

iTrader: (0)

I'd like a definitive answer for this too, but the answer might lie in this thread.

http://www.e90post.com/forums/showthread.php?t=42669
__________________
2006 325i - Sparkling Graphite
2000 S2000 - New Formula Red
2007 Chev Silverado crew cab Z71
Appreciate 0
      03-09-2007, 01:38 PM   #3
dolby
Second Lieutenant
dolby's Avatar
12
Rep
262
Posts

 
Drives: 2009 e90 M3
Join Date: Oct 2006
Location: Charlotte, NC

iTrader: (0)

Figured it out!

Push start button twice with the foot off the back and clutch....when check control image disappears and all that is left is current time on the LCD panel of the instrument cluster, press and hold the odometer reset button. After a few seconds, a yellow icon will show up showing that you have service indicator light on. Push and hold the "BC" button of the turn signal stalk until it states "Reset?" let go of the button and push the button back in and hold, a little clock will come up, once the clock graphic besides the reset goes away let go. Turn the car off and resart as normal. The brake light service indicator has now been reset.

dolby
__________________
- 1998 E36M3/4 (retired)
- 2005 E46 330i ZHP (totaled)
- 2007 E90 335i Black/Blk/Alu Trim (retired)
- 2009 E90 M3 - Jet Blk on Blk mDCT
- 1987 E30 325is - track car conversion in progress
Appreciate 0
      03-09-2007, 01:44 PM   #4
dolby
Second Lieutenant
dolby's Avatar
12
Rep
262
Posts

 
Drives: 2009 e90 M3
Join Date: Oct 2006
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by Jaws View Post
I'd like a definitive answer for this too, but the answer might lie in this thread.

http://www.e90post.com/forums/showthread.php?t=42669
Thanks! That got me going in the right direction.
__________________
- 1998 E36M3/4 (retired)
- 2005 E46 330i ZHP (totaled)
- 2007 E90 335i Black/Blk/Alu Trim (retired)
- 2009 E90 M3 - Jet Blk on Blk mDCT
- 1987 E30 325is - track car conversion in progress
Appreciate 0
      03-09-2007, 05:55 PM   #5
Placey
First Lieutenant
Placey's Avatar
United_States
3
Rep
367
Posts

 
Drives: 08 Z4 3.0SI
Join Date: Feb 2007
Location: Upstate New York

iTrader: (1)

NP
Appreciate 0
      06-28-2007, 12:59 AM   #6
rotaz
Captain
rotaz's Avatar
17
Rep
686
Posts

 
Drives: CaymanS
Join Date: Sep 2006
Location: OC

iTrader: (0)

awesome...I have the same problem...I'll try this tonight.
__________________
|Arrived 12/14/06| JP Vizage Kit| Gone 4/4/09 |
Appreciate 0
      01-09-2009, 05:31 PM   #7
AllGo'N'Show
New Member
AllGo'N'Show's Avatar
Canada
0
Rep
5
Posts

 
Drives: In the works...
Join Date: Jan 2009
Location: Canada

iTrader: (0)

Quote:
Originally Posted by dolby View Post
Figured it out!

Push start button twice with the foot off the back and clutch....when check control image disappears and all that is left is current time on the LCD panel of the instrument cluster, press and hold the odometer reset button. After a few seconds, a yellow icon will show up showing that you have service indicator light on. Push and hold the "BC" button of the turn signal stalk until it states "Reset?" let go of the button and push the button back in and hold, a little clock will come up, once the clock graphic besides the reset goes away let go. Turn the car off and resart as normal. The brake light service indicator has now been reset.

dolby

Tried this a few times, couldn't get it to work. Any ideas anyone?
Appreciate 0
      02-05-2009, 05:59 PM   #8
e90drvr
Private
United_States
0
Rep
62
Posts

 
Drives: Graphite/Terra 330i
Join Date: Sep 2008
Location: Los Angeles, CA

iTrader: (0)

worked fine for me after a couple of tries. i was letting go of the odo reset button when the yellow icon appeared...don't do this...hold the odo reset button, after about a second when the yellow icon appears continue holding the odo reset button AND hold the BC button. "> Reset?" will appear, release both the BC and the odo reset buttons and then hold BC. A clock animation shows up next to the word "Reset", continue holding the BC button. Once the clock animation disappears, the word "Reset" should be followed by a check mark. And your done.
Appreciate 0
      02-05-2009, 06:13 PM   #9
ksfrogman
Major General
ksfrogman's Avatar
United_States
154
Rep
6,751
Posts

 
Drives: E90 330i 6MT
Join Date: Nov 2005
Location: Torrance, CA

iTrader: (12)

Garage List
2006 330i  [0.00]
2006 330i  [0.00]
Send a message via AIM to ksfrogman
Yeah, I wish I had known how to do this a few months back. I was talking to someone who used to work for BMW as a service tech, and have the procedure written down at home. Sounds like what was suggested above.

Now I'm also curious to know if there's a similar way to reset the service due warning, so we don't have to spend hundreds of dollars just for routine unnecessary diagnostics.
__________________
Appreciate 0
      02-05-2009, 10:38 PM   #10
ksfrogman
Major General
ksfrogman's Avatar
United_States
154
Rep
6,751
Posts

 
Drives: E90 330i 6MT
Join Date: Nov 2005
Location: Torrance, CA

iTrader: (12)

Garage List
2006 330i  [0.00]
2006 330i  [0.00]
Send a message via AIM to ksfrogman
Here's the dialog I had on AIM with a former BMW Tech. I just changed his name...

Tech: get in driver's seat, shut the door, and insert the key... don't start the engine... then press and hold the trip reset button on the cluster. as you hold it, it should bring up a 'service' triangle... when that happens, press and hold again.
Tech: this SHOULD (operative word) bring you into the services reset menu.... each press of the button should now change the picture on the cluster... things like an oil lamp, a picture of a radiator, the brake pad warning symbol, etc...
Tech: anything that is overdue will show red. services coming due will show yellow. services NOT due are green
Tech: when you find the 'rear brakes' symbol, press and hold again. it will come up with a 'reset?' press and hold again.... it should reset at this time.
Tech: now here's the rub
Tech: instead of resetting, occasionally it will bug. it will begin to show your brakes as 25,000 or so miles overdue.
Tech: the only fix you'll be able to do, is try to reset it a few more times. if it still doesn't work, drive around the block and try again. if it STILL doesn't go... then you must go to the dealer and they'll have to hook up
Ksfrogman: so what the dealer does is slightly different?
Tech: no
Tech: but they have an option you don't, by hooking up the diag tool (which has been upgraded since I left, so I don't even know what it is)
__________________
Appreciate 0
      01-16-2010, 06:27 PM   #11
gary01502
Registered
0
Rep
1
Posts

 
Drives: bmw 325td
Join Date: Jan 2010
Location: uk

iTrader: (0)

brake pad light reset

when changing brake pads you have to change pad sensor as well, this is due to
the cluster stores your old pad senosr in it`s memory and though you chaned your pads it still thinks you have the old set in as it has not seen a change in the pad sensor.
once reset brake pad change, it will default at 6,000 miles then change once driven a few miles.
hopes this helps. took a long time to find this out.
Appreciate 0
      02-05-2010, 04:56 PM   #12
badass1g
Captain
badass1g's Avatar
13
Rep
646
Posts

 
Drives: 07 335i
Join Date: Oct 2009
Location: utah

iTrader: (7)

Sorry to revive such an old thread but i tried this, i reset every option available and the red brake light is still on. The brakes cannot be bad i can see TONS of pad left and car only has 13k miles. I dont want to have to take of my jb3 and buy a scan tool just to clear any possible tuner codes just to drive an hour to have the dealer just reset it. UGH this is frustrating. Anybody have the same problem i am having?
Appreciate 0
      02-05-2010, 10:50 PM   #13
badass1g
Captain
badass1g's Avatar
13
Rep
646
Posts

 
Drives: 07 335i
Join Date: Oct 2009
Location: utah

iTrader: (7)

nevermind i went out to drive it to work and the light was gone. thanks
Appreciate 0
      03-18-2010, 04:44 PM   #14
lamia2super
Colonel
lamia2super's Avatar
United_States
42
Rep
2,500
Posts

 
Drives: 335i
Join Date: May 2008
Location: Miami Beach, FL

iTrader: (4)

Garage List
2007 335i  [5.00]
Send a message via AIM to lamia2super
I have a similar situation, but in my case when I reset the brakes it work, but then I went back the a day later and held the reset button again and now it doesnt show me the mileage and is lit up in yellow

look

Last edited by lamia2super; 03-18-2010 at 04:56 PM.
Appreciate 0
      05-07-2010, 07:57 PM   #15
bmw6953
Second Lieutenant
6
Rep
257
Posts

 
Drives: 2006 325i
Join Date: Oct 2008
Location: california

iTrader: (0)

Quote:
Originally Posted by gary01502 View Post
when changing brake pads you have to change pad sensor as well, this is due to
the cluster stores your old pad senosr in it`s memory and though you chaned your pads it still thinks you have the old set in as it has not seen a change in the pad sensor.
once reset brake pad change, it will default at 6,000 miles then change once driven a few miles.
hopes this helps. took a long time to find this out.
Correct the reset wont work unless you actually service the car and replace the brake sensor or sensor/brakes.
Appreciate 0
      05-22-2010, 12:56 PM   #16
Jorge Leal
Registered
0
Rep
3
Posts

 
Drives: 325I
Join Date: May 2010
Location: Monterrey, MX

iTrader: (0)

I have the same issue as lamia2super, it doesnt show me the mileage and is lit up in yellow
Appreciate 0
      05-22-2010, 12:57 PM   #17
Jorge Leal
Registered
0
Rep
3
Posts

 
Drives: 325I
Join Date: May 2010
Location: Monterrey, MX

iTrader: (0)

did you find any solution?

Quote:
Originally Posted by lamia2super View Post
I have a similar situation, but in my case when I reset the brakes it work, but then I went back the a day later and held the reset button again and now it doesnt show me the mileage and is lit up in yellow

look
did you find any solution?
Appreciate 0
      05-22-2010, 12:58 PM   #18
Jorge Leal
Registered
0
Rep
3
Posts

 
Drives: 325I
Join Date: May 2010
Location: Monterrey, MX

iTrader: (0)

did you find any solution?
Appreciate 0
      05-23-2010, 12:00 PM   #19
bkeath
Registered
0
Rep
1
Posts

 
Drives: 2006 330i
Join Date: Aug 2009
Location: NC

iTrader: (0)

When the brake pad warning light is reset it will show up in yellow...when it is red that means service is needed
Appreciate 0
      06-04-2010, 01:59 PM   #20
Midas78
Private
0
Rep
71
Posts

 
Drives: 2007 335i
Join Date: May 2010
Location: Melbourne, Fl

iTrader: (1)

I'm also getting the service brake light with no mileage, I took it to the local dealership, scanned the key and the service message says the brakes are 372K miles past due. I'm at 51K miles now and they were all serviced at 31K miles. The dealership offered to investigate this for $115.

I tried the reset steps listed above a few times, with no immediate changes, maybe this afternoon when I drive home from work it'll be off.

BTW - I also got a quote (if they actually need to be replaced) of $620 for the front brakes to be serviced and $620 for the rears.
Appreciate 0
      06-05-2010, 11:32 PM   #21
bimmernoob
Private First Class
bimmernoob's Avatar
2
Rep
102
Posts

 
Drives: 2006 330i 6MT
Join Date: Apr 2010
Location: So. Cal

iTrader: (0)

^

Don't know if you guys are still looking for answers for the yellow service brake light w/o mileage. I just changed my brakes today (rear) and ran into this problem. Basically I replaced my rear pads w/o replacing the sensor, and then reset the yellow service brake light (which at the time still had about 1000 miles on it). After resetting it, the yellow brake service light remain lit but w/o mileage. Furthermore, I got the car on the red car on the lift light along with the red service light.

The good thing is that I have a rear sensor handy, but originally I decided not to change it to see if I could get away with it since it was not triggered. So I took out the old sensor and replaced with the new one. After that, I reset the yellow service brake light, and it registered 30,000 miles. And after a while the red car on the lift light and the red brake light was also cleared.

So... the moral of the story is that one must always replace the sensor with the pads. I know that there are plenty of posts that says this... but I guess I just have to learn it the hard way. Also I find the BC brake service indicator to be pretty useless. I took the pads out and they still had quit a bit of life in them... I think next time I am just going to wait until the brake sensor get's tripped, since they have to be replaced anyways regardless if they are tripped or not.

Last edited by bimmernoob; 06-07-2010 at 11:58 AM.
Appreciate 0
      06-06-2010, 01:11 PM   #22
blackbeast06
adrenergic stimulation
blackbeast06's Avatar
United_States
6
Rep
321
Posts

 
Drives: 2007 E92 335i
Join Date: Dec 2009
Location: Akron

iTrader: (4)

Garage List
2006 325i  [0.00]
i just tried the reset on my car after installing new rear pads, rotors and sensor. i stuck the key in the ignition with foot off of the clutch and pressed the start button once. then i held the odo reset button until the yello abs light came on. then i held the bc button on the turn signal stalk. the word reset appeared and i let go of all buttons and pressed the bc button and held it. a clock appeared next to the word reset and made an animation of the clock hand moving. after this the red brake light is still on on my car. i am going to have to wait to see if it goes off after i drive it around later.
__________________
07 335i. Montego Blue/Saddle Brown. 6 MT.

[IMG]
bm insta by senntera, on Flickr[/IMG]
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:11 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST