E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Intake problems?



Reply
 
Thread Tools Search this Thread
      01-28-2010, 08:11 PM   #1
shane_lee70
New Member
 
Drives: 2006 325i
Join Date: Jul 2009
Location: SD

Posts: 8
iTrader: (0)

Intake problems?

I have a 2006 325i and I just installed a AFE intake. Im having a little bit of lag when I punch it at around 3k rpm's. Does anybody know what this could be from?
shane_lee70 is offline  
0
Reply With Quote
      01-28-2010, 08:28 PM   #2
Kroy
Brigadier General
 
Kroy's Avatar
 
Drives: E90
Join Date: Jul 2009
Location: Los Angeles, CA

Posts: 3,035
iTrader: (1)

Quote:
Originally Posted by shane_lee70 View Post
I have a 2006 325i and I just installed a AFE intake. Im having a little bit of lag when I punch it at around 3k rpm's. Does anybody know what this could be from?
try checking to see if everything is loose. also is the filter dirty?
Kroy is offline   United_States
0
Reply With Quote
      01-29-2010, 01:52 PM   #3
SV Concepts II
 
SV Concepts II's Avatar
 
Drives: E90 M3
Join Date: Dec 2008
Location: 1460 White Oaks Rd. Suite F Campbell, CA 95008

Posts: 6,095
iTrader: (7)

Double check for vacuum leaks on the hoses...

did you experience this lag before you installed the intake?
SV Concepts II is offline   United_States
0
Reply With Quote
      01-29-2010, 02:26 PM   #4
teemuturunen
New Member
 
Drives: BMW 335DAT INDIVIDUAL C3
Join Date: Jan 2010
Location: Finland

Posts: 20
iTrader: (0)

Garage List
2007 335d  [0.00]
reset your DME airmass and quantity adaptation values
teemuturunen is offline   Finland
0
Reply With Quote
      02-05-2010, 04:53 PM   #5
shane_lee70
New Member
 
Drives: 2006 325i
Join Date: Jul 2009
Location: SD

Posts: 8
iTrader: (0)

I did not experience these problems before the intake and it is now throwing a P0170 fuel trim bank 1 rich code. Im going to take it apart and check to make sure there are no leaks for the 3rd time.

How do I reset my DME airmass and quantity adaptation values?
shane_lee70 is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
325i, e90, intake, issue, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST