E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > jb3 install need hep!!!



Reply
 
Thread Tools Search this Thread
      03-25-2010, 06:17 PM   #1
Dom the Bomb
Lieutenant
 
Dom the Bomb's Avatar
 
Drives: 2007 335i
Join Date: Mar 2010
Location: Corpus Christi, Texas

Posts: 467
iTrader: (18)

just finished installing it. the check light suppose to come on??
Dom the Bomb is offline  
0
Reply With Quote
      03-25-2010, 06:24 PM   #2
jonerik26
Lieutenant Colonel
 
jonerik26's Avatar
 
Drives: black 335i e90 PRE-LCI
Join Date: Apr 2006
Location: somewhere

Posts: 1,868
iTrader: (21)

Garage List
2007 335i  [4.00]
1998 Acura Integra  [4.25]
2006 325i  [4.00]
nope, pin out or pnp... either way check installation
__________________
jonerik26 is offline   Philippines
0
Reply With Quote
      03-25-2010, 06:25 PM   #3
Dom the Bomb
Lieutenant
 
Dom the Bomb's Avatar
 
Drives: 2007 335i
Join Date: Mar 2010
Location: Corpus Christi, Texas

Posts: 467
iTrader: (18)

its pnp so no check engine light should be on?
Dom the Bomb is offline  
0
Reply With Quote
      03-25-2010, 06:26 PM   #4
oner
Second Lieutenant
 
oner's Avatar
 
Drives: BMW
Join Date: Jul 2009
Location: Earth

Posts: 214
iTrader: (0)

Quote:
Originally Posted by Dom the Bomb View Post
its pnp so no check engine light should be on?
No. Try start the car. you might need to check if you bent any pins or if the connectors are in the right slots.
oner is offline  
0
Reply With Quote
      03-25-2010, 06:27 PM   #5
BoostedCosta
SUPERMAN
 
BoostedCosta's Avatar
 
Drives: AW e90 335i M-Sport
Join Date: Jul 2008
Location: nj

Posts: 3,174
iTrader: (6)

Send a message via AIM to BoostedCosta
how do u fuck up a pnp install? lol
__________________
MODS: JB3 18ohm | AR Design Catlles Downpipes | CDV Delete | Clutch Masters FX400 | ZEX Nitrous Kit | Devils Own Methonal Kit | VMR V701 (Matte Black) | H&r Race Springs| BMW Perf Grilles|
BoostedCosta is offline  
0
Reply With Quote
      03-25-2010, 06:28 PM   #6
Dom the Bomb
Lieutenant
 
Dom the Bomb's Avatar
 
Drives: 2007 335i
Join Date: Mar 2010
Location: Corpus Christi, Texas

Posts: 467
iTrader: (18)

car starts but the light turns on i messed up a few times at first but finally got it to turn on. would crank but wouldnt start. now it starts but light is on
Dom the Bomb is offline  
0
Reply With Quote
      03-25-2010, 06:29 PM   #7
jonerik26
Lieutenant Colonel
 
jonerik26's Avatar
 
Drives: black 335i e90 PRE-LCI
Join Date: Apr 2006
Location: somewhere

Posts: 1,868
iTrader: (21)

Garage List
2007 335i  [4.00]
1998 Acura Integra  [4.25]
2006 325i  [4.00]
yeah, no check engine... do you have a bt tool? either way it should be an issue with installation..
__________________
jonerik26 is offline   Philippines
0
Reply With Quote
      03-25-2010, 06:30 PM   #8
BoostedCosta
SUPERMAN
 
BoostedCosta's Avatar
 
Drives: AW e90 335i M-Sport
Join Date: Jul 2008
Location: nj

Posts: 3,174
iTrader: (6)

Send a message via AIM to BoostedCosta
Quote:
Originally Posted by Dom the Bomb View Post
car starts but the light turns on i messed up a few times at first but finally got it to turn on. would crank but wouldnt start. now it starts but light is on
oh maybe u installed it right this time but since u didnt install it correctly the other times it prob gave it s SES light. turn your car on and off and drive it a lot the light should come off, if it doesnt u should reinstall it again and read the intructions
__________________
MODS: JB3 18ohm | AR Design Catlles Downpipes | CDV Delete | Clutch Masters FX400 | ZEX Nitrous Kit | Devils Own Methonal Kit | VMR V701 (Matte Black) | H&r Race Springs| BMW Perf Grilles|
BoostedCosta is offline  
0
Reply With Quote
      03-25-2010, 06:31 PM   #9
jonerik26
Lieutenant Colonel
 
jonerik26's Avatar
 
Drives: black 335i e90 PRE-LCI
Join Date: Apr 2006
Location: somewhere

Posts: 1,868
iTrader: (21)

Garage List
2007 335i  [4.00]
1998 Acura Integra  [4.25]
2006 325i  [4.00]
Quote:
Originally Posted by Dom the Bomb View Post
car starts but the light turns on i messed up a few times at first but finally got it to turn on. would crank but wouldnt start. now it starts but light is on
what do you mean messed up? hmmm, I would PM Mike and be specific about what happen he might be able to help you out, good luck!
__________________
jonerik26 is offline   Philippines
0
Reply With Quote
      03-25-2010, 06:43 PM   #10
zackday30
Captain
 
zackday30's Avatar
 
Drives: 06 Carrera S, Black on Black
Join Date: Feb 2008
Location: Tulsa

Posts: 613
iTrader: (1)

I've read about this before...apparently if you drive the car for a bit, the SES light will go off...I would try that first, then maybe think about a BT Tool. Good Luck!
__________________
My Garage:
'13 F30 328i (Wifey)
'11 Silverado CC (DD)
'06 Carrera S (Fun)
Sold: 08 E92 335, 07 X5
zackday30 is offline   United_States
0
Reply With Quote
      03-25-2010, 06:48 PM   #11
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,583
iTrader: (86)

Follow the troubleshooting guide at the bottom of the install PDF. If you can't figure it out email me some photos of the install and I'll help you determine what is wrong.

Mike
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      03-25-2010, 07:16 PM   #12
Dom the Bomb
Lieutenant
 
Dom the Bomb's Avatar
 
Drives: 2007 335i
Join Date: Mar 2010
Location: Corpus Christi, Texas

Posts: 467
iTrader: (18)

check light was on cause hood was open dumb a** me
Dom the Bomb is offline  
0
Reply With Quote
      03-25-2010, 07:36 PM   #13
Drakos
Lieutenant
 
Drakos's Avatar
 
Drives: 09 335xi E90/13 X5 35i M Sport
Join Date: May 2009
Location: Canada

Posts: 513
iTrader: (1)

Quote:
Originally Posted by Dom the Bomb View Post
check light was on cause hood was open dumb a** me
ROFL!!! Enjoy the JB3, it is a fantastic tune. Would suggest a BT scan tool though. You always run the risk of triggering a code.
__________________
Cobb S2+ | AR DP | Helix FMIC | BMS DCI | Forge DV | ER UCP | KW V1 | BMW Performance Exhaust | P3 DBG |
Drakos is offline  
0
Reply With Quote
      03-25-2010, 07:38 PM   #14
roozie2001
Just some guy
 
roozie2001's Avatar
 
Drives: 2008 White 335i sedan
Join Date: Apr 2008
Location: Houston, TX

Posts: 1,529
iTrader: (4)

yah i know exactly what u did. i did it too. Forgot to plug one piece in and cranked it and all the lights came on. Then when i hooked it in right it cranked just fine. After i drove it for a few miles and did some WOTs. The light went off.
__________________
2008 BMW 335i/Sedan/Alpine White/Terra/Steptronic/Premium Package/Sports package/Comfort Access/USB/Sirius
roozie2001 is offline   United_States
0
Reply With Quote
      03-25-2010, 07:49 PM   #15
roozie2001
Just some guy
 
roozie2001's Avatar
 
Drives: 2008 White 335i sedan
Join Date: Apr 2008
Location: Houston, TX

Posts: 1,529
iTrader: (4)

yah i know exactly what u did. i did it too. Forgot to plug one piece in and cranked it and all the lights came on. Then when i hooked it in right it cranked just fine. After i drove it for a few miles and did some WOTs. The light went off.
__________________
2008 BMW 335i/Sedan/Alpine White/Terra/Steptronic/Premium Package/Sports package/Comfort Access/USB/Sirius
roozie2001 is offline   United_States
0
Reply With Quote
      03-25-2010, 07:49 PM   #16
roozie2001
Just some guy
 
roozie2001's Avatar
 
Drives: 2008 White 335i sedan
Join Date: Apr 2008
Location: Houston, TX

Posts: 1,529
iTrader: (4)

yah i know exactly what u did. i did it too. Forgot to plug one piece in and cranked it and all the lights came on. Then when i hooked it in right it cranked just fine. After i drove it for a few miles and did some WOTs. The light went off
__________________
2008 BMW 335i/Sedan/Alpine White/Terra/Steptronic/Premium Package/Sports package/Comfort Access/USB/Sirius
roozie2001 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST