E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > exhaust vanos help!



Reply
 
Thread Tools Search this Thread
      09-18-2009, 02:46 PM   #1
Elie335
ايلي ٣٣٥ هاهاها
Elie335's Avatar
St Pierre and Miquelon
27
Rep
1,446
Posts

 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

iTrader: (1)

exhaust vanos help!

hey guys;
everytime getting the limp mode and scanning my car with the GT1 getting the code " 2A87 VANOS exhaust- stiff, jammed mechanically " it happens only when i drive with high speed and suddenly pushing the brakes, i get the half engine light popped up.... the worst part is that i got the exhaust vanos part changed, i changed many oil types and markets and still nothing changed, chain tension is exact, oil level is ok, both solenoid was replaced, Cam sensor is ok, i did everything related with the exhaust vanos repair troubleshooting, and i keep getting the vanos exhaust error on the GT1.... i was reading arround and there was a thread about rare camshaft issues can cause this, so i was wondering if this was my case
Quote:
Originally Posted by 1clean335i
if its the cam problem im thinking of, its only the cam bearing ledges/caps. the end seals toward the front of the vehicle wear a groove into the cam ledges and causes vanos faults for either intake or ex. its just the cam ledges/caps that get replaced, not the actual camshaft... that is unless there is another issue which i do not know of
any help guys?
Appreciate 0
      09-19-2009, 01:20 AM   #2
Elie335
ايلي ٣٣٥ هاهاها
Elie335's Avatar
St Pierre and Miquelon
27
Rep
1,446
Posts

 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

iTrader: (1)

anyone please?
Appreciate 0
      10-09-2009, 09:23 PM   #3
kanecvl
Lieutenant
kanecvl's Avatar
United_States
7
Rep
552
Posts

 
Drives: 07 335i coupe
Join Date: Aug 2009
Location: IL

iTrader: (6)

Im having the same exact problem. When I hear somethin i'll let you know.
Appreciate 0
      10-12-2009, 12:45 AM   #4
CJCIII
Private
1
Rep
59
Posts

 
Drives: E90 335I
Join Date: Apr 2008
Location: Dallas

iTrader: (2)

I was having a similar issue, but I would limp when I let out of it. A few other symptoms that I noticed were rough idle, loss of power at lower RPM's (below 3K), and poor fuel economy.

I took the car into BMW and told them my symptoms. They first changed the exhaust VANOS. I picked up the car, and before I got home car limped. Took the car back and they changed out the cam shaft (worn ledges).

Good Luck!!
Appreciate 0
      03-27-2010, 09:27 AM   #5
kanecvl
Lieutenant
kanecvl's Avatar
United_States
7
Rep
552
Posts

 
Drives: 07 335i coupe
Join Date: Aug 2009
Location: IL

iTrader: (6)

Thread revival

I finally had a chance to get that fault fixed and it end up being the solenoid. That was out of pocket cause I have no warranty. A lil bit over $400 was the price. So far no problems or codes
Appreciate 0
      04-04-2010, 04:56 PM   #6
kiteboy
First Lieutenant
kiteboy's Avatar
France
4
Rep
377
Posts

 
Drives: E92 Stage 2 BR Performance
Join Date: Apr 2010
Location: France

iTrader: (0)

Send a message via MSN to kiteboy
hello, i'm from france and i've got the same pb that Elie335.

is that ok if we change solenoid ??????
Appreciate 0
      04-04-2010, 07:23 PM   #7
kanecvl
Lieutenant
kanecvl's Avatar
United_States
7
Rep
552
Posts

 
Drives: 07 335i coupe
Join Date: Aug 2009
Location: IL

iTrader: (6)

its not a certain fix but seems to be very common.
__________________
Appreciate 0
      04-05-2010, 03:52 PM   #8
kiteboy
First Lieutenant
kiteboy's Avatar
France
4
Rep
377
Posts

 
Drives: E92 Stage 2 BR Performance
Join Date: Apr 2010
Location: France

iTrader: (0)

Send a message via MSN to kiteboy
Kanecyl , what do you mean ? if i replace both solenoid it's no sure that solve my problem ??
Appreciate 0
      04-05-2010, 04:29 PM   #9
Blk07335i
Captain
Blk07335i's Avatar
United_States
16
Rep
919
Posts

 
Drives: 2012 Alpine White e93 Msport
Join Date: Mar 2007
Location: Orange County

iTrader: (4)

Send a message via AIM to Blk07335i
Had the same issue. take it in to the dealer and they will either clean it or replace it. Easy fix. No other option.
Appreciate 0
      04-05-2010, 05:07 PM   #10
kanecvl
Lieutenant
kanecvl's Avatar
United_States
7
Rep
552
Posts

 
Drives: 07 335i coupe
Join Date: Aug 2009
Location: IL

iTrader: (6)

Quote:
Originally Posted by kiteboy View Post
Kanecyl , what do you mean ? if i replace both solenoid it's no sure that solve my problem ??
According to the dealer it could be a vanos problem,(less likely), it could be software problem(less likely) or it could be a camshaft problem(even more less likely. The solenoid is the most common. They have a way of testing it. It cost me 400 for them to do it I'm out of warranty
__________________
Appreciate 0
      04-05-2010, 05:25 PM   #11
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
269
Rep
8,626
Posts

 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by kanecvl View Post
According to the dealer it could be a vanos problem,(less likely), it could be software problem(less likely) or it could be a camshaft problem(even more less likely. The solenoid is the most common. They have a way of testing it. It cost me 400 for them to do it I'm out of warranty
Are you talking about the solenoid that controls the wastegates?
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      04-05-2010, 05:31 PM   #12
Blk07335i
Captain
Blk07335i's Avatar
United_States
16
Rep
919
Posts

 
Drives: 2012 Alpine White e93 Msport
Join Date: Mar 2007
Location: Orange County

iTrader: (4)

Send a message via AIM to Blk07335i
No he's talking about the vanos solenoid. There are two...one for the intake and one for the exhaust. There have been a large number of problems with them getting stuck or jammed. They usually clean and swap them to see if the problem persists or switches to the other solenoid.
Appreciate 0
      04-05-2010, 06:03 PM   #13
kanecvl
Lieutenant
kanecvl's Avatar
United_States
7
Rep
552
Posts

 
Drives: 07 335i coupe
Join Date: Aug 2009
Location: IL

iTrader: (6)

Quote:
Originally Posted by Blk07335i View Post
No he's talking about the vanos solenoid. There are two...one for the intake and one for the exhaust. There have been a large number of problems with them getting stuck or jammed. They usually clean and swap them to see if the problem persists or switches to the other solenoid.
+1 that is the usual. Thats exactly what they did for mine
__________________
Appreciate 0
      04-06-2010, 01:34 AM   #14
kiteboy
First Lieutenant
kiteboy's Avatar
France
4
Rep
377
Posts

 
Drives: E92 Stage 2 BR Performance
Join Date: Apr 2010
Location: France

iTrader: (0)

Send a message via MSN to kiteboy
is that this on the front of motor ....just behind ventilator ?

which is front ans exhaut ? do you say ?
Attached Images
 
Appreciate 0
      04-06-2010, 08:03 AM   #15
kiteboy
First Lieutenant
kiteboy's Avatar
France
4
Rep
377
Posts

 
Drives: E92 Stage 2 BR Performance
Join Date: Apr 2010
Location: France

iTrader: (0)

Send a message via MSN to kiteboy
this morning i swap and clean solenoids... i raz the fault code...

now waiting and see , and if now i've got 2A82 instead of 2A87, the solenoid will be replaced.....
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:20 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST