E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Stuttering, Misfiring, Stumbling--Fixed!



Reply
 
Thread Tools Search this Thread
      05-13-2010, 08:21 PM   #1
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
270
Rep
8,626
Posts

 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Stuttering, Misfiring, Stumbling--Fixed!

I went to the dealer a while back and they flashed my car with the newest software. I drove away from the dealer on the stock software and my car started to run really rough. It even threw misfire codes. I pulled over, restarted my car and everything was fine. At first, I thought it was the meth spraying with my stock software but once it started happening more and more, I realized that it had nothing to do with meth.

This usually happened in the middle of being cold and hot but more on the cold side. For example, I would start the car and it would run fine. I would drive away going through the residnetial section so keeping it in 2nd gear cruising. I'll pull up to a stop sign and stop and the engine is running fine. I then accelerate from the stop sign and that's when the sputtering would happen. I'd be like WTF? I would either shut the car off or just hit the accelerator pedal a couple times to try to snap my car out of it and then it would be fine.
If my car was completely hot, I wouldn't experience anything like this. It was only the warm up phase.

This was starting to happen every other day so I wanted to see if there was anything that I could do.
I opened up the BT software and went to the "Commands" section under the Engine tab.
With my engine warmed up and running, I reset the following:

-Air Control Adjustment
-Throttle Valve Adaptation
-Fuel/Air Adaptation
-Secondary Air Injection Adaptation

I did this May 2nd and haven't had any sputtering or anything since. I'm not saying that if you guys are having this issue then this will take care of all your problems, but I'm just saying that it may just work. In my case, all I needed was either one thing reset or a couple things reset.
I'm curious with how many perfectly fine fuel pumps the dealers replaced

If you guys decide to do this then I take absolutely no responsibility with whatever you guys do to your car. What you decide to do with your car is at your own risk.
Attached Images
 
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      05-13-2010, 08:36 PM   #2
onesuperboi
Major
onesuperboi's Avatar
United_States
21
Rep
1,343
Posts

 
Drives: '08 e92 335i COBB 4.01 Stage 1
Join Date: Aug 2008
Location: Bay Area, CA (Alameda)

iTrader: (6)

I thought you were going to say that your fix was switching to another tune.

That's is very interesting with resetting the values using BT. I guess other people that have misfiring codes should try that out as a last resort and see if that could be a fix instead of trying to replace the plugs and coils all the time.
Appreciate 0
      05-13-2010, 08:39 PM   #3
John 070
Lieutenant General
157
Rep
11,514
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

I did a google search on the msd81, and it says it can detect tunes?

http://wiki.bavariantechnic.com/inde...mens_MSD80_DME
Appreciate 0
      05-13-2010, 08:41 PM   #4
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
270
Rep
8,626
Posts

 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by onesuperboi View Post
I thought you were going to say that your fix was switching to another tune.

That's is very interesting with resetting the values using BT. I guess other people that have misfiring codes should try that out as a last resort and see if that could be a fix instead of trying to replace the plugs and coils all the time.
Seriously huh? I was amazed that it worked so well.
There's a spot by my work where it stuttered almost every day.
Once I reset those parameters, it hasn't happened since.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      05-13-2010, 08:49 PM   #5
onesuperboi
Major
onesuperboi's Avatar
United_States
21
Rep
1,343
Posts

 
Drives: '08 e92 335i COBB 4.01 Stage 1
Join Date: Aug 2008
Location: Bay Area, CA (Alameda)

iTrader: (6)

Quote:
Originally Posted by Mr. 5 View Post
Seriously huh? I was amazed that it worked so well.
There's a spot by my work where it stuttered almost every day.
Once I reset those parameters, it hasn't happened since.
I guess it's just like rebooting a computer.

Sometimes, regardless of how many programs you terminate or ram you free, all it might take is just a clean reboot and the OS will run smoother.
Appreciate 0
      05-13-2010, 08:50 PM   #6
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Caveat with the Throttle Valve Adaptation....

I did this once and I am not if the car needed to be cycled on and off, but when I started the car, the car was reving up and down rapidly. Totally freaked me out, I shut off the car, let it sit until the ECU went into sleep mode, then re-did the adaptation, shut off the car again and restarted and everything was fine afterwards.

Just be careful with that one parameter and don't worry as you didn't break the car
Appreciate 0
      05-13-2010, 08:54 PM   #7
lawwailok
Lieutenant Colonel
lawwailok's Avatar
United_States
34
Rep
1,923
Posts

 
Drives: E90 335i, E70 X5
Join Date: Aug 2009
Location: Sacramento, CA

iTrader: (18)

Garage List
Mr. 5, did you reset all those values when the engine is still running? if so, how's the car's activity during the reset procedure, just like normal idling?
__________________
-eric
E90 335i TiAg *STOCK* see my garage for mod list..
E70 X5 SGM *try to stay stock* :/
Appreciate 0
      05-13-2010, 08:58 PM   #8
UAP1
www.UltimateAutoPortal.co m
UAP1's Avatar
United_States
12
Rep
556
Posts

 
Drives: 2007 BMW 335i. Few mods.
Join Date: Mar 2010
Location: Texas

iTrader: (3)

Great info!
Appreciate 0
      05-13-2010, 09:00 PM   #9
Dr_Dirt
Major
Dr_Dirt's Avatar
United_States
19
Rep
1,475
Posts

 
Drives: E90 335i 6AT
Join Date: Apr 2007
Location: DFW

iTrader: (1)

Why did you choose those specific settings to reset?
Tell us your thought process.
__________________
Verizon LTE speed
Appreciate 0
      05-13-2010, 09:03 PM   #10
R1000K3
Major
R1000K3's Avatar
United_States
16
Rep
1,313
Posts

 
Drives: 335i MT
Join Date: Jul 2009
Location: USA

iTrader: (0)

I had a similar issue earlier. The car could hesitate or sometimes even trigg a LIMP if I used a bit too much throttle (non aggressive) during the end of the warm-up phase as Mr. 5 has encountered problems. After installing hard O2-sims and resetting the Lambda adaptation the problem has disappeared completely.
Appreciate 0
      05-13-2010, 10:13 PM   #11
dzenno
Banned
Canada
114
Rep
5,883
Posts

 
Drives:
Join Date: Feb 2006

iTrader: (1)

Quote:
Originally Posted by joec500 View Post
Caveat with the Throttle Valve Adaptation....

I did this once and I am not if the car needed to be cycled on and off, but when I started the car, the car was reving up and down rapidly. Totally freaked me out, I shut off the car, let it sit until the ECU went into sleep mode, then re-did the adaptation, shut off the car again and restarted and everything was fine afterwards.

Just be careful with that one parameter and don't worry as you didn't break the car
+10000000000 happened here too
Appreciate 0
      05-13-2010, 10:31 PM   #12
Kelvin1000
Major
United_States
29
Rep
1,190
Posts

 
Drives: 2008 E92 335i Space Gray
Join Date: Sep 2007
Location: Miami, FL

iTrader: (4)

Quote:
Originally Posted by joec500 View Post
Caveat with the Throttle Valve Adaptation....

I did this once and I am not if the car needed to be cycled on and off, but when I started the car, the car was reving up and down rapidly. Totally freaked me out, I shut off the car, let it sit until the ECU went into sleep mode, then re-did the adaptation, shut off the car again and restarted and everything was fine afterwards.

Just be careful with that one parameter and don't worry as you didn't break the car
I still have stains in the seat from when I did this as well...
Appreciate 0
      05-13-2010, 10:31 PM   #13
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
246
Rep
18,404
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Ive reset almost all of those things many times.

Sometimes my car freaks out though and I need to end up reseting again.

Specifically the throttle adaptation I reset, made my car go Bonkers! It would start revving on its own LOL. Throwing codes left and right.

Finally I reset it again and everything was fine.

edit looks like some other people did the same thing LOL
Appreciate 0
      05-14-2010, 02:46 AM   #14
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

Great info Mr5!
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
Appreciate 0
      05-14-2010, 09:09 AM   #15
fast4door
Captain
fast4door's Avatar
16
Rep
802
Posts

 
Drives: E60 M5
Join Date: Sep 2009
Location: Davie, FL

iTrader: (3)

I was having similar issues..I reset Lambda adaptation and Air/Fuel adaptaion and that seemed to work for me..good info Mr.5
Appreciate 0
      05-14-2010, 09:15 AM   #16
uberschnell
Brigadier General
uberschnell's Avatar
No_Country
71
Rep
3,424
Posts

 
Drives: // 135i //, X5
Join Date: Mar 2007
Location: Bay Area

iTrader: (44)

I can see how software alone can do this. Since the install of stage 1 my rough idle is gone, no other mods or changes.
Appreciate 0
      05-14-2010, 09:17 AM   #17
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
270
Rep
8,626
Posts

 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by joec500 View Post
Caveat with the Throttle Valve Adaptation....

I did this once and I am not if the car needed to be cycled on and off, but when I started the car, the car was reving up and down rapidly. Totally freaked me out, I shut off the car, let it sit until the ECU went into sleep mode, then re-did the adaptation, shut off the car again and restarted and everything was fine afterwards.

Just be careful with that one parameter and don't worry as you didn't break the car
This is why I said to do it with the engine running.
I actually did the same thing. The key was on and I reset it without the engine on and did exactly as you said.
On the laptop in the lower left hand side of the screen, it will say resetting and let you know when it's finished.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      05-14-2010, 05:15 PM   #18
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
270
Rep
8,626
Posts

 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by JPSlick View Post
Ive reset almost all of those things many times.

Sometimes my car freaks out though and I need to end up reseting again.

Specifically the throttle adaptation I reset, made my car go Bonkers! It would start revving on its own LOL. Throwing codes left and right.

Finally I reset it again and everything was fine.

edit looks like some other people did the same thing LOL
I was always curious with when to reset things but I've never got the true answer.
The question that I always had is, "When resetting things, should the engine be off or on?"
People are quick to say that the engine should be off but there's nothing to back up the statement.

When I reset these devices, the engine was on and everything reset perfectly fine.
Now, I can see how resetting the ECU with the engine running probably wouldn't be the best thing to do, but when talking about air/fuel and throttle plates I don't see how it could have been a bad thing.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      05-14-2010, 07:31 PM   #19
Kroy
Brigadier General
Kroy's Avatar
United_States
39
Rep
3,035
Posts

 
Drives: E90
Join Date: Jul 2009
Location: Los Angeles, CA

iTrader: (1)

Thanks for the info. I'm sure this'll help some people in the near future.
Appreciate 0
      05-14-2010, 07:42 PM   #20
BuLoOoSki
Major
BuLoOoSki's Avatar
United_States
18
Rep
1,054
Posts

 
Drives: 2015 BMW M3
Join Date: Oct 2007
Location: Nashville, TN

iTrader: (8)

just an advice, be careful when trying to reset air control adjustment
i did that a while back and posted a thread about it. for some vehicles it may trigger a transmission malfunction code, and this code is a PAIN to get rid of. it puts the transmission in safety mode. it took me four days to figure it out with Duram@BT. he had to create a new BT software to enable a new function just to fix this problem. just read my thread for instructions.
__________________
2015 BMW M3: Mineral White / SO Full Leather / Executive Pkg / Lighting Pkg / 19" Black Wheels / Adaptive Suspension / Double-Clutch Transmission / Harman Kardon
2007 BMW 335i Coupe (SOLD): BMS JB3 / Quaife LSD / RR Catless DPs / Helix Intercooler / VK Motorwerks Oil Cooler / AFE Intake / STETT Charge Pipe / Forge DVs
Appreciate 0
      05-14-2010, 08:28 PM   #21
Mr. 335xi
New Member
0
Rep
9
Posts

 
Drives: 335xi
Join Date: Apr 2010
Location: Montreal

iTrader: (0)

Can we reset these functions with the procede canbus?
Appreciate 0
      05-14-2010, 09:29 PM   #22
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
270
Rep
8,626
Posts

 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by BuLoOoSki View Post
just an advice, be careful when trying to reset air control adjustment
i did that a while back and posted a thread about it. for some vehicles it may trigger a transmission malfunction code, and this code is a PAIN to get rid of. it puts the transmission in safety mode. it took me four days to figure it out with Duram@BT. he had to create a new BT software to enable a new function just to fix this problem. just read my thread for instructions.
That's good to know.
I was curious about that icon because that's what it said when I clicked it.
I have a manual so I didn't have to worry about it.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:03 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST