E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Africa > Audio Installation on 2007 320i



Reply
 
Thread Tools Search this Thread
      07-05-2010, 03:20 AM   #1
ZA320i
New Member
South Africa
2
Rep
7
Posts

 
Drives: 320i
Join Date: Jul 2010
Location: Tshwane, South Africa

iTrader: (0)

Audio Installation on 2007 320i

Hey All...

I'm a newbie, so first off, "Hi" to everyone on the site. I just bought a pre-facelift 320i and I'm really keen to upgrade the audio. The car doesn't have i-Drive, and has the "Professional" stereo option. Also, it's a South African model, if that makes any difference.

What I'd like to do, is add a couple of subwoofers and an amp to drive them. I'd like to keep everything else, and retain my steering wheel controls. I'm sure it goes without saying, but while I'd like to do this myself, I don't want to do anything that damages the car in any way.

I'm totally open to suggestions, and would appreciate any guidance.

Thanks

ZA320i
Appreciate 0
      07-05-2010, 10:31 AM   #2
Menno11
Member
Menno11's Avatar
South Africa
11
Rep
261
Posts

 
Drives: 320d
Join Date: Sep 2008
Location: Cape Town

iTrader: (0)

Garage List
2005 320d  [0.00]
Send a message via Skype™ to Menno11
I did my system and this is what I did

http://www.e90post.com/forums/showthread.php?t=195939

http://www.e90post.com/forums/showthread.php?t=251282


also look at Mike's ride

http://www.speednsound.co.za/forum/v...6d966e6b541b79

I'm changing my setup now to include 2 x 12's but will post pics as soon as I complete my new box.

Good luck with your project!
Appreciate 0
      07-06-2010, 10:39 AM   #3
ZA320i
New Member
South Africa
2
Rep
7
Posts

 
Drives: 320i
Join Date: Jul 2010
Location: Tshwane, South Africa

iTrader: (0)

Quote:
Originally Posted by Menno11 View Post
I did my system and this is what I did

http://www.e90post.com/forums/showthread.php?t=195939

http://www.e90post.com/forums/showthread.php?t=251282


also look at Mike's ride

http://www.speednsound.co.za/forum/v...6d966e6b541b79

I'm changing my setup now to include 2 x 12's but will post pics as soon as I complete my new box.

Good luck with your project!
Hey Menno...

Again, thanks for all the information. To be completely honest though, I'm still a little lost. I've looked over the suggested information, but have a few questions:

1) My stereo's HU says "Professional". Does that imply a six speaker set up with no amp?

2) When you say "tap" into the 4-inch drivers in the rear, do you mean divert them completely? Does that render those speakers inoperative (An obvious "yes" if that's the case)? One of the threads you directed me to indicated that those speakers aren't fed the full spectrum. Will they work to feed an amp that powers a subwoofer?

3) Is there perhaps a step-by-step guide somewhere on these boards that could perhaps make the install a little easier, especially in terms of the wiring?

Again, I appreciate the feedback.

Thanks

ZA320i
Appreciate 0
      07-07-2010, 05:19 AM   #4
Menno11
Member
Menno11's Avatar
South Africa
11
Rep
261
Posts

 
Drives: 320d
Join Date: Sep 2008
Location: Cape Town

iTrader: (0)

Garage List
2005 320d  [0.00]
Send a message via Skype™ to Menno11
Hey bud, if your system is not Logic 7 in South Africa, it automatically means you dont have an amp and have the standard 6 speaker setup.

You can tap the signal without loosing the feed to the speakers. I initially had the LOC to the rear speakers and it worked well, but when I changed the feed to the signal from the underseat subs, I had to turn the gain on my amp down considerably!

The wiring is pretty simple if you have an average understanding of sound and follow the steps in the threads above.

1 - tap speaker level signal from underseat woofers
2 - convert to RCA signal through LOC
3 - plug RCA in amp
4 - run amplified signal to subwoofer
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:40 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST