E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Sunroof no longer working after installing EAS RemoteKey+



Reply
 
Thread Tools Search this Thread
      07-04-2010, 03:31 PM   #1
nemith
Second Lieutenant
 
Drives: 14 BMW 335xi M-Sport EBII
Join Date: Aug 2009
Location: Denver, CO

Posts: 204
iTrader: (1)

Garage List
Sunroof no longer working after installing EAS RemoteKey+

I have installed an EAS RemoteKey+ module mostly to emulate the alarm but it works wonders with the mirrors and windows but now I have a problem with the sunroof refusing to work properly

When i start the car I used to get (I think i still do) the error stating the sunroof pinch sensors are not functioning correctly.

When i go to use the sunroof it will move just a couple of inches and then stop and i have to keep hitting it. It won't do anything more than tilt up (vent) and open about 3" or so.

I have checked that everthing on the RemoteKey+ is working properly (except for the red flashing light but I will look more into that)

Any ideas of where to start? I didn't really untwist the CANBUS cables that much so I can't imagine that being it. Maybe I need to reset something?
nemith is offline  
0
Reply With Quote
      07-04-2010, 05:10 PM   #2
VP Electricity
BimmerPost Supporting Vendor

 
VP Electricity's Avatar
 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

Posts: 3,177
iTrader: (3)

I'm sure that even on a holiday like this, Tom will be along shortly. He's good like that.

I still have never installed mine, so I'm no help.
__________________
Musicar Northwest, Portland Oregon
The premier experts on BMW high-performance audio
Home of Tom Miller, 2014 Installer of the Year
Named a Top 12 Retailer in North America
musicarnw.com (please email, don't PM)

VP Electricity is offline   United_States
0
Reply With Quote
      07-04-2010, 06:58 PM   #3
VGR00
Major
 
VGR00's Avatar
 
Drives: 125I Edition Sport Carbon Blk
Join Date: Feb 2007
Location: Brisbane - Australia

Posts: 1,494
iTrader: (1)

Push and hold the sunroof button (for vent position) for about 30 sec. This resets the sunroof operation
VGR00 is offline   Australia
0
Reply With Quote
      07-04-2010, 07:24 PM   #4
nemith
Second Lieutenant
 
Drives: 14 BMW 335xi M-Sport EBII
Join Date: Aug 2009
Location: Denver, CO

Posts: 204
iTrader: (1)

Garage List
Well I answered my own question. I broke out the BT tool and started poking around. There is a calibration mode for the sunroof (and it looks like i could of done it by pressing 15 seconds on the "lift" button). Everything works fine (minus the flashing clown nose) which should be an easy fix. Just need to break out the multimeter
nemith is offline  
0
Reply With Quote
      07-04-2010, 09:37 PM   #5
Ron1n
Speed Demon
 
Ron1n's Avatar
 
Drives: '10 335d E90
Join Date: Oct 2009
Location: The 858

Posts: 3,248
iTrader: (4)

Garage List
2010 335d  [5.00]
Quote:
Originally Posted by nemith View Post
Well I answered my own question. I broke out the BT tool and started poking around. There is a calibration mode for the sunroof (and it looks like i could of done it by pressing 15 seconds on the "lift" button). Everything works fine (minus the flashing clown nose) which should be an easy fix. Just need to break out the multimeter
It's closer to 45 for a full reset, but this is correct. Push and hold, wait for it to open all the way, then close, and it should be good.
__________________
Ron1n is offline   United_States
0
Reply With Quote
      07-08-2010, 07:33 PM   #6
tom @ eas
BimmerPost Supporting Vendor

 
tom @ eas's Avatar
 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

Posts: 10,152
iTrader: (13)

Garage List
Quote:
Originally Posted by nemith View Post
Well I answered my own question. I broke out the BT tool and started poking around. There is a calibration mode for the sunroof (and it looks like i could of done it by pressing 15 seconds on the "lift" button). Everything works fine (minus the flashing clown nose) which should be an easy fix. Just need to break out the multimeter
Just stumbled on this thread - was your situation resolved?

Quote:
Originally Posted by VP Electricity View Post
I'm sure that even on a holiday like this, Tom will be along shortly. He's good like that.

I still have never installed mine, so I'm no help.
Thanks for the kind words, much appreciated.
__________________
tom @ eas is offline   United_States
0
Reply With Quote
      07-09-2010, 01:06 PM   #7
nemith
Second Lieutenant
 
Drives: 14 BMW 335xi M-Sport EBII
Join Date: Aug 2009
Location: Denver, CO

Posts: 204
iTrader: (1)

Garage List
Quote:
Originally Posted by tom @ eas View Post
Just stumbled on this thread - was your situation resolved?



Thanks for the kind words, much appreciated.

Yup everything works fine (except for the clown nose but i am guessing that is a bad vampire tap). Just needed to reset the sunroof.
nemith is offline  
0
Reply With Quote
      07-09-2010, 02:52 PM   #8
tom @ eas
BimmerPost Supporting Vendor

 
tom @ eas's Avatar
 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

Posts: 10,152
iTrader: (13)

Garage List
Quote:
Originally Posted by nemith View Post
Yup everything works fine (except for the clown nose but i am guessing that is a bad vampire tap). Just needed to reset the sunroof.
A multimeter will be your friend in this case. If you are unsure about the wiring, feel free to send a picture my way and I can take a look.
__________________
tom @ eas is offline   United_States
0
Reply With Quote
      07-19-2010, 02:51 PM   #9
levy01
BMW Fan
 
levy01's Avatar
 
Drives: '09 335i
Join Date: Jun 2005
Location: Miami

Posts: 14
iTrader: (0)

Quote:
Originally Posted by tom @ eas View Post
A multimeter will be your friend in this case. If you are unsure about the wiring, feel free to send a picture my way and I can take a look.
Hi Tom,

Just wondering if you guys plan on modifying the RemoteKey+ module to fix the 15 minute timing issue after BMW's changes with the latest cars ?
I understand this only applies to cars with CA correct ?

Thanks,
Rodolfo
levy01 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Tags
eas, remotekey, remotekey+, sunroof

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST