E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Need Help with 335is HK stereo



Reply
 
Thread Tools Search this Thread
      12-03-2010, 11:15 AM   #1
trusaleen1
Private
2
Rep
81
Posts

 
Drives: 2011 BMW 335iS Coupe
Join Date: Oct 2007
Location: Bay Area

iTrader: (0)

Need Help with 335is HK stereo

So my 335is is two weeks old. I used the setting optimize the L7. I also had these in my 2008 335i. These sounded great in the new my new 335is for about a week. Now all of a sudden the bass is really flat and seems really weak. It doesnt have the punch it use to and its had boomy instead of tight. I also had the bass at +1 now I have it at +4 and its still not as strong. Any suggestions?
Appreciate 0
      12-03-2010, 12:07 PM   #2
kmarei
Major General
kmarei's Avatar
Egypt
130
Rep
6,481
Posts

 
Drives: 1988 E30 M3 Evo II
Join Date: Jul 2008
Location: Reston, VA

iTrader: (33)

Garage List
go to dealer
Appreciate 0
      12-03-2010, 05:45 PM   #3
E93Ray
New Member
Canada
0
Rep
9
Posts

 
Drives: E92is White
Join Date: Dec 2009
Location: Edmonton

iTrader: (0)

The factory amplifier not too great ...on my 2008 E93...i switch twice....
Appreciate 0
      12-03-2010, 08:03 PM   #4
trusaleen1
Private
2
Rep
81
Posts

 
Drives: 2011 BMW 335iS Coupe
Join Date: Oct 2007
Location: Bay Area

iTrader: (0)

E93ray, what were your symptoms when the amp went out?
Appreciate 0
      12-03-2010, 11:11 PM   #5
wrickem
doesn't really care
wrickem's Avatar
25
Rep
2,302
Posts

 
Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

iTrader: (0)

I went from an '07 with Logic 7 to an '11 with HK. Mine sound just about the same with the same settings, the '11 might even sound a little better. I think you need to push the dealer a bit.
__________________
______________________________________________
'14 528-xdrive - daily driver/winter beater, '06 Boxster - for fun, '07 M6- for even more fun.
Appreciate 0
      12-05-2010, 01:18 PM   #6
trusaleen1
Private
2
Rep
81
Posts

 
Drives: 2011 BMW 335iS Coupe
Join Date: Oct 2007
Location: Bay Area

iTrader: (0)

Yeah it sounded great for about a week. Then all of a sudden the bass seemed weaker. Didn't have that punch and was more distorted. The quick bass is ok but the deep bass just isn't there. Seems like the amp??? Not enough power.

I'm just worried the dealer will say it's normal
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:11 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST