E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Ultimate Subwoofer Installation Guide (Instructions inside)



View Poll Results: Did you find this post helpful?
Yes 81 82.65%
No 17 17.35%
Voters: 98. You may not vote on this poll

Reply
 
Thread Tools Search this Thread
      11-25-2009, 08:56 PM   #67
ken530i
Private
ken530i's Avatar
United_States
0
Rep
99
Posts

 
Drives: 2011 328i
Join Date: Dec 2007
Location: Lancaster PA

iTrader: (1)

Quote:
Originally Posted by pruitt68 View Post
I just picked up my 2010 e90 335i, I've ripped the trunk apart and rear seats...can't find the amp anywhere! It's not on the left hand side where it used to be. I had a 2006 325i before this car and had no problem installing an aftermarket amp and speakers. Any suggestions?
2009 and earlier E90 models had 3 systems:
1. Basic - non USA; HU w/ 6 speakers
2. HIFI - base USA; HU, black amp in trunk, 10 speakers
3. TOP HIFI (L7) - MOST fiber optic, silver amp in trunk, 13 speakers

2010 USA models now have #1 and 3 above, no longer #2.

Lots of posts on the different systems in the forum. Also, check out 1Addicts forum, which has lots of posts on #1 basic system.
Appreciate 0
      11-26-2009, 02:36 AM   #68
pruitt68
Enlisted Member
Germany
0
Rep
44
Posts

 
Drives: 2010 335i
Join Date: Dec 2005
Location: Germany

iTrader: (1)

Wow. Did not know that! I looked all over last night trying to find out what the deal was, thanks so much for your post. I now at least know where to look! Wish I would have known this before ordering my car, would have probably upgraded to the L7. Any recommendations on the best way to upgrade the system? Again, thanks for pointing me in the right direction.
Appreciate 0
      11-26-2009, 12:37 PM   #69
TMR
Colonel
TMR's Avatar
United_States
49
Rep
2,892
Posts

 
Drives: M3
Join Date: Jun 2008
Location: Torrance

iTrader: (11)

Quote:
Originally Posted by pruitt68 View Post
Wow. Did not know that! I looked all over last night trying to find out what the deal was, thanks so much for your post. I now at least know where to look! Wish I would have known this before ordering my car, would have probably upgraded to the L7. Any recommendations on the best way to upgrade the system? Again, thanks for pointing me in the right direction.
I would think you can tap the wires at the back of the factory radio.
__________________
2015 M3 BPM Tuned, Eibach, Magnaflow and more www.tmrmzine.com/m3/f80
SOLD E92 Slēk Carbon Fiber Widebody M3 www.tmrmzine.com/m3/slek/
SOLD E92 335i Stage 3+ with all the toys www.tmrmzine.com/335/
SOLD E39 M5 Modded, What a great car! www.tmrmzine.com/m5/
Appreciate 0
      11-27-2009, 01:33 PM   #70
pruitt68
Enlisted Member
Germany
0
Rep
44
Posts

 
Drives: 2010 335i
Join Date: Dec 2005
Location: Germany

iTrader: (1)

Could I tap into the speaker wires further back, or do I need to tap directly from the back of the factory radio?
Appreciate 0
      03-10-2010, 06:35 PM   #71
spaceear
Registered
0
Rep
3
Posts

 
Drives: 318d SE
Join Date: Feb 2010
Location: UK

iTrader: (0)

Is there a thread on system #2 specifically anywhere?

I guess thats what I have here....
Also, does anyone know what the apparently spare connector is for?



Appreciate 0
      03-10-2010, 08:07 PM   #72
fdriller9
Banned
United_States
101
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
^^Extra connector is for a CD changer. Not sure what system you have. Definitely not L7, my amp looks nothing like that. I think it's HiFi. Basic doesn't have an optical output from the HU, which is what is shown in your picture.
Appreciate 0
      03-11-2010, 05:58 AM   #73
spaceear
Registered
0
Rep
3
Posts

 
Drives: 318d SE
Join Date: Feb 2010
Location: UK

iTrader: (0)

Still a little confused here tbh. So I have optical connection to the head unit (or in other words need to use a speaker level wire tap to install my additional amp)?

Does not appear to be many UK peeps on here - this is the mid upgrade definately not the L7. I thought it was an analogu amp
Appreciate 0
      03-11-2010, 07:04 AM   #74
Lee Rambler
Captain
United_States
7
Rep
605
Posts

 
Drives: 07 e92 335 6mt, 04 e53 x5 4.4
Join Date: Mar 2007
Location: PA

iTrader: (0)

amp is analog, with a flat 5v balanced signal going to it. the most optical connector is for a cd changer (you are prewired for it)
Appreciate 0
      12-22-2010, 12:01 AM   #75
LinxuS
First Lieutenant
LinxuS's Avatar
11
Rep
389
Posts

 
Drives: 2007 BMW 328i
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (1)

Garage List
2007 328i e90  [4.64]
Thanks for the great post! Just a couple of questions before I start tackling this subwoofer install...

1) Are you guys seeing any kind of a drop off on the EQ curve for low notes on the subwoofer? My sub really comes to life around 30-40 hz, will I have problem with this on the HiFi system?

2) What kind of connectors if any do I need to connect the power and ground to the subwoofer?
Appreciate 0
      12-26-2010, 07:57 PM   #76
kensk
Getting there...
kensk's Avatar
United_States
1
Rep
84
Posts

 
Drives: 2011 e90 LCI
Join Date: Jun 2010
Location: Orange County, CA

iTrader: (3)

Help!
I seem to not have the amp in the left side of my trunk. Im trying to locate the amp. It is also the basic sound system with the 2 subs underneath the front seats. Anyone know where it might be?
Appreciate 0
      12-26-2010, 09:15 PM   #77
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,184
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by kimks View Post
Help!
I seem to not have the amp in the left side of my trunk. Im trying to locate the amp. It is also the basic sound system with the 2 subs underneath the front seats. Anyone know where it might be?
Is there any tweeters in your front doors? If not then there's no OEM amp in your car.
Appreciate 0
      12-29-2010, 07:31 AM   #78
kensk
Getting there...
kensk's Avatar
United_States
1
Rep
84
Posts

 
Drives: 2011 e90 LCI
Join Date: Jun 2010
Location: Orange County, CA

iTrader: (3)

Quote:
Originally Posted by Technic View Post
Is there any tweeters in your front doors? If not then there's no OEM amp in your car.
oh ok. that's what i thought. i don't have tweeters. if i were to install my Fosgate punch P300-1 amp (300 watts) with a 10" Eclipse sub. where should i tap the amp into? i heard that tapping it to the stock subs underneath the seats might do the trick?
Appreciate 0
      12-29-2010, 11:06 AM   #79
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,184
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by kimks View Post
oh ok. that's what i thought. i don't have tweeters. if i were to install my Fosgate punch P300-1 amp (300 watts) with a 10" Eclipse sub. where should i tap the amp into? i heard that tapping it to the stock subs underneath the seats might do the trick?
Yes...
Appreciate 0
      12-29-2010, 11:47 AM   #80
brocklanders
Captain
brocklanders's Avatar
14
Rep
986
Posts

 
Drives: the uno, mineral white
Join Date: Mar 2010
Location: houston

iTrader: (1)

Garage List
06 325  [0.00]
Quote:
Originally Posted by nhhiep View Post
Here is the hi.lo converter that you will need, only $15 shipped.
http://www.cardomain.com/item/STISLOCII

I used it for 3 months and so far, very happy with it. Installation was easy because everything you need are in the trunk.


By the way, anyone know any method to have more sound coming in? I have MTX 421D with 420w RMS connect to 2 10" Kicker CVC. It's very loud when the trunk is opened but when it closes, inside I can feel it, but don't hear much. I don't have the seat fold down option.

Another tip for sub DUYer, if you don't have a port sub box, make sure you add poly-fill. My subs hit a lot harder after 20 oz of poly fill at walmart for 2 bucks.
i have the same problem and would love some feedback. i have an aftermarket head unit so my amp is running its signal from the sub rca's. i have a 10" boston g2 with a 500w alpine amp, i can definitely fell the bass inside the cabin but not really hear it.
Appreciate 0
      01-05-2011, 11:18 PM   #81
elratrero69
Private
elratrero69's Avatar
United_States
0
Rep
99
Posts

 
Drives: 07 335xi AT sedan
Join Date: Apr 2006
Location: SI, NY

iTrader: (0)

is it me or its not possible to connect a amp and sub on my L7 idrive. ive tried my loc on rear subs and rear speakers and nothing, my sub sound but no boom, what gives???
__________________

07 Bmw 335xi
07 A4 3.2 quattro
Appreciate 0
      01-20-2013, 11:54 PM   #82
Eurocraze
Custom User Title
0
Rep
94
Posts

 
Drives: 09 335i
Join Date: Dec 2012
Location: San Diego

iTrader: (0)

Followed these to a "t" and got my 12" mtx up in no time..
Appreciate 0
      01-20-2013, 11:57 PM   #83
Eurocraze
Custom User Title
0
Rep
94
Posts

 
Drives: 09 335i
Join Date: Dec 2012
Location: San Diego

iTrader: (0)

Though to round off some of your guys feedback, I think I should have tapped the "sub" lines and not rear output.. I feel a bit more punch but not like I did in my GTI, I hear n feel more outside the car then anything else
Appreciate 0
      06-23-2013, 06:30 PM   #84
apatel89
Enlisted Member
0
Rep
45
Posts

 
Drives: 328I coupe
Join Date: May 2013
Location: Delaware

iTrader: (0)

any diy on running rca cables from aftermarket head unit to the trunk? on a e92
Appreciate 0
      06-24-2013, 01:04 AM   #85
Viktimize
First Lieutenant
Canada
3
Rep
375
Posts

 
Drives: 2007 335i, 2002 325i
Join Date: Apr 2013
Location: Edmonton, Alberta, Canada

iTrader: (0)

Quote:
Originally Posted by apatel89 View Post
any diy on running rca cables from aftermarket head unit to the trunk? on a e92
What exactly do you want to know?? Plug them into the head unit, then tuck them under your trim all the way to the back, then plug them into the amp. It's about as straight forward a job as you can get.
Appreciate 0
      06-30-2013, 05:19 AM   #86
paprmkr
BMW Enthusiast
United_States
2
Rep
202
Posts

 
Drives: 2007 328i Black/Black
Join Date: May 2013
Location: Oxnard, Ca.

iTrader: (2)

Is there any sub replacements for the one under my seat on my 2007 325i coupe with HiFi option
Appreciate 0
      06-30-2013, 03:57 PM   #87
Nhe261
Second Lieutenant
4
Rep
201
Posts

 
Drives: 2008 335i 4 door
Join Date: Dec 2012
Location: SoCal

iTrader: (1)

The best way to get the real boom is to use 4 ch amp. 2 channels to power the underseat , the other 2 or 1 to power the trunk sub. Only trunk sub will have a break music as you can feel the boom is from back but not surround. The stock amp for underseat woofer is simply too weak. The woofer itself is not bad.
Appreciate 0
      10-16-2013, 01:31 AM   #88
kevinking_7
Registered
0
Rep
1
Posts

 
Drives: 2009 BMW 335d w/Sprts Pkg-Nav
Join Date: Oct 2012
Location: Surrey, B.C - Canada

iTrader: (0)

Okay, I went out and bought a Hi/Low Converter, installed it following the instructions, and got the light to power on. I connected the other end of the Hi/Low Converter's RCA outputs to my amp. My amp is receiving power, but my subwoofer that i installed isn't working nor are any of the speakers in my car. Spent about 4 hours installing and tapping into the stupid wires, and im pretty much ready to send it in to pro's.

Basically, i've tapped into the wires properly using the OP's help (I tapped into the rear LEFT and RIGHT sub's). I do however how the Remote cable from my aftermarket amp lying around as I have no clue where that's supposed to go... But from the Hi/Low Converter I did use the Remote cable from there and tapped into the "thin black wire" from the factory amp's harness.

I'm not sure if that could be the problem or not. Also, I tried to old amp's that I had laying around, neither would send a signal to the Subwoofer. Maybe I just need a new amp?

Any help would be appreciated. And i'll try and post some pics up tomorrow in the day time.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST