E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > stronger than usual vibration when idle



Reply
 
Thread Tools Search this Thread
      12-19-2010, 06:49 PM   #45
micah_675
Second Lieutenant
6
Rep
253
Posts

 
Drives: 2006 325i (US Spec)
Join Date: Sep 2010
Location: Germany

iTrader: (0)

I would like to point out, that a rough idle can be multiple things.

The least of which is timing, dirty oil, loss of compression in a cylinder, fouled spark plugs, weak coil pack, weak detination, improper spray of fuel injectors and so on and so forth. So will you be able to figure it out easy, in a word no.

I would swap your spark plugs out, and run a bottle of fuel injector cleaner (before the spark plugs are changed) and change your oil. If it persists after that, you COULD replace your coil packs. If that still doesnt fix it I would have the techs check the compression of your cylinders. Honestly, their answer sounds like a lame excuse to do anything. Your car being under warranty and such low miles should NOT be doing this.

Also why the hell did you bump this thread from obscurity? Why not make your own thread.
Appreciate 0
      12-30-2010, 01:45 PM   #46
cgnahc
Major
cgnahc's Avatar
United_States
21
Rep
1,258
Posts

 
Drives: TiAg E90 ZSP
Join Date: Dec 2006
Location: Westlake Village, CA

iTrader: (9)

My check engine light was on and had rough idle and lost 50% HP. I had two coils replaced and changed out spark plugs.
__________________
9/2011 Need someone to install angle eye bulbs.
9/2011 WTB: an OEM 17" front rim.
Appreciate 0
      12-30-2010, 07:01 PM   #47
goztepe2002
New Member
0
Rep
13
Posts

 
Drives: 09 328i
Join Date: Dec 2010
Location: Houston

iTrader: (0)

Any ideas what this could be. Mine is a 2009 e90 at 13k miles.

Had 10k when i picked it up 2 months ago and it iscertified. You would think they'd check the radiator fluid before they put the car on the lot. Last month radiator light came on when i turned it on and car shook like it was about to stall for a sec. Turned it off and restarted and it was fine but ever since then idle has been weird when i restart the car after driving it for while.

Notice it does not start up like the 2nd part of the video if the car is off for 5-6 hours. Only after the engine warms up. You can also hear the radiator fans kicking in immediately on the 2nd start. I'm thinking something is not right. BMW service adviser said it might be bad gas .. which is bull since i've been putting Shell 93 octane.

Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST