E90Post
 


Evolve Automotive
 
BMW 3-Series (E90 E92) Forum > BIMMERPOST Universal Forums > Off-Topic Discussions Board > Video + PC Gaming / Computing > DLP HD experts.......problem



Reply
 
Thread Tools Search this Thread
      02-03-2011, 07:35 PM   #1
Tim B.
Lieutenant
 
Drives: 2010 Jet Black E92 M3
Join Date: Dec 2009
Location: Baton Rouge, LA

Posts: 544
iTrader: (0)

DLP HD experts.......problem

I've got a Samsung DLP that i've had for about 3 or 4 years now. Over the last couple of weeks it has started to develop a bunch(about 40) of little "specks" on the screen. Most are dark, some are white, a few are flickering. Any ideas on what is starting to fail before i call out a service guy???
Tim B. is offline  
0
Reply With Quote
      02-03-2011, 09:43 PM   #2
lauer87
Lieutenant
 
lauer87's Avatar
 
Drives: 335xi
Join Date: Sep 2007
Location: USA

Posts: 585
iTrader: (0)

Probably just have some dust on the bulb.

There should be an access panel on the back or side of the tv that you can get into and look around.

That or the bulb is going bad, the bulbs are only supposed to last a few years anyway.
lauer87 is offline  
0
Reply With Quote
      02-04-2011, 03:52 AM   #3
Railgun
Major
 
Railgun's Avatar
 
Drives: FD, CBR600RR, R56 JCW
Join Date: Mar 2007
Location: London

Posts: 1,353
iTrader: (2)

Send a message via ICQ to Railgun Send a message via AIM to Railgun Send a message via MSN to Railgun Send a message via Yahoo to Railgun Send a message via Skype™ to Railgun
I suspect the mirrors are starting to flake out on the chip. I can't say anything about the longevity of Samsung DLP sets, nor can I say whether they use the same piece as Mitsu's (probably not). But it's akin to a dead pixel on an LCD set. I assume the specs are essentially as small as a pixel?

The dark/white specs are probably where the mirrors are away/towards the light source and stuck there. The flickering perhaps where that particular mirror is flipping out and won't sit still (which they all do anyway), but not where it is supposed to be hence you noticing it.
Railgun is online now   United Kingdom
0
Reply With Quote
      02-04-2011, 10:37 AM   #4
Tim B.
Lieutenant
 
Drives: 2010 Jet Black E92 M3
Join Date: Dec 2009
Location: Baton Rouge, LA

Posts: 544
iTrader: (0)

yeah, i called Samsung and they said it sounds like a problem with the chip and they would replace it at no charge. They are sending someone out in the next day or two, so we'll see. Thanks.
Tim B. is offline  
0
Reply With Quote
      02-04-2011, 08:27 PM   #5
Tim B.
Lieutenant
 
Drives: 2010 Jet Black E92 M3
Join Date: Dec 2009
Location: Baton Rouge, LA

Posts: 544
iTrader: (0)

Chip was replaced and it works fine. And thankfully Samsung picked up the tab It must be a common problem.
Tim B. is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:49 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST