E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DEPO projector90 upgrade DIY - work in progress



Reply
 
Thread Tools Search this Thread
      02-09-2011, 11:23 AM   #397
sqexpress
New Member
4
Rep
24
Posts

Drives: 2008 E90 328xi
Join Date: Jan 2011
Location: NJ

iTrader: (0)

Quote:
Originally Posted by misterba View Post
Finally done.
Of course not reading DIY I was confident to do it without anybody's help.
It took me (alone) three hours, due to one forgotten screw on the passenger side (I had to remove it to install bolt holding light in the bracket), fixing the latching two plastic screws which hold the light bulb access door (When I was pulling the mud guard off I didn't remove them) and fixing the back cover on the DEPO headlight. (Very poor cover design, two snap on clips very easy to "snap off").
Before I removed the halogens I marked the beam position on the plywood for easy adjustment of the new lights. I checked the lights functionality after every major step to eliminate the mistakes. Error was always on due to disconnected fog lights.
There is horizontal adjustment screw which many members claim doesn't exist. It is under the rubber plug on the outer side of the light. See a hole on the picture.
The AE’s are on only when parking lights are on, together with the turning lights. Don’t like it.
The lights are beautiful; no error, no flickering, I can’t wait for the night to take it for a spin.
Sorry for the lousy pictures, (Iphone) I will take a good one later on to show AE's only.
Do you happen to have a picture of the horizontal adjustment screw? Is it accessible without removing the bumper? Thanks.
Appreciate 0
      02-09-2011, 01:11 PM   #398
veloSpeed
New Member
veloSpeed's Avatar
United_States
0
Rep
9
Posts

Drives: 2007 328i Sedan
Join Date: Dec 2010
Location: Upland, CA

iTrader: (0)

>:/ Love-Hate

*** If you really want these lights, be prepared to deal with some annoying issues. ******

My personal experience with DEPO headlights w/ LED Ring Angel Eyes.

I replaced my halogens on my E90 328i with these beauties (sarcasm). Had them professionally installed by an experienced shop to avoid the trial and error approach. It all appeared to be a success until I got the first error on my way home. My right turn signal was out! I returned to the shop and they fixed the issue by refitting the bulb. A minor glitch I thought and got back on the road. A few miles later, BING, BING, BADABING! both turn signals failed randomly!!! WTF!!!!! Hide me from other Bimmers. Since I live 25 miles away from the shop, I decided to tough it out for a week before returning. In that week from hell, this annoyance happened about 25 times.

I went back to the shop and they decided to replace both headlights with a new set. No Joy, they both behaved the same way with the added bonus of not being able to adjust down the driver's side headlight (not self leveling). I am now that prick blinding all incoming traffic. But wait, there's more! It rained, and my high tech POS headlights fog up badly. ARRRGH, what an eyesore! The shop doesn't know how to solve the problem because is a design flaw, not and installation issue. The lights look awesome when they behave, IF and WHEN they behave. I'm really starting to regret getting them. I can only imagine how they'll behave a few months down the road.

The saga continues, and I'll be my 3rd set soon. Somehow I have the feeling it's going to be more of the same. I'll keep you posted.
Appreciate 0
      02-09-2011, 07:11 PM   #399
Goodneighbor
Enlisted Member
4
Rep
33
Posts

Drives: 06 Z4, 07 328i
Join Date: Dec 2010
Location: NC

iTrader: (0)

Wow! Thats rough! Did you try the blinker adapters from jlevisw? I havent had a problem with errors or fogging. Did you adjust your headlights? There is a screw right behind the headlight to adjust them down.
Appreciate 0
      02-14-2011, 10:23 PM   #400
chatre
New Member
0
Rep
11
Posts

Drives: Range Rover
Join Date: Dec 2009
Location: Canada

iTrader: (0)

All these bad reviews are really putting me off buying these lights. I'm planning on buying them for my Uncle so I don't really want them to have any error codes or problems for him. I emailed Bryan at Jlevi and asked him about the upgraded LED angel eyes and LED turn signals (without the HIDs) and he said that it would work for sure with no problems and money back guarantee.... should I believe him? I just want the lights to work. From what I have gathered the HIDs are the problem area. Has anyone had troubles with the upgraded LED angel eyes and LED turn signals? Thanks again guys and girls
Appreciate 0
      02-15-2011, 10:26 AM   #401
yxu
Enlisted Member
0
Rep
45
Posts

Drives: 2007 328i
Join Date: Aug 2010
Location: nj

iTrader: (0)

Seems like the AE cause the parking light current incorrect, and HID cause the low beam current incorrect, I have no problem to use a hype white halogen bulb for the low beam, but the AE with the parking light issue bothers me a LOT!
Appreciate 0
      02-19-2011, 05:10 PM   #402
veloSpeed
New Member
veloSpeed's Avatar
United_States
0
Rep
9
Posts

Drives: 2007 328i Sedan
Join Date: Dec 2010
Location: Upland, CA

iTrader: (0)

Quote:
Originally Posted by veloSpeed View Post
*** If you really want these lights, be prepared to deal with some annoying issues. ******

My personal experience with DEPO headlights w/ LED Ring Angel Eyes.

I replaced my halogens on my E90 328i with these beauties (sarcasm). Had them professionally installed by an experienced shop to avoid the trial and error approach. It all appeared to be a success until I got the first error on my way home. My right turn signal was out! I returned to the shop and they fixed the issue by refitting the bulb. A minor glitch I thought and got back on the road. A few miles later, BING, BING, BADABING! both turn signals failed randomly!!! WTF!!!!! Hide me from other Bimmers. Since I live 25 miles away from the shop, I decided to tough it out for a week before returning. In that week from hell, this annoyance happened about 25 times.

I went back to the shop and they decided to replace both headlights with a new set. No Joy, they both behaved the same way with the added bonus of not being able to adjust down the driver's side headlight (not self leveling). I am now that prick blinding all incoming traffic. But wait, there's more! It rained, and my high tech POS headlights fog up badly. ARRRGH, what an eyesore! The shop doesn't know how to solve the problem because is a design flaw, not and installation issue. The lights look awesome when they behave, IF and WHEN they behave. I'm really starting to regret getting them. I can only imagine how they'll behave a few months down the road.

The saga continues, and I'll be my 3rd set soon. Somehow I have the feeling it's going to be more of the same. I'll keep you posted.
Soooooo, I'm on the 3rd set. The adjustment has been resolved with a secondary pivot point located elsewhere in the assembly, according to the shop. Everything was working PURFECT and I was happy until the next morning. ARRRGH! My driver side turn signal was out, AGAIN! The shop, and everyone that has worked on these lights is confused, they used OEM bulbs to be safe, and no joy! These lights are possesed, FFFFF*CK!

But wait, there's more! The random LED flicker still there when the engine's running, OH JOY!

I turned a great German machine into unreliable crap with chinese aftermarket junk. I want BMW OEMs!!! At least they work the way they should, every time!
Appreciate 0
      02-19-2011, 05:23 PM   #403
veloSpeed
New Member
veloSpeed's Avatar
United_States
0
Rep
9
Posts

Drives: 2007 328i Sedan
Join Date: Dec 2010
Location: Upland, CA

iTrader: (0)

Quote:
Originally Posted by Goodneighbor View Post
Wow! Thats rough! Did you try the blinker adapters from jlevisw? I havent had a problem with errors or fogging. Did you adjust your headlights? There is a screw right behind the headlight to adjust them down.
Yeah, the shop finally figured out the read adjustment pivot inside the housing. The lights still fog up, the LEDs have a faint flicker when the engine is running and both turn signals keep loosing contact randomly. Nothing that a patient customer can't handle. I wish I was one.
Appreciate 0
      02-19-2011, 05:26 PM   #404
veloSpeed
New Member
veloSpeed's Avatar
United_States
0
Rep
9
Posts

Drives: 2007 328i Sedan
Join Date: Dec 2010
Location: Upland, CA

iTrader: (0)

Quote:
Originally Posted by chatre View Post
All these bad reviews are really putting me off buying these lights. I'm planning on buying them for my Uncle so I don't really want them to have any error codes or problems for him. I emailed Bryan at Jlevi and asked him about the upgraded LED angel eyes and LED turn signals (without the HIDs) and he said that it would work for sure with no problems and money back guarantee.... should I believe him? I just want the lights to work. From what I have gathered the HIDs are the problem area. Has anyone had troubles with the upgraded LED angel eyes and LED turn signals? Thanks again guys and girls
Listen, if you like the look, get them. Most people here don't seem to be in the hell I'm in.
Appreciate 0
      02-21-2011, 04:20 PM   #405
sandman0615
obsessed....
sandman0615's Avatar
25
Rep
524
Posts

Drives: e90 325xi 6sp
Join Date: Sep 2009
Location: ffld, ct

iTrader: (2)

since writing the DIY ive had no issues it really seems to depend, but the way i see it the depos are a giant flashlight. any errors or problems are going to be a problem with the xenon bulbs, ballast, or error cancellers. my only issue is low highbeams. i dont see how halogen to OEM xenons wont share some of the same problems
__________________
|6SP|BILSTEIN/H&R SPORTS|INJEN CAI|BMS PBX|DEPO P90 6000K|x244 LED AE|BLACKLINES|20% TINT|MATTE KIDNEYS|BLACKOUT EMBLEMS|10" BAZOOKA|

||DIY: DEPO P90||
RIP E46 330xi
Appreciate 0
      02-26-2011, 10:36 PM   #406
misterba
Milan
misterba's Avatar
United_States
1
Rep
158
Posts

Drives: 2007 E90 328i
Join Date: Feb 2010
Location: Oceanside, California

iTrader: (2)

Send a message via Skype™ to misterba
I have the lights for few month and even I still have old lights in my garage I will not put them back. I had learned to run with lights on all the time, untill I will start to mess with it and rewire them to have AE's only running as the day lights. Have same issue as sandman, low hi-beams. Since I don't use them, it doesn't bother me. In the future I will replace them with Xeons and the argument about blinding other drivers...I'm talking about Hi-Beams, they should be used when there is nobody to be blinded. So for now I'm happy. Not bad for close to $600 total and risk of using E-Bay. When I will be getting newer bimmer I will put the old one's back, resell the Depo one's and get one with factory ae's. Still worth it.
Appreciate 0
      03-03-2011, 05:13 PM   #407
sandman0615
obsessed....
sandman0615's Avatar
25
Rep
524
Posts

Drives: e90 325xi 6sp
Join Date: Sep 2009
Location: ffld, ct

iTrader: (2)

^amen

does anyone know how to adjust the high beams??? ive heard tales of an adjustment screw
__________________
|6SP|BILSTEIN/H&R SPORTS|INJEN CAI|BMS PBX|DEPO P90 6000K|x244 LED AE|BLACKLINES|20% TINT|MATTE KIDNEYS|BLACKOUT EMBLEMS|10" BAZOOKA|

||DIY: DEPO P90||
RIP E46 330xi
Appreciate 0
      03-03-2011, 07:16 PM   #408
misterba
Milan
misterba's Avatar
United_States
1
Rep
158
Posts

Drives: 2007 E90 328i
Join Date: Feb 2010
Location: Oceanside, California

iTrader: (2)

Send a message via Skype™ to misterba
Quote:
Originally Posted by sandman0615 View Post
^amen

does anyone know how to adjust the high beams??? ive heard tales of an adjustment screw
As far as I know there are just two screws for adjustment. Since the light is all one unit the low beam goes up at the same rate as high beam. There is one clip inside for xenon lights which is for adjustment driving on the left side or right side. I'd be happy to now if there are more options which I doubt.
Appreciate 0
      03-06-2011, 05:48 PM   #409
Casca
Captain
15
Rep
637
Posts

Drives: E90 6MT
Join Date: May 2010
Location: California

iTrader: (0)

I got my kit to fix issues with these lights from JLevi, but haven't gotten around to putting them in yet. Biggest problem I have is my left light randomly throws an error and then eventually shuts off. I found if I immediatly dismiss the error via the BC button on the steering stalk, then the lights never shuts off and I don't have to look like a fool driving around with only one working headlight.
Appreciate 0
      03-06-2011, 07:38 PM   #410
misterba
Milan
misterba's Avatar
United_States
1
Rep
158
Posts

Drives: 2007 E90 328i
Join Date: Feb 2010
Location: Oceanside, California

iTrader: (2)

Send a message via Skype™ to misterba
Quote:
Originally Posted by Casca View Post
I got my kit to fix issues with these lights from JLevi, but haven't gotten around to putting them in yet. Biggest problem I have is my left light randomly throws an error and then eventually shuts off. I found if I immediatly dismiss the error via the BC button on the steering stalk, then the lights never shuts off and I don't have to look like a fool driving around with only one working headlight.
I don't have anything like that going on. After all I'm glad I bough the one from e-bay.
Appreciate 0
      03-06-2011, 08:00 PM   #411
wuchao1
台北 台灣
wuchao1's Avatar
Taiwan
17
Rep
619
Posts

Drives: 2004 MazdaSpeed Miata
Join Date: Apr 2009
Location: Michigan State Spartans / Taipei

iTrader: (5)

Send a message via MSN to wuchao1
I have the one from Jlevisw.. was throwing all kinds of error and sometimes my left low beam will shut off randomly..
But I do believe I found a fix for it:
I have dimsum coded my car for me.. stopped the light check so no more errors and also he coded the car so now the car thinks it has xenon from the factory.. so far so good. no more problem anymore!
__________________
2006 E90 325i AT TiAG...Sold!
2000 E39 M5 "The Beast"...Sold!

2004 Mazda Speed Miata... Bone Stock...
2000 Ford Explorer... Beater all the way
Appreciate 0
      03-11-2011, 03:40 PM   #412
wmb0000
Private First Class
6
Rep
128
Posts

Drives: 2008 E93 328I
Join Date: Sep 2010
Location: Boston

iTrader: (1)

Quote:
Originally Posted by wuchao1 View Post
I have the one from Jlevisw.. was throwing all kinds of error and sometimes my left low beam will shut off randomly..
But I do believe I found a fix for it:
I have dimsum coded my car for me.. stopped the light check so no more errors and also he coded the car so now the car thinks it has xenon from the factory.. so far so good. no more problem anymore!
Can you tell me how this is done? I want to know what dimsum change to make it work. Need to find a coder near boston as well.
Appreciate 0
      03-14-2011, 12:03 PM   #413
wuchao1
台北 台灣
wuchao1's Avatar
Taiwan
17
Rep
619
Posts

Drives: 2004 MazdaSpeed Miata
Join Date: Apr 2009
Location: Michigan State Spartans / Taipei

iTrader: (5)

Send a message via MSN to wuchao1
Quote:
Originally Posted by wmb0000 View Post
Can you tell me how this is done? I want to know what dimsum change to make it work. Need to find a coder near boston as well.
Im not 100% sure what he did. But according to wat he said.. he turned off the light bulb self checking... So no more flickering on those LEDs during start up.. and he also coded the car to make the car think it comes with xenon.. I believe thats what he did.
And sadly he got banned from e90post..
__________________
2006 E90 325i AT TiAG...Sold!
2000 E39 M5 "The Beast"...Sold!

2004 Mazda Speed Miata... Bone Stock...
2000 Ford Explorer... Beater all the way
Appreciate 0
      03-14-2011, 02:43 PM   #414
Matador2k7
Registered
0
Rep
1
Posts

Drives: 2006 E90
Join Date: Mar 2011
Location: Tampa, FL

iTrader: (0)

Did you have to use a separate harness ? If so, can you share how you connected and which cables you tapped ?
Appreciate 0
      03-15-2011, 04:52 PM   #415
wuchao1
台北 台灣
wuchao1's Avatar
Taiwan
17
Rep
619
Posts

Drives: 2004 MazdaSpeed Miata
Join Date: Apr 2009
Location: Michigan State Spartans / Taipei

iTrader: (5)

Send a message via MSN to wuchao1
Quote:
Originally Posted by Matador2k7 View Post
Did you have to use a separate harness ? If so, can you share how you connected and which cables you tapped ?
No, all I have is the headlight, LED AE, 6000k, and the error canceling harness. All from jlevisw.
__________________
2006 E90 325i AT TiAG...Sold!
2000 E39 M5 "The Beast"...Sold!

2004 Mazda Speed Miata... Bone Stock...
2000 Ford Explorer... Beater all the way
Appreciate 0
      03-15-2011, 08:23 PM   #416
wmb0000
Private First Class
6
Rep
128
Posts

Drives: 2008 E93 328I
Join Date: Sep 2010
Location: Boston

iTrader: (1)

I am finally error free .. woohoo !!!

I installed a fixed that Jlevisw sent out and now it's working perfectly. No more error whatsoever. Finally !!!!!
Appreciate 0
      03-16-2011, 07:38 PM   #417
d3l0n
I love the ///M3, but I want 550hp ///M5
d3l0n's Avatar
United_States
70
Rep
3,278
Posts

Drives: BMW330iE90
Join Date: May 2006
Location: NYC

iTrader: (1)

Garage List
Adaptive Headlight Compatibility?
Appreciate 0
      04-03-2011, 02:56 PM   #418
chowser51
Second Lieutenant
chowser51's Avatar
United_States
3
Rep
278
Posts

Drives: 2009 BMW 328i xDrive
Join Date: Feb 2009
Location: Cleveland, OH

iTrader: (1)

has anyone done this with just halogen setup? or even with the xenesis halogen bulbs? not looking for HID, but need to replace a headlight so i thought about just replacing them both with a set of these.

sticking with halogen so i won't need error cancelers.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:53 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST