E90Post
 


jb4store
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Radio, Bluetooth, etc. all kaput



Reply
 
Thread Tools Search this Thread
      02-18-2011, 05:38 PM   #1
bookman2
Second Lieutenant
2

 
bookman2's Avatar
 
Drives: 2006 330i SP, PP
Join Date: Jun 2005
Location: Chicago, IL


Posts: 203
iTrader: (0)

Radio, Bluetooth, etc. all kaput

I recently had the displeasure of having my radio, sat, bluetooth, CD... the whole kit and caboodle go out on me. The symptoms were consistent with what others here have reported just before their systems shut down:

First my iPod would cut on and off as the SOS light flashed above my head. I then tried the CD player which worked for a moment before it too stopped responding. My first clue that something was amiss was when my Droid X wouldn't sync up with the bluetooth after four months of near flawless operation. Now, to add insult to injury, my airbag malfunction warning signal has lit as well. Naturally I'm out of warrantee.

What I couldn't find during my search of the threads was what others paid for the repairs (not necessarily including the airbag issue). If there is anyone out there who has had this issue I would much appreciate some sense of what your approximate costs for the repairs were.

Last edited by bookman2; 02-18-2011 at 05:40 PM. Reason: grammer
Appreciate 0
      02-18-2011, 05:41 PM   #2
bsamoul
Major General
No_Country
78

 
bsamoul's Avatar
 
Drives: E90 325i
Join Date: Feb 2007
Location: Walnut Creek, California


Posts: 7,425
iTrader: (2)

Send a message via AIM to bsamoul
Happened to me (under warrantee, though) and they had to replace the TCU. The TCU runs all the communications for the entire car. My radio didn't go out, though. I just didn't have BMW Assist (SOS) and Bluetooth.
__________________
-Brian
2X 2006 BMW 325i [Electric Red & Mystic Blue] | ZPP | V1 | Rear Fogs | M3 Lip Spoiler | EAS RemoteKey | BMS Powerbox | Projector90 Headlights w/ LED AE | LED plate lights | OEM Blacklines
http://www.tech-shine.com
Appreciate 0
      02-18-2011, 08:16 PM   #3
csquared013
Private
United_States
0

 
Drives: Arctic metallic 2006 330xi
Join Date: Nov 2009
Location: rochester, new york


Posts: 72
iTrader: (1)

hey i JUST dug myself outta this situation, sorry to hear about the radio.

My dealer thought it was a blown amplifier since I have L7. They quoted it at $1800 for a new amp with labor and coding give or take a bit (there are some lower figures on here).

I bought a used amp for $600 since it was a lot cheaper than getting a new one and they were going to charge me $345 for a coding and install until they found out they were wrong about what was wrong with the car.

Finally had a competent shop work on the car and found the issue was the TCU. A new TCU with install and coding set me back $875 after the base fee for diagnostics ($150 at my dealer)

Good luck with the problem, I hope it doesn't turn out to be as much of a pain as mine was!!
Appreciate 0
      02-18-2011, 08:54 PM   #4
urbanite23
Private First Class
10

 
Drives: black beauty
Join Date: Oct 2010
Location: east coast


Posts: 188
iTrader: (0)

Wow, I just got a 330i both the op and csquare who had the issue have 330's as well. Are there any symptoms for this or just random? Is it a common issue? sorry to hear btw..
Appreciate 0
      02-19-2011, 08:00 AM   #5
bookman2
Second Lieutenant
2

 
bookman2's Avatar
 
Drives: 2006 330i SP, PP
Join Date: Jun 2005
Location: Chicago, IL


Posts: 203
iTrader: (0)

Thanks for the responses they were helpful. It looks like I'm going to be out at least a grand on this one.
Appreciate 0
      02-19-2011, 08:52 AM   #6
John 070
Lieutenant General
150

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW


Posts: 11,483
iTrader: (0)

I too have a droid X. I was talking on the bluetooth when it kept dropping. My first impulse was to reboot the phone, no go. Then I got into repairing, etc., no go. I was beginning to worry, when all of a sudden I got the yellow battery icon, and then the entire ignition shut-off (sorry but WTF?).

My hunch is it's software that's trying to orderly shut down unimportant things when the battery is low (unimportant, like the ignition, what do these engineers think?).....

I've never had the problem again and the car was taken on a few trips on the highway which lasted several hours, so my assumption is the battery is recharged properly now...
Appreciate 0
      02-19-2011, 10:10 PM   #7
csquared013
Private
United_States
0

 
Drives: Arctic metallic 2006 330xi
Join Date: Nov 2009
Location: rochester, new york


Posts: 72
iTrader: (1)

Quote:
Originally Posted by urbanite23 View Post
Wow, I just got a 330i both the op and csquare who had the issue have 330's as well. Are there any symptoms for this or just random? Is it a common issue? sorry to hear btw..
I asked the dealer about this when i was in for the repair and he told me they see it from time to time because the TCU is a "delicate" unit but he didn't say it was terribly common, luckily.
Appreciate 0
      02-21-2011, 11:08 AM   #8
rbelf
Private
0

 
Drives: 2006 330I
Join Date: Jun 2006
Location: Wilmington, DE


Posts: 72
iTrader: (0)

"Delicate" my a#$...BMW shopped out their TCU productions for the 06 and had a bad install/product with 2 of the 3 suppliers (at least thats what i am finding out). If you look at the price history of the TCU's they started at $1400 and are now down to about $300-$400 because so many people had to buy them. I am having a horrible problem right now...see thread

http://www.e90post.com/forums/showthread.php?t=487872

What i am about to replace next is the TCU (already replace the CCC). The only difference is that my entire Nav screen is blank and shuts on and off but this may (hopefully) be because of an intermittent fault in the MOST bus caused by the TCU. IT IS VERY FRUSTRATING and I am in conversations with BMW NA about it. My car is just out of warranty but is a CPO (which doesnt cover electronics!). I urge you and everyone else to call BMW NA about this problem and force them to do something about it (1-800-831-1117; bill at ext. 7305).

Anyway, if you know anyone that can get you wholesale pricing for parts, the TCU should be in the mid $200's plus coding. There are a lot of shops that can code these things if you can avoid going to a dealer...it only takes about 20 minutes. good luck.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:36 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST