E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > is 1x12" + 2x8" too much?



Reply
 
Thread Tools Search this Thread
      01-27-2011, 10:09 AM   #1
piggelin
First Lieutenant
 
piggelin's Avatar
 
Drives: BMW 320i E90 2005
Join Date: Apr 2009
Location: -.-

Posts: 355
iTrader: (0)

is 1x12" + 2x8" too much?

i have a http://www.alpine-europe.com/switzer...sbe-12kit.html

and i also have this: http://www.alpine-usa.com/product/view/mrp-f300/ for my Earthquake SWS-8 4ohms.

i just ordered the mrp-f300 since my old bp tha555 broke.

will this be a good combination, or just too much?

Thanks!
piggelin is offline  
0
Reply With Quote
      01-27-2011, 02:51 PM   #2
cbi1972
New Member
 
Drives: 1998 Lexus GS400
Join Date: Jan 2011
Location: Birmingham, AL

Posts: 5
iTrader: (0)

Whether it is "too much" depends almost entirely on your tastes. 12s will reproduce lower frequencies than 10s, and if your music has a lot of deep bass, 12 inch subs will be better at it.

What I would be concerned with is the mid-bass. I have read that the Earthquakes are not as good at mid-bass as sub-bass, which could leave a gap in the upper bass region that neither the 4" door speakers nor the 8" subs would perform well.

I don't have an E9x yet, but I have a pair of 10s in the trunk of my Lexus, with 6.5s in the front, and I am still short on mid-bass. I would first try the 12 with the stock 8s and then decide if I needed anything else.
cbi1972 is offline   United_States
0
Reply With Quote
      01-27-2011, 03:03 PM   #3
piggelin
First Lieutenant
 
piggelin's Avatar
 
Drives: BMW 320i E90 2005
Join Date: Apr 2009
Location: -.-

Posts: 355
iTrader: (0)

Hmmm.

But I'm not that selective.. I'm happy as long as it sounds better than it does now.

About the new MRP-F300 I just ordered. With that amp and my sws-8's, I can still use them as mid-basses right? As I said, I'm not that selective. My car isn't flawless. Hehe.
piggelin is offline  
0
Reply With Quote
      01-27-2011, 03:11 PM   #4
cbi1972
New Member
 
Drives: 1998 Lexus GS400
Join Date: Jan 2011
Location: Birmingham, AL

Posts: 5
iTrader: (0)

http://www.e90post.com/forums/showthread.php?t=343673
I have never heard them before, but this thread is pretty much what I am going by.
cbi1972 is offline   United_States
0
Reply With Quote
      01-27-2011, 07:36 PM   #5
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by piggelin View Post
Hmmm.

But I'm not that selective.. I'm happy as long as it sounds better than it does now.

About the new MRP-F300 I just ordered. With that amp and my sws-8's, I can still use them as mid-basses right? As I said, I'm not that selective. My car isn't flawless. Hehe.
The f300 is perfect for the SWS-8s.

I have my stock L7 woofers amped with a M500....mono I know :/

I wanted to get an F300 as well but had the M500 laying around.
fdriller9 is offline   United_States
0
Reply With Quote
      01-28-2011, 03:14 AM   #6
piggelin
First Lieutenant
 
piggelin's Avatar
 
Drives: BMW 320i E90 2005
Join Date: Apr 2009
Location: -.-

Posts: 355
iTrader: (0)

So they won't sound good at all? I'm new with this. So if the woofers won't work good as mid-bass, I might just use them as normal subs.

We will see, I'll keep you posted. The store just shipped it out though..

Last edited by piggelin; 01-28-2011 at 04:17 AM. Reason: dunno dunt care bitches
piggelin is offline  
0
Reply With Quote
      01-31-2011, 08:12 AM   #7
kaigoss69
Colonel
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 2,741
iTrader: (5)

The only way to get the Earthquakes to sound decent at midbass is through "heavy" processing. If you don't have that capability I would put back in the Logic 7 woofers (assuming you have L7).
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) AE SBP15
kaigoss69 is offline   United_States
0
Reply With Quote
      02-08-2011, 09:20 PM   #8
piggelin
First Lieutenant
 
piggelin's Avatar
 
Drives: BMW 320i E90 2005
Join Date: Apr 2009
Location: -.-

Posts: 355
iTrader: (0)

I don't. I have the shitty euro-woofers. No hifi, no L7. Maybe the best thing to do is using thoose as subs
piggelin is offline  
0
Reply With Quote
      02-20-2011, 10:10 AM   #9
piggelin
First Lieutenant
 
piggelin's Avatar
 
Drives: BMW 320i E90 2005
Join Date: Apr 2009
Location: -.-

Posts: 355
iTrader: (0)

any tips on wich settings i should use? sounds really bad now
piggelin is offline  
0
Reply With Quote
      02-20-2011, 10:36 AM   #10
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
If you're running the 2, 8" and a 12" you should bandpass the 8"s and low pass the trunk sub.

I have my L7 woofers bandpassed between 60Hz and 200Hz. Trunk sub is low passed around 65Hz. Play around with those settings. You may want the SWS-8s handle a bit more low end though.

Btw, you can make any sub too much. Just set the gain to your liking.
fdriller9 is offline   United_States
0
Reply With Quote
      02-24-2011, 07:10 PM   #11
piggelin
First Lieutenant
 
piggelin's Avatar
 
Drives: BMW 320i E90 2005
Join Date: Apr 2009
Location: -.-

Posts: 355
iTrader: (0)

Quote:
Originally Posted by ********* View Post
If you're running the 2, 8" and a 12" you should bandpass the 8"s and low pass the trunk sub.

I have my L7 woofers bandpassed between 60Hz and 200Hz. Trunk sub is low passed around 65Hz. Play around with those settings. You may want the SWS-8s handle a bit more low end though.

Btw, you can make any sub too much. Just set the gain to your liking.
thanks alot mate. you always answer and try to help. it sounds better now, alot better. but i wonder if the speakers are in bad shape lol, i didnt use them well before and they havent been used for a while (until i got my new amp)

piggelin is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:14 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST