E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Burned smell in my 325i



Reply
 
Thread Tools Search this Thread
      02-23-2011, 11:08 AM   #1
Horniekoala
New Member
 
Drives: 325i
Join Date: Feb 2011
Location: Stanton

Posts: 6
iTrader: (0)

Burned smell in my 325i

My car would randomly has this smell of burned rubber, and it doesn't come from a/c vents. Does anyone have any idea what's wrong??
Horniekoala is offline  
0
Reply With Quote
      02-23-2011, 12:55 PM   #2
sneaks
Lieutenant
 
sneaks's Avatar
 
Drives: '08 335xi
Join Date: Apr 2008
Location: 24 Sussex

Posts: 431
iTrader: (1)

Garage List
2008 335xi  [0.00]
happened to me once on a reaaaaly cold start early in the morning.
sneaks is offline   Canada
0
Reply With Quote
      02-23-2011, 02:51 PM   #3
Horniekoala
New Member
 
Drives: 325i
Join Date: Feb 2011
Location: Stanton

Posts: 6
iTrader: (0)

Does it just go away?
Horniekoala is offline  
0
Reply With Quote
      02-23-2011, 04:05 PM   #4
Tzu
Major
 
Drives: 335i
Join Date: Jun 2010
Location: Toronto

Posts: 1,468
iTrader: (1)

I had this once as well when it was very very cold, -20C. My exhaust flap froze shut, and I had to drive around to warm it up so it could open, I figured I may have overheated that seal or something.

Smell has not returned since.
Tzu is offline   Canada
0
Reply With Quote
      02-24-2011, 12:29 PM   #5
sneaks
Lieutenant
 
sneaks's Avatar
 
Drives: '08 335xi
Join Date: Apr 2008
Location: 24 Sussex

Posts: 431
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by Tzu View Post
I had this once as well when it was very very cold, -20C. My exhaust flap froze shut, and I had to drive around to warm it up so it could open, I figured I may have overheated that seal or something.

Smell has not returned since.
This is possibly what happened to me. The smell was bad but only for 20 seconds and hasn't been back.
sneaks is offline   Canada
0
Reply With Quote
      03-01-2011, 07:13 PM   #6
beppy
Private
 
Drives: 06 325i ZPP ZSP ZCW
Join Date: Oct 2009
Location: Toronto

Posts: 81
iTrader: (0)

Same thing happened to me. Exhaust tip frozen could be it. Where is that located btw?
beppy is offline  
0
Reply With Quote
      03-01-2011, 07:18 PM   #7
sneaks
Lieutenant
 
sneaks's Avatar
 
Drives: '08 335xi
Join Date: Apr 2008
Location: 24 Sussex

Posts: 431
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by beppy View Post
Same thing happened to me. Exhaust tip frozen could be it. Where is that located btw?

does the 325 have an exhaust flap?
sneaks is offline   Canada
0
Reply With Quote
      03-01-2011, 09:43 PM   #8
AlanAZ
Captain
 
AlanAZ's Avatar
 
Drives: E90 325i sport manual
Join Date: Aug 2009
Location: Scottsdale, AZ

Posts: 795
iTrader: (4)

Quote:
does the 325 have an exhaust flap?
No, for 325/328. I wish it had one, the exhaust note sucks, thanks to the German Green Party's noise restrictions in Germany.
AlanAZ is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:38 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST