E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Spark Plugs/Ignition coil Help



Reply
 
Thread Tools Search this Thread
      04-03-2011, 03:19 PM   #1
JL 325i
straight^
JL 325i's Avatar
United_States
9
Rep
766
Posts

 
Drives: 325i
Join Date: Jan 2010
Location: Baton Rouge, LA

iTrader: (7)

Spark Plugs/Ignition coil Help

Hi guys, I recently have gotten 2 misfired error codes. I brought it in the 1st time and they replaced ignition coil#5. So i get the 2nd error last week..i Researched and supposedly some people were saying that they think the 06 325i's had a bad batch of ignition coils. Can anyone attest to this? Anyway, i decided to buy all new ignition coils and iridium spark plugs..

1st off, has anyone had any kind of performance change from iridiums over platinum spark plugs?

2nd, has anyone had trouble taking out the spark plugs? my engine was cold and the damn sparkplug would still not come loose. Any suggestions or tips?
__________________
Wanting to sell.
Appreciate 0
      04-03-2011, 10:17 PM   #2
Got Euro ?
Here Comes The Boom
Got Euro ?'s Avatar
United_States
4
Rep
494
Posts

 
Drives: e92
Join Date: Feb 2011
Location: NNJ

iTrader: (1)

Quote:
Originally Posted by JL 325i View Post
Hi guys, I recently have gotten 2 misfired error codes. I brought it in the 1st time and they replaced ignition coil#5. So i get the 2nd error last week..i Researched and supposedly some people were saying that they think the 06 325i's had a bad batch of ignition coils. Can anyone attest to this? Anyway, i decided to buy all new ignition coils and iridium spark plugs..

1st off, has anyone had any kind of performance change from iridiums over platinum spark plugs?

LOL thats all hype and BS.. Only way your gonna see a chance is by NOT using the garbage coilpacks from BMW..

2nd, has anyone had trouble taking out the spark plugs? my engine was cold and the damn sparkplug would still not come loose. Any suggestions or tips?
Turn the car on for a few mins and then try again... But make sure you are using proper tools
__________________
▀▄▀▄▀▄// DTMPOWER //
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST