E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Pixel 2 XL Bluetooth 5.0 Issues



Reply
 
Thread Tools Search this Thread
      10-23-2017, 08:44 AM   #1
cRo5
2013 E92 335i MSport
cRo5's Avatar
United_States
5
Rep
53
Posts

Drives: E92
Join Date: Jun 2015
Location: MA VT NC

iTrader: (0)

Garage List
Pixel 2 XL Bluetooth 5.0 Issues

I received my Pixel 2 XL a few days ago and one huge compliant I have is that every 30 or so minutes of playing music over Bluetooth, the phone disconnects with a loud high-pitched sound, then reconnects automatically a few minutes later. I've never had this problem with any previous phones (Nexus 6P, iPhone 7 Plus), yet this is my first phone with Bluetooth 5.0.

Has anyone had a similar problem with a Bluetooth 5.0 phone on iDrive before? I'm trying to narrow the problem down to my phone or the iDrive system (2013 335 E92).
Appreciate 0
      10-23-2017, 09:10 AM   #2
hz_diesel
Major
89
Rep
1,396
Posts

Drives: 2012 E92 335ix
Join Date: Jun 2015
Location: New England

iTrader: (6)

Quote:
Originally Posted by cRo5 View Post
I received my Pixel 2 XL a few days ago and one huge compliant I have is that every 30 or so minutes of playing music over Bluetooth, the phone disconnects with a loud high-pitched sound, then reconnects automatically a few minutes later. I've never had this problem with any previous phones (Nexus 6P, iPhone 7 Plus), yet this is my first phone with Bluetooth 5.0.

Has anyone had a similar problem with a Bluetooth 5.0 phone on iDrive before? I'm trying to narrow the problem down to my phone or the iDrive system (2013 335 E92).
I have a issue with my m4 but never had a issue on my 335ix. I am using my pixel xl still. I can chime in at the end of this week when I receive my pixel 2 xl. Jealous you have yours already.
Appreciate 0
      10-23-2017, 05:21 PM   #3
cRo5
2013 E92 335i MSport
cRo5's Avatar
United_States
5
Rep
53
Posts

Drives: E92
Join Date: Jun 2015
Location: MA VT NC

iTrader: (0)

Garage List
Quote:
Originally Posted by hz_diesel View Post
I have a issue with my m4 but never had a issue on my 335ix. I am using my pixel xl still. I can chime in at the end of this week when I receive my pixel 2 xl. Jealous you have yours already.
I'll have to try it out on my dad's F30 and see if the problem persists. There aren't many phones with Bluetooth 5.0 out there, so troubleshooting is tricky.

When you receive your Pixel 2 XL, let me know if you have a similar issue. Besides that, the phone is an amazing experience (4 days in, no display issues ((yet)).
Appreciate 0
      10-24-2017, 06:51 AM   #4
hz_diesel
Major
89
Rep
1,396
Posts

Drives: 2012 E92 335ix
Join Date: Jun 2015
Location: New England

iTrader: (6)

Quote:
Originally Posted by cRo5 View Post
I'll have to try it out on my dad's F30 and see if the problem persists. There aren't many phones with Bluetooth 5.0 out there, so troubleshooting is tricky.

When you receive your Pixel 2 XL, let me know if you have a similar issue. Besides that, the phone is an amazing experience (4 days in, no display issues ((yet)).
Will do, it shipped yesterday. Which case are you using? JW
Appreciate 0
      10-24-2017, 01:44 PM   #5
cRo5
2013 E92 335i MSport
cRo5's Avatar
United_States
5
Rep
53
Posts

Drives: E92
Join Date: Jun 2015
Location: MA VT NC

iTrader: (0)

Garage List
Quote:
Originally Posted by hz_diesel View Post
Will do, it shipped yesterday. Which case are you using? JW
Using this case- basic and no issues with it besides that it's snug and needs some force to remove- 4/5:

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Using this screen protector- mine doesn't slide around and feels great, however there is a slight rainbow effect as mentioned in the reviews- 3/5:

https://www.amazon.com/Protector-amF...dp/B075WW69PS/
Appreciate 0
      10-28-2017, 08:27 PM   #6
hz_diesel
Major
89
Rep
1,396
Posts

Drives: 2012 E92 335ix
Join Date: Jun 2015
Location: New England

iTrader: (6)

No issues on my m4
Appreciate 0
      11-01-2017, 08:37 AM   #7
cRo5
2013 E92 335i MSport
cRo5's Avatar
United_States
5
Rep
53
Posts

Drives: E92
Join Date: Jun 2015
Location: MA VT NC

iTrader: (0)

Garage List
Quote:
Originally Posted by hz_diesel View Post
No issues on my m4
Must be something to do with the older iDrive system- still having the same issues though it's reconnected as quick as 30 seconds.
Appreciate 0
      11-22-2017, 05:40 PM   #8
chris.gid
Enlisted Member
United Kingdom
1
Rep
32
Posts

Drives: F31 330d M Sport
Join Date: Feb 2015
Location: United Kingdom

iTrader: (0)

Any updates on this? Have tried my Pixel 2 XL with my F30 and get an error message when i connect over USB, says the device is not recognised.

Also have problems connecting over bluetooth and when i say 'hey google' it seems to disconnect the bluetooth.

Just moved from an iphone and everything worked fine
Appreciate 0
      12-01-2017, 01:34 PM   #9
vylanis
Registered
0
Rep
2
Posts

Drives: 2007 BMW 335i
Join Date: May 2013
Location: Woodinville, WA

iTrader: (0)

Apparently Bluetooth 5.0 is basically broken on any pre-2014 Combox. I have a Pixel 2 and can't stay connected for more than 15 seconds or so.

Supposedly the ConnectedDrive update to software versions MX-3.5.4, TX-3.5.8, TX-2.6.6, MX-1.12.0 will fix this, but you need option 6FL (USB in armrest) to do the update without having the BMW ISTA/P tool, so I have not been able to apply the update and try to fix it.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:01 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST