E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > 2011 iDrive losing memory



Reply
 
Thread Tools Search this Thread
      03-14-2017, 10:10 AM   #1
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
2011 iDrive losing memory

I have a 2011 with iDrive and comfort access. About 10% of the time when I shut the car off it will for the radio station it was on and be at 87.7. Now it has started to lose the split screen info sometimes. The screen is still split, but there is nothing on the right side (normally is radio station and RDS info). If I go turn the split screen off and back on again, then it comes back like normal.

Does anyone have any ideas of what it might be? I tried to get CPO to cover it, but my dealership is pretty worthless and I am out of CPO now. The only thing I can think is that maybe the battery is getting weak, but the car starts fine. Is there a backup battery for the iDrive somewhere like the CMOS in a computer so it can store it's memory?
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
      03-14-2017, 10:14 AM   #2
///Mposter
Macgyver
///Mposter's Avatar
United_States
91
Rep
882
Posts

Drives: 2007 e92 335i
Join Date: Jun 2011
Location: Greensboring

iTrader: (0)

Hook up a trickle charger overnight and when you start your car see if the station stays. If so then your battery capacity probably dropped below %60 or whatever the threshold is for memory.

I can tell you that after replacing my 6 year old battery and registering it, I have not had an issue with the radio, heated seats, or alarm light not blinking.
__________________
GTX3076R , ADV, JB4, FMIC, BOV, 17"APEX, 255/40/17 SQ, 6-SPD Manual
Appreciate 1
      03-16-2017, 04:13 PM   #3
vespa
Private First Class
64
Rep
166
Posts

Drives: 2011 335i
Join Date: Dec 2014
Location: Thousand Oaks

iTrader: (0)

My 2011 does this too and a new battery made no difference. It happens randomly, not just overnight -- sometimes I can just turn the car off and right back on without even opening the door and it will forget where it was.

It happens once out of every 10 or 20 starts and includes any random combination of:
  • The main screen goes back to the main menu instead of wherever I left it (usually "CD" USB or BT audio)
  • The radio comes on instead of USB or BT audio
  • The split screen goes to GPS coordinates
Appreciate 0
      03-17-2017, 09:57 AM   #4
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
Quote:
Originally Posted by vespa View Post
My 2011 does this too and a new battery made no difference. It happens randomly, not just overnight -- sometimes I can just turn the car off and right back on without even opening the door and it will forget where it was.

It happens once out of every 10 or 20 starts and includes any random combination of:
  • The main screen goes back to the main menu instead of wherever I left it (usually "CD" USB or BT audio)
  • The radio comes on instead of USB or BT audio
  • The split screen goes to GPS coordinates
That does sound very similar. My split screen just goes blank though, like it didn't load properly on boot. I think all of this is either it not keeping the memory from when it was turned off or a boot error.

Mine is also any time I turn the car off, I can run in a store for 10 minutes and come back out and it could have done it. The rate at which it happens is about the same as mine too.

Do you have comfort access? My comfort access computer was replaced about 2 years ago, but I don't know if that has any correlation. My issues started a bit after that and slowly became worse. Does anyone know if there is a battery backup in the head unit?
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
      03-17-2017, 10:02 PM   #5
vespa
Private First Class
64
Rep
166
Posts

Drives: 2011 335i
Join Date: Dec 2014
Location: Thousand Oaks

iTrader: (0)

I don't have comfort access. I do have a USB drive full of music and I do use iPhone BT streaming most of the time, both of which are very flakey. It was happening before I installed JB4 and a backup camera but I did try removing both and there was no improvement. I did mess with coding when I first got the car to turn off some gongs and stuff so it's possible I screwed something up there.
Appreciate 0
      03-18-2017, 02:40 AM   #6
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
Quote:
Originally Posted by vespa View Post
I don't have comfort access. I do have a USB drive full of music and I do use iPhone BT streaming most of the time, both of which are very flakey. It was happening before I installed JB4 and a backup camera but I did try removing both and there was no improvement. I did mess with coding when I first got the car to turn off some gongs and stuff so it's possible I screwed something up there.
I have had no coding done and mostly listen to the HD radio. Uninstalling JB4 makes no difference for me either. Now that I posted on here about it my car did it 3 out of 4 times I shut it off today. It is getting really annoying and I don't know where to start...
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
      03-19-2017, 03:26 AM   #7
Scrippy
Lord Scrip
Scrippy's Avatar
United_States
159
Rep
1,120
Posts

Drives: 2011 M3 Coupe
Join Date: Jan 2012
Location: LA,Ca

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
Sounds like a power issue. The guy who said he changed his battery might want to process the car with NCSExpert. Might have corrupt data from prior shitty battery. If that's not the case then a failing hard drive in your CIC.
__________________
Love it, clean it, maintain it and drive it like you stole it!
Appreciate 1
      06-17-2017, 11:45 AM   #8
SHEEDI
Colonel
SHEEDI's Avatar
United_States
275
Rep
2,503
Posts

Drives: 2009 335i - Sport PKG
Join Date: Jun 2009
Location: NY

iTrader: (0)

Garage List
2009 BMW 335i  [4.25]
IBS Sensor, I am recently having same issue and battery is also 8 years old, if your battery is 5 years or older, replace battery and IVBS Sensor cable
__________________
Appreciate 0
      06-18-2017, 12:23 PM   #9
vespa
Private First Class
64
Rep
166
Posts

Drives: 2011 335i
Join Date: Dec 2014
Location: Thousand Oaks

iTrader: (0)

I believe most of my idrive and Bluetooth issues are caused by the MP3's on my pen drive.
Appreciate 0
      06-18-2017, 01:33 PM   #10
david in germany
Captain
132
Rep
762
Posts

Drives: 118i
Join Date: Nov 2011
Location: Mannheim Germany

iTrader: (1)

Quote:
Originally Posted by JETmn View Post
I have a 2011 with iDrive and comfort access. About 10% of the time when I shut the car off it will for the radio station it was on and be at 87.7. Now it has started to lose the split screen info sometimes. The screen is still split, but there is nothing on the right side (normally is radio station and RDS info). If I go turn the split screen off and back on again, then it comes back like normal.

Does anyone have any ideas of what it might be? I tried to get CPO to cover it, but my dealership is pretty worthless and I am out of CPO now. The only thing I can think is that maybe the battery is getting weak, but the car starts fine. Is there a backup battery for the iDrive somewhere like the CMOS in a computer so it can store it's memory?
Sounds like a battery on the way out. Make sure you code the car to the new battery or any ghosts will continue to visit.
__________________
2009 118i Monaco Blue "Maximillion"
2009 335i Saphire Black M Sport "Leopold" Cobb tune, Mishimoto FMIC, Cobb charge pipe and Cyba scoops.
2011 328i Titan Silver M Sport "Franzel" <--Wife's car
Appreciate 0
      06-18-2017, 01:36 PM   #11
opjose
First Lieutenant
opjose's Avatar
41
Rep
358
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

A dying hard drive exhibiting striction may do this.
Appreciate 0
      06-19-2017, 11:20 AM   #12
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
Quote:
Originally Posted by david in germany View Post
Sounds like a battery on the way out. Make sure you code the car to the new battery or any ghosts will continue to visit.
It has been doing this for 2 years... I would have expected the battery to die in that time if that was the case. I looked up more info on the IBS, it might be an outside possibility but I don't seem to be losing power. It also sounds like the IBS won't cut power to the rest of the car, just the starter. The ECM still has power when the IBS is triggered because they pull codes. Thanks for the thoughts though, they were good things to check in to!

The HD could be a possibility. Not sure if that would have anything to do with the radio station memory. I would think that is all internal in the head unit.
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
      06-19-2017, 11:24 AM   #13
peterparker
Captain
63
Rep
701
Posts

Drives: e90
Join Date: Oct 2013
Location: Rochester NY

iTrader: (3)

Garage List
2009 BMW 335i  [0.00]
Weird.

For me, my trip odometer resets along with my clock. Usually on a daily basis, if not hourly basis.

And when I think it's all good again (No resets for a few trips). It resets.

So far I'm at 70 miles / 3 days! Wish me luck guys!
Appreciate 0
      06-19-2017, 03:26 PM   #14
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
Quote:
Originally Posted by peterparker View Post
Weird.

For me, my trip odometer resets along with my clock. Usually on a daily basis, if not hourly basis.

And when I think it's all good again (No resets for a few trips). It resets.

So far I'm at 70 miles / 3 days! Wish me luck guys!
Yeah, the only thing I notice is my radio station goes to 87.7 (static) randomly. Sometimes it will do it every other start, then it will go weeks without doing it. I will watch my trip odometer. I don't use it, so I am not sure if it is resetting at all too.
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
      06-19-2017, 04:50 PM   #15
opjose
First Lieutenant
opjose's Avatar
41
Rep
358
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

The HD stores station settings.
Appreciate 1
      06-20-2017, 09:00 AM   #16
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
Quote:
Originally Posted by opjose View Post
The HD stores station settings.
Any idea if I can pull it out and do a byte by byte copy with Acronis True Image on to a SSD? It would be awesome to get the system to boot up much faster!
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
      06-20-2017, 10:27 AM   #17
opjose
First Lieutenant
opjose's Avatar
41
Rep
358
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

Quote:
Originally Posted by JETmn View Post
Quote:
Originally Posted by opjose View Post
The HD stores station settings.
Any idea if I can pull it out and do a byte by byte copy with Acronis True Image on to a SSD? It would be awesome to get the system to boot up much faster!
There are many threads that detail cloning the HDD to a SDD.

The only major issue is that the BMW HDD uses an EIDE instead of SATA interface.
Appreciate 0
      06-20-2017, 12:27 PM   #18
JETmn
Major
United_States
131
Rep
1,465
Posts

Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Orlando

iTrader: (0)

Garage List
2011 335Xi  [0.00]
Quote:
Originally Posted by opjose View Post
There are many threads that detail cloning the HDD to a SDD.

The only major issue is that the BMW HDD uses an EIDE instead of SATA interface.
Ewww, that does make life difficult. I will do some searching, thanks!
__________________
2011 335Xi 6AT - Pure Stage 1 turbo - JB4 - E30 - xHP Stage 3 - Strongflex tension bushings
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:09 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST