E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY Powered seat retrofit (WIP)



Reply
 
Thread Tools Search this Thread
      02-25-2015, 09:53 AM   #287
b-man
Major
b-man's Avatar
United_States
396
Rep
1,087
Posts

Drives: 328xi
Join Date: Jan 2013
Location: maine

iTrader: (2)

Quote:
Originally Posted by b-man View Post
I had nonsport seats with heat and lumbar. I just installed sport seats with heat and lumbar.

My old seats used pin 7 for lumbar, but the new seats use pin 9 for lumbar and side bolsters. So pin 7 has power but is not being used, pin 9 is being used but has no power.

Can I just modify my car's harness and move the cable from pin 7 to pin 9? Pin 7 is thin and pin 9 is wide, so I want to make sure it won't cause any problems.
any help?
Appreciate 0
      02-25-2015, 02:58 PM   #288
cmg5461
First Lieutenant
United_States
37
Rep
317
Posts

Drives: 2008 Deep Green 335xi 6MT
Join Date: Sep 2014
Location: Falling Waters, WV

iTrader: (1)

Garage List
2008 BMW 335xi  [0.00]
I retrofitted sport seats into my non sport 335. My factory seats are heat, power and memory. The sport seats I bought are heat, power and memory also. The passenger seat went in fine - bolsters work. Completely plug and play.

The drivers side, however, clicks (relay sound) when I try to move it to bolt it in. It also clicks when I press every other button on the seat. I have a feeling its the module that came with the seat. I'm going to swap modules from my factory seat to the new sport seat to see what that does.

Any ideas what is causing this?
__________________
Appreciate 0
      02-26-2015, 03:42 PM   #289
b-man
Major
b-man's Avatar
United_States
396
Rep
1,087
Posts

Drives: 328xi
Join Date: Jan 2013
Location: maine

iTrader: (2)

Where can I find those connectors to connect pins, instead of soldering them?
Appreciate 0
      03-10-2015, 05:51 AM   #290
FX_Munkee
Registered
1
Rep
3
Posts

Drives: 325D M Sport
Join Date: Feb 2015
Location: UK

iTrader: (0)

You can get the connectors form your BMW dealer.

Thanks very much for a really helpful guide, I've just completed my interior swap. I went from manual sports seats with no heating, to fully electric, heated memory seats. Just about everything you need to know is in this guide. I'll just add a couple of bits that I can remember that aren't mentioned here.

If you've got a RHD car the screws to remove the fusebox are really hidden, you can do it though, you just need long drivers (250mm) use T20 and T15 (for the ones you have to hit at an angle.

If you're adding the PWM cable for passenger heating into X14270 (the long one on the back of the JBE). Note that once you remove the plug, you then have to slide the pin holder out of the plug housing. This stumped me for a while as it wasn't obvious.

Don't worry too much about what the pin outs are for fuses you're supposed to use in the fusebox, when you get it out you'll realise that the connectors in the back are directly behind the fuses, so you can work it out with just the fusebox card and RealOEM, before you remove the fusebox.

One quick question for others that have done this. I haven't coded my car yet to tell it it has memory seats, and currently my wing mirrors reposition themselves (to somewhere not wanted) when I turn the car off. Is this normal? Will they stop doing that after I code it?
Appreciate 0
      03-19-2015, 10:06 AM   #291
b-man
Major
b-man's Avatar
United_States
396
Rep
1,087
Posts

Drives: 328xi
Join Date: Jan 2013
Location: maine

iTrader: (2)

Quote:
Originally Posted by FX_Munkee View Post
You can get the connectors form your BMW dealer.
I still feel like we're talking about different items. My pins don't align so I was hoping to pull out the pins and connect them outside the harness. Are you suggesting I buy a new harness(yellow housing)?
Appreciate 0
      06-08-2015, 04:53 PM   #292
Flyboyflash
New Member
0
Rep
7
Posts

Drives: 228i
Join Date: Feb 2015
Location: South Carolina

iTrader: (0)

F22 Pin Out Diagrams

Do you know where I can find pin out diagrams for an f22? Specifically, I'm looking for male/female f connectors under the seats. I'm trying to install 2014 220d power seats (w/o lumbar) in a 2015 228i with mechanical (heated) seats. I know the + and - wires from the wiring harness to the seat blade pins, but cannot determine the correct wiring for the sensors and other pins.
Many thanks,
Flyboyflash
Appreciate 0
      10-20-2015, 07:28 AM   #293
alien07
Enlisted Member
0
Rep
33
Posts

Drives: BMW E92
Join Date: Jun 2015
Location: QLD

iTrader: (0)

Hi Guys,

Need some help. I have the normal electric seats with no seat heater. I've bought E87 seats that are fully adjustable with seat heater (I don't need the heating function though).

I've done the:
1. Moved Pin #9 to #4 (Pin 9 is an empty slot on the seat),
2. Tapped the ground from #8 to #13
3. Tapped the 12v from #4 to #7 (For the side bolsters and lumbar).

The issue I have is: I can only do the seat adjustments (Front, back, tilt, backrest etc) only for like 15 seconds when i reconnect back the battery. After which, I cannot do any electronic adjustments at all except for the lumbar and bolsters. Tried turing off and on, only lumbar and bolsters. I need to disconnect the ground from the battery and then reconnect after a few minutes for it to have another 15 seconds to adjust.

Any insights?

Thanks.
Appreciate 0
      02-26-2016, 02:48 PM   #294
07_328i_Brett
New Member
07_328i_Brett's Avatar
United_States
0
Rep
8
Posts

Drives: 2007 328i sedan
Join Date: Feb 2016
Location: Northern Ky

iTrader: (0)

Seeking guidance from the vast knowledge here.. I'm a newby BMW owner, just purchased a 2007 328i (manufactured in S. Africa 10/2006). I got a great deal on the car, I'm fairly "handy" and comfortable with taking things part & reassembling them.
I've got a few gremlins to get rid of in the car, first was a yaw rate sensor that took the DTC offline, making driving in the snow more exciting than skydiving with an umbrella. $1,100 later, problem resolved.
Both the front seats were in rough shape, but of main concern was the passenger seat coding out for errors & deactivated ABS. Mechanic said it was likely a seat mat in need of replacing. I looked at links contained here at e90post, and decided it best & most economical to swap out the seats.
I found a great set on EBay, from an LCI 328i manufactured 10/2010 & ordered them up last week, should arrive in next couple days.
I used RealOEM with my VIN & also the VIN of donor vehicle. Everything seems to match up in the way of seating options, lumbar, memory, color, (SA 459 & 488); the only exception in the donor VIN is heated seats, which my 07 pre-LCI has (SA494).
1) Did the LCI seats have heating elements installed, just no control panel/switch on dash to turn on/off?
2) modules under seats have identical #'s for heating module but different module #'s for controlling seat adjuster & memory (07 pre-LCI seat module #61359196936; LCI seat module #61359264974).
3) what problems should I anticipate with installing these seats?
Appreciate 0
      04-24-2016, 11:32 AM   #295
terryd5150
Head Fry Cook at McBurgertown
167
Rep
442
Posts

Drives: 2008 335i 2006 325i
Join Date: May 2015
Location: SC

iTrader: (4)

Quote:
Originally Posted by cmg5461 View Post
I retrofitted sport seats into my non sport 335. My factory seats are heat, power and memory. The sport seats I bought are heat, power and memory also. The passenger seat went in fine - bolsters work. Completely plug and play.

The drivers side, however, clicks (relay sound) when I try to move it to bolt it in. It also clicks when I press every other button on the seat. I have a feeling its the module that came with the seat. I'm going to swap modules from my factory seat to the new sport seat to see what that does.

Any ideas what is causing this?
I'm doing the exact same retrofit.

Did the module swap fix the issue?
Appreciate 0
      04-24-2016, 06:15 PM   #296
cmg5461
First Lieutenant
United_States
37
Rep
317
Posts

Drives: 2008 Deep Green 335xi 6MT
Join Date: Sep 2014
Location: Falling Waters, WV

iTrader: (1)

Garage List
2008 BMW 335xi  [0.00]
Quote:
Originally Posted by terryd5150 View Post
I'm doing the exact same retrofit.

Did the module swap fix the issue?
No, I had to buy a new seat frame as the motors were toast.
__________________
Appreciate 1
      05-02-2016, 12:40 PM   #297
redhotrod
Registered
0
Rep
2
Posts

Drives: 1994 325ic
Join Date: Apr 2016
Location: Ohio USA

iTrader: (0)

Quote:
Originally Posted by rufsen View Post
Can anyone confirm that these are the connectors for the heating on the drivers seat? What about the passenger seat?




Which wires are ground and +12 on these outlets (seats are from an Z4 E89 2010)? I'm retrofitting these in an older car without canbus, therefore the question. My plan is to "hot-wire" the seat heating with an aftermarket external switch/relay. Any ideas?

I am trying the same thing, putting 2008 E92 powered heated seats in an E36 that had heated power seats. Where can I get a diagram of the under seat module?
Appreciate 0
      05-03-2016, 03:50 PM   #298
Najt
Second Lieutenant
No_Country
2
Rep
239
Posts

Drives: e92 325D 2008
Join Date: Jan 2010
Location: Europe

iTrader: (0)

Quote:
Originally Posted by alien07 View Post
Hi Guys,

The issue I have is: I can only do the seat adjustments (Front, back, tilt, backrest etc) only for like 15 seconds when i reconnect back the battery. After which, I cannot do any electronic adjustments at all except for the lumbar and bolsters. Tried turing off and on, only lumbar and bolsters. I need to disconnect the ground from the battery and then reconnect after a few minutes for it to have another 15 seconds to adjust.

Any insights?

Thanks.
I had exactly the same issue... its because your old seats have that small seat module..and the new one has the bigger one..which need also CAN cable ( i used cables from some foot module or how was it called) for comunication... i guess because of the memory or what ever..check mine post:

http://www.e90post.com/forums/showth...480313&page=10

Appreciate 0
      05-04-2016, 07:20 AM   #299
redhotrod
Registered
0
Rep
2
Posts

Drives: 1994 325ic
Join Date: Apr 2016
Location: Ohio USA

iTrader: (0)

So a car that does not have Kcan (my 1994 E36), is there a way to make a Kcan signal? Would +12V make the module happy?
Appreciate 0
      05-04-2016, 06:42 PM   #300
Najt
Second Lieutenant
No_Country
2
Rep
239
Posts

Drives: e92 325D 2008
Join Date: Jan 2010
Location: Europe

iTrader: (0)

hmmm..thats really good question... but I guess it was bad idea to put e9x seats to e36... it depends on equipment..and that seat module. Mine origin seat module was that small one...but when I bought Dakota brown .. they have the bigger one seat module which requires CAN connection.. read the whole thread from begining...there is quite a lot of usefull information. But almost every car has CAN BUS connection....the question is, if the seats will comunicat with the car

good luck
Appreciate 0
      06-14-2016, 06:34 PM   #301
Noise™
Registered
0
Rep
1
Posts

Drives: VW Gol
Join Date: Jun 2016
Location: Brazil

iTrader: (0)

Some help

Quote:
Originally Posted by woodpecka View Post
I think so.

Your only solution is to rebuild the wiring harness and not using the driver seat position module.

I have an extra passenger seat module if you need it.
Hello, mate.
I have the 130i M sport seats and I'm doing a a custon instalation on a Volks Wagen car.


I have the following problem in a customization (installing the seats on a Volkswagen):
The passenger seat works perfectly.
The driver's seat, is that when I feed it with 12V, the controls work normally, since I engage any of them within 10 seconds after connecting the 12V.
If you spend 10 seconds, the power is cut off, and so they come back to work, switch off the power, wait 45 seconds and turning it back on.
I'll give an example of use:

Suppose I connect the 12V on the seat and, before spending 10 seconds, I trigger some adjustment knob. While I regulate, it works normally can take 10 minutes activating the buttons, but if I do not set them off for 10 seconds, the power is cut.
For seat adjustment back to work, I need to disconnect the 12V, wait between 45 seconds and a minute and only then reconnect 12V.
I wonder if with this module you offered to another member of the forum, that my problem would be solved.

Another possibility would be to reconstruct the wiring, but this would give a tremendous job.

I apologize for posting this being four years after the original post, and I'm waiting for help.

Greeting.
Appreciate 0
      10-04-2016, 05:36 AM   #302
Najt
Second Lieutenant
No_Country
2
Rep
239
Posts

Drives: e92 325D 2008
Join Date: Jan 2010
Location: Europe

iTrader: (0)

show us the seats connectors under the seat
Appreciate 0
      10-04-2016, 03:59 PM   #303
ptpending
Captain
28
Rep
676
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (0)

Quote:
Originally Posted by Noise™ View Post
Hello, mate.
I have the 130i M sport seats and I'm doing a a custon instalation on a Volks Wagen car.


I have the following problem in a customization (installing the seats on a Volkswagen):
The passenger seat works perfectly.
The driver's seat, is that when I feed it with 12V, the controls work normally, since I engage any of them within 10 seconds after connecting the 12V.
If you spend 10 seconds, the power is cut off, and so they come back to work, switch off the power, wait 45 seconds and turning it back on.
I'll give an example of use:

Suppose I connect the 12V on the seat and, before spending 10 seconds, I trigger some adjustment knob. While I regulate, it works normally can take 10 minutes activating the buttons, but if I do not set them off for 10 seconds, the power is cut.
For seat adjustment back to work, I need to disconnect the 12V, wait between 45 seconds and a minute and only then reconnect 12V.
I wonder if with this module you offered to another member of the forum, that my problem would be solved.

Another possibility would be to reconstruct the wiring, but this would give a tremendous job.

I apologize for posting this being four years after the original post, and I'm waiting for help.

Greeting.
driver seat have module which require can bus signals from car
you can use can interface to record can messages from real car and then program some arduino or raspberry to emulate car
or you can get seat switch module from RHD passenger seat which is same as your passenger switch (powering seat motor directly)
__________________
E91 2006. Retrofits:High beam assistant,Individual Audio,Autodim mirrors,CIC,Combox(USB and Bluetooth),Electric Sport Seats,Light package,Front PDC, Heated Steering Wheel,Happy Robot,Climate Comfort Windscreen,Black Line rear lights.
Appreciate 0
      11-02-2016, 10:32 AM   #304
zmiller08
Private
United_States
0
Rep
96
Posts

Drives: 2008 e90 335xi
Join Date: Oct 2012
Location: APPLETON,WI

iTrader: (1)

2009 bmw e92

First off im sure its been answered buttttt.

I have a 2009 335 coupe I currently have memory heated electric non sport seats going to memory, heated, electric, sport seats should be completely plug and play I would assume please correct me if wrong. Thanks in advance
__________________
straight pipe mhd led interior dci syle 95s m3 high spoiler
Appreciate 0
      11-28-2016, 05:53 AM   #305
Felix_928
Registered
0
Rep
2
Posts

Drives: E93 330d 2007
Join Date: Nov 2016
Location: Aachen, Germany

iTrader: (0)

Hey guys,

I just tried to code my heated seats in my E93, that my preowner retrofitted. But now I got some trouble, the whole FA (what's your English word for it?) is coded as it should be in NCS Expert (at least I think so), but none of the seats is getting heated
To get into some detail:
- according to INPA my junction box recognizes the signal of the heated seats switches below the climate control, but it says "only low" (is there some difference between heated seats low and high?)
- according to INPA I get the correct temperature of my seat cushions
- trying to heat the seats using INPA doesn't work either
- electric memory functionality etc. works just fine
- my car isn't in transport mode either
- I can't find the seat modules in NCS Expert but this seems to be normal with E9X models
- lordose and width control don't have wiring by now but this shouldn't affect heating? Or does ist?

Wiring should be correct, due to working memory functionality and the fact I get the temperature in INPA?

I know that there's a difference how heated seats are controlled depending on the fact if you got fully electric seats (signal via CAN) or just heated manual seats (signal via PWM). I read the whole thread twice by now and didn't find an answer yet.

Thank you so much and greetings from Germany
Felix
Appreciate 0
      12-02-2016, 10:29 PM   #306
azx33
Registered
0
Rep
1
Posts

Drives: 2011 335i
Join Date: Nov 2016
Location: Arizona

iTrader: (0)

I have read the thread and would like to do the seat swap. I have a 2006 325i with heated seats all options and a 2011 335i with non-heated seats with power and memory. Both E90s.

I would like to swap the 06 seats into my 11. Does anyone know for sure if this will work or not. I am a EE and will figure it out, but I am curious if anyone had tried this and found it to be a no go before I waste my time.

Thanks
Appreciate 0
      12-04-2016, 10:20 AM   #307
Felix_928
Registered
0
Rep
2
Posts

Drives: E93 330d 2007
Join Date: Nov 2016
Location: Aachen, Germany

iTrader: (0)

UPDATE: I just fixed it. It was a problem in NCS Expert, so I wasn't able to code my seat modules properly
Now it works fine!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:04 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST