E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > Rough running cylinder no faults



Reply
 
Thread Tools Search this Thread
      10-05-2016, 10:59 PM   #1
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Rough running cylinder no faults

The last few days I have been having a rough run at idle. No faults for cylinder 6 but the smother runnings reached almost 4 on the test plan via ista. I also see the SR values not so close to 0 during steasy cruise. Any idea? Injector failure. I have methanol and jbd on. And have it on my car for about 2.5 years.
Appreciate 0
      10-06-2016, 01:34 AM   #2
335duff
Private First Class
16
Rep
115
Posts

Drives: 2011 335d E90
Join Date: May 2015
Location: United States

iTrader: (0)

How do you know you have rough cylinder? What are your symptoms? How many miles? There are a slightly less than infinite amount of things that seem to cause rough running. What previous service has been performed on the car?

When my maf goes my car runs like shit but has no codes.

Any scr fault seems to make it run like shit

Could it be either of those?
Appreciate 0
      10-06-2016, 09:06 AM   #3
Andrew@FixMyVW
BimmerPost Supporting Vendor
Andrew@FixMyVW's Avatar
United_States
169
Rep
279
Posts


Drives: 2010 335D
Join Date: Jan 2016
Location: Dallas, GA

iTrader: (0)

Quote:
Originally Posted by 335dlci View Post
The last few days I have been having a rough run at idle. No faults for cylinder 6 but the smother runnings reached almost 4 on the test plan via ista. I also see the SR values not so close to 0 during steasy cruise. Any idea? Injector failure. I have methanol and jbd on. And have it on my car for about 2.5 years.
Does it run rough with the a/c off?
Appreciate 0
      10-06-2016, 11:23 AM   #4
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Andrew@FixMyVW View Post
Does it run rough with the a/c off?
Yeah. Wth all consumers off.
Appreciate 0
      10-06-2016, 11:27 AM   #5
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by 335duff View Post
How do you know you have rough cylinder? What are your symptoms? How many miles? There are a slightly less than infinite amount of things that seem to cause rough running. What previous service has been performed on the car?

When my maf goes my car runs like shit but has no codes.

Any scr fault seems to make it run like shit

Could it be either of those?
I could feel it like a slight misfire. I'm at 70k. I am using ista's test plan for smooth running to find the current conditon and values of cylinder 6. All my services are up to date. I have never had CBU. MAF has been replaced at approx 15k. No faults for the maf. Only I can see cylinder 6 is running higher than the other cylinders. I'll take a screenshot of it. Only started happening the day we arrived in the Seattle area after a 20 hour non stop drive from socal.
Appreciate 0
      10-07-2016, 01:01 PM   #6
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Appreciate 0
      10-07-2016, 01:02 PM   #7
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

It's not out of range but it has been abnormaly rough at udle.
Appreciate 0
      10-07-2016, 02:14 PM   #8
ninja_zx11
Private First Class
Canada
36
Rep
177
Posts

Drives: X5 diesel 2009
Join Date: Jan 2014
Location: Langley BC,Canada

iTrader: (0)

Are you getting rough idle all the times or only when the engine is cold?
Appreciate 0
      10-07-2016, 04:48 PM   #9
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by ninja_zx11 View Post
Are you getting rough idle all the times or only when the engine is cold?
it's more noticable when cold but still can be felt when warm.
Appreciate 0
      10-07-2016, 05:34 PM   #10
lnxguy
Captain
81
Rep
717
Posts

Drives: 2009 335D
Join Date: Jun 2016
Location: Barrie

iTrader: (0)

For shits and gigs run a can of Diesel Purge through the engine.
__________________
'09 335D
Appreciate 0
      10-07-2016, 10:23 PM   #11
JOHNNYBRAVO1
NY BRAVEST
United_States
26
Rep
286
Posts

Drives: 2010 Monaco blue, 335D
Join Date: Mar 2016
Location: NEW YORK, LONG ISLAND

iTrader: (0)

Im thinking injector is going or shot. I've replaced all 6 for lost boost and power and boom power came back. Andrews been threw that also.
Appreciate 0
      10-08-2016, 12:26 AM   #12
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by JOHNNYBRAVO1 View Post
Im thinking injector is going or shot. I've replaced all 6 for lost boost and power and boom power came back. Andrews been threw that also.
Hopefully it makes it back 1100 miles before it fails lol. I'm on travel in Seattle from Los Angeles.
Appreciate 0
      10-08-2016, 01:30 AM   #13
JOHNNYBRAVO1
NY BRAVEST
United_States
26
Rep
286
Posts

Drives: 2010 Monaco blue, 335D
Join Date: Mar 2016
Location: NEW YORK, LONG ISLAND

iTrader: (0)

Hope the German gods look over you to make it back. 1100 ouch.
Appreciate 0
      10-08-2016, 11:43 AM   #14
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by JOHNNYBRAVO1 View Post
Hope the German gods look over you to make it back. 1100 ouch.
Drover up here non stop
Appreciate 0
      10-08-2016, 08:56 PM   #15
JOHNNYBRAVO1
NY BRAVEST
United_States
26
Rep
286
Posts

Drives: 2010 Monaco blue, 335D
Join Date: Mar 2016
Location: NEW YORK, LONG ISLAND

iTrader: (0)

Niceeee, German gods listened to your needs
Appreciate 0
      10-08-2016, 10:36 PM   #16
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by JOHNNYBRAVO1 View Post
Niceeee, German gods listened to your needs
Well it has been running rough since I did the 1100 mile drive, since Sunday. Driving back to socal early tmw morning.
Appreciate 0
      10-09-2016, 12:22 AM   #17
Yozh
Colonel
Yozh's Avatar
No_Country
420
Rep
2,175
Posts

Drives: 2011 335d M-Sport
Join Date: Mar 2014
Location: Wet Coast

iTrader: (4)

May try taking your JBD off for the drive back South and see if things will change.

PS: I did NorCal to SEA overnight in the summer - boring drive.
Appreciate 0
      11-23-2016, 09:56 PM   #18
Sti581
Private First Class
Sti581's Avatar
United_States
6
Rep
105
Posts

Drives: 2011 335d M-sport
Join Date: Apr 2016
Location: Milwaukee

iTrader: (0)

Anything come out of this? My buddy has issues similar if not identical to this. Curious what this is? There are no codes at all. How can you tell if the MAF is bad? Weird thing is that I unplugged it from the car while it was running and it didn't change anything the car ran the same. Do you think it's that?
Appreciate 0
      11-24-2016, 12:13 PM   #19
335dlci
Captain
41
Rep
710
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Sti581 View Post
Anything come out of this? My buddy has issues similar if not identical to this. Curious what this is? There are no codes at all. How can you tell if the MAF is bad? Weird thing is that I unplugged it from the car while it was running and it didn't change anything the car ran the same. Do you think it's that?
I believe it was either winterized fuel and/or a bad batch of diesel while I was up in the PNW. I haven't had a problem since a tank after that one tank of fuel. Dish I had more to add but it was very weird that it was a slight hesitation kind of stumble.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:01 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST