E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > did my turbo go bye bye??



Reply
 
Thread Tools Search this Thread
      08-12-2015, 10:49 PM   #1
almcbs
First Lieutenant
19
Rep
327
Posts

Drives: 2009 335i
Join Date: Oct 2014
Location: Alexandria VA

iTrader: (1)

did my turbo go bye bye??

Can someone take a look at these partial logs and tell me what you get from them? I didn't see any point going any farther in the logs than i did.

i'm not seeing over 6-7psi, no cel. Not sure if inlet pipes are known for coming off, but i can see that the front one is still on, but i can't tell if the back one is. Any help is greatly appreciated!!

Log.zip
Appreciate 0
      08-12-2015, 11:28 PM   #2
335NJ
Colonel
United_States
348
Rep
2,900
Posts

Drives: 2008 335i 6MT E90
Join Date: Feb 2014
Location: NJ/Philadelphia Suburbs

iTrader: (1)

Check all of the connections first, before assuming turbo failure.

Chargepipe connected? Etc.. If you have a JB4, what map is the car CURRENTLY in?

Also, a 30FF will typically pop-up when there's a certain amount of time (2-3 seconds I believe) that boost isn't hitting target. Did this happen suddenly?
__________________
BSM E90 6MT-JB4 G5 ISO-BMS DCI-Golf-Tee Mod-Hankook S1N2 Non-RFT-ER Chargepipe/TiAL BOV-E40 blend-VRSF V2's-M3 CDV-MHD/JB4 FLASH-VRSF 5" STEPPED FMIC
Appreciate 0
      08-13-2015, 07:27 AM   #3
almcbs
First Lieutenant
19
Rep
327
Posts

Drives: 2009 335i
Join Date: Oct 2014
Location: Alexandria VA

iTrader: (1)

Quote:
Originally Posted by 335NJ View Post
Check all of the connections first, before assuming turbo failure.

Chargepipe connected? Etc.. If you have a JB4, what map is the car CURRENTLY in?

Also, a 30FF will typically pop-up when there's a certain amount of time (2-3 seconds I believe) that boost isn't hitting target. Did this happen suddenly?
The only connection I couldn't check was the rear turbo inlet pipe. I plan to do a more thorough look this weekend when I finally get a break. Charge pipe, ic pipe, front TIP were all connected fine.

I believe that one of those logs was on map 5 and the other was on map 2.

The other thing puzzling me is that I am not getting the 30FF. After a while of boost not hitting target, I am getting the engine malfunction reduced power light, but when I check codes nothing is there.
Appreciate 0
      08-13-2015, 07:32 AM   #4
almcbs
First Lieutenant
19
Rep
327
Posts

Drives: 2009 335i
Join Date: Oct 2014
Location: Alexandria VA

iTrader: (1)

Also worth noting that I just thought of. A few days ago as I was leaving my car started making a loud scraping noise (easiest way I can think to describe it was as if something was stuck between the rotor and pad). I figured it was something with my brakes or bearing as it only made the noise when I was moving. I had the gf slowly move the car so I can try and see what the noise was and where it was coming from, and of course it stopped making the noise shortly after she got in. Nothing dropped or popped out, it just kind of seemed like whatever it was popped back in place.

Not sure if this is directly related to my issue but I figure I would throw it out there in case some one experienced this as well.
Appreciate 0
      08-13-2015, 06:01 PM   #5
MachWon
Private First Class
15
Rep
197
Posts

Drives: 2007 335i 6mt. JB4 + CDP's.
Join Date: Mar 2015
Location: .

iTrader: (0)

Your car will still build boost with the inlet off. You'll just be sucking in dirty air. I believe it's pretty common for the stock rear inlet to be loose/off on these cars. Make sure you don't turn off the car before pulling codes. 30ff should still be there either way, but it never hurts to try.

When did you notice your boost was low?
Appreciate 0
      08-13-2015, 06:58 PM   #6
almcbs
First Lieutenant
19
Rep
327
Posts

Drives: 2009 335i
Join Date: Oct 2014
Location: Alexandria VA

iTrader: (1)

Quote:
Originally Posted by MachWon
Your car will still build boost with the inlet off. You'll just be sucking in dirty air. I believe it's pretty common for the stock rear inlet to be loose/off on these cars. Make sure you don't turn off the car before pulling codes. 30ff should still be there either way, but it never hurts to try.

When did you notice your boost was low?
I've made the light come on purposely twice so that I could try and pull codes, nothing. Both times I've tried to put the codes before shutting off the car.

I wanna say about a week ago I noticed it felt slower, but confirmed 2 days ago that the boost was low. I noticed about 4 days that if I listen to the engine/exhaust while I'm steadily accelerating (3rd gear, 30%-40% throttle), it feels and sounds like it's pulsing the whole way up the rpm range. Hard to explain this, I might try to stick a go pro under the hood and record it lol
Appreciate 0
      08-14-2015, 01:43 AM   #7
MachWon
Private First Class
15
Rep
197
Posts

Drives: 2007 335i 6mt. JB4 + CDP's.
Join Date: Mar 2015
Location: .

iTrader: (0)

Do a boost leak test first, and if no leaks then check wastegates/wastegate solenoids/vacuum canisters.

If all else fails, make sure your cat converter(s?) isn't clogged. Had that problem on a 1.8t audi and the car would only make 6-7psi instead of 16-17psi.
Appreciate 0
      08-20-2015, 03:03 PM   #8
mirkwo0dforest
Enlisted Member
1
Rep
38
Posts

Drives: 2007 335i Coupe 6MT Sport/Prem
Join Date: Jun 2015
Location: Richmond, Va

iTrader: (0)

Just a shot in the dark, but I had a similar problem a while ago and i had also heard a weird noise. Turns out the c-clip for the rear WG actuator rod popped off and the arm was just hanging, with that wastegate open all the time it was like a had one turbo. Worth a shot to check. Also, I don't have much XP with the newer JB4, but is you 3rd gear boost limited to 2psi, or is that BAR?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:35 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST