E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > *** Calling All Members With Problems With The 320i ***



Reply
 
Thread Tools Search this Thread
      11-21-2014, 02:51 PM   #1079
hussainpatel
hussainpatel
United Kingdom
0

 
Drives: E92 320i SE
Join Date: Jul 2014
Location: United Kingdom


Posts: 2
iTrader: (0)

BMW 320i jerking/loss of power/over revs

Hi guys,

Recently joined this forum in search for an answer....

I bought my first ever BMW (320i 50k) in July 2014. I had an Audi A3 2.0TDI which was an amazing car and never let me down.

320i SE 57 REG only 50k.

The 320i was my dream car, a gift to myself after graduation :-)

After buying the BMW, 2 months into driving it I noticed the following issues:
Jerking in gears 1/2/3
Loss of power when I put my foot down - almost like the engine is skipping a beat
Once at 10mph in 2nd the car jerked and cut off resulting in the engine management light coming on
Usually in the the first gear, occasionally I find the car revving quite high before moving off.

Gave it to a BMW specialist - diagnostics identified many sensors came up - cleared the memory and took it back two weeks later after the light came on that the NOX sensor was faulty. Replaced it at 450 and still same issues.

I feel extremely let down. After reading much on the 320i, these were common faults I gathered...

Common Problems:

Fuel Injectors
Coil Packs
High Pressure Fuel Pump
Spark Plugs
NOX Sensor
Cam Shaft Sensor
Vanos

Anyone with similar issues?

I don't feel there is a fairly straight forward answer for this issue. According to others who have paid out 0000's to fix the problem, the problem still hasn't been solved.
Appreciate 0
      11-21-2014, 06:12 PM   #1080
makkan00
Major General
United Kingdom
115

 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex


Posts: 7,398
iTrader: (48)

Sell your dream car and buy a normal car such as 325, 330, 335 i/d.
__________________
Appreciate 0
Reply

Bookmarks

Tags
320i, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST