E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Water Pump failure. Any experience? Cost?



Reply
 
Thread Tools Search this Thread
      11-27-2013, 02:30 AM   #111
DocSolis
Enlisted Member
1
Rep
40
Posts

Drives: BMW 2008 E92 335i Sport
Join Date: Feb 2013
Location: Brownsville , TX

iTrader: (0)

My pump went out..I think. Driving home engine overheat warning came on pulled over cooled it down. Drove to the nearest parking lot.The over flow hose hose had split and was also leaking from the upper radiator hose nipple. The weird part was the small dent I noted today that came from under the hood around where the overflow hose is.
Appreciate 0
      11-27-2013, 03:10 PM   #112
TRoN
New Member
0
Rep
5
Posts

Drives: 2006 323i
Join Date: Nov 2013
Location: Canada

iTrader: (0)

Mine died a few months ago. 2006 323i(Canada), 175,000 km. Cost about $380 for pump, $80 for thermostat, I think $20 for new bolts and $25 for coolant. Labour by a friend of a friend was $150. Dealer would probably be 3 times that.
Appreciate 0
      12-20-2013, 01:16 PM   #113
asnieze
Registered
0
Rep
1
Posts

Drives: 2007 335i
Join Date: Dec 2013
Location: Philadelphia

iTrader: (0)

We have another winner here! Coming home from work last night (I have a 2007 335i, +sport pack, approx. 58,000 miles) get about two blocks from home, yellow temp warning pops. Panic. "Please God, not another problem, I just replaced a cracked rim two weeks ago". Another block, Red warning pops. Double panic, memories of being on I95 as a kid in my family's Dodge K-Car (hey, it was the 80's) with the engine massively over-heating run through my head. The fan starts going nuts. I get it to my complex's lot, albeit parked crookedly in a spot and shut the car off. Battery warning in yellow pops. I don't smell anything, no sweet smell of coolant, no steam from beneath the hood. I can't leave it all crooked ass in the spot, so I wait about 10 minutes and move the car maybe 4 feet, no problem, no fan noise, no warning. It was dark, so I didn't pop the hood. But from what I've read, it's definitely the water pump. I really love this car, but I've had more money spent on this car in 4 years than in my previous 20 years and 5 cars put together.
Appreciate 0
      01-15-2014, 01:52 AM   #114
rotarypower101
Private First Class
rotarypower101's Avatar
1
Rep
114
Posts

Drives: 335xi
Join Date: Jan 2013
Location: USA

iTrader: (0)

Has there ever been a statistical average of mileage and failure on this component for those that have had issues?

Just a rough guess but 70k?



How many have preemptively replaced this component?
Appreciate 0
      01-15-2014, 11:32 PM   #115
.fLip.
no more coupe :(
3
Rep
1,034
Posts

Drives: e90
Join Date: Feb 2012
Location: Miami

iTrader: (0)

i think thats around the same. but many have made it will over 100k. i got lucky and mine went out pretty much at home. i still feel its best to ride it out because people have changed their pump and it went out in 10k
Appreciate 0
      01-17-2014, 09:23 PM   #116
LittleBlue
Second Lieutenant
United_States
3
Rep
235
Posts

Drives: 2006 325i
Join Date: Jul 2007
Location: U.S.A

iTrader: (0)

Send a message via Yahoo to LittleBlue
mine went out at 60k miles. $1300. pump, thermostat and radiator flush.
Appreciate 0
      01-18-2014, 12:08 AM   #117
StealYourFace
Lieutenant Colonel
United_States
141
Rep
1,728
Posts

Drives: 2006 330i sport
Join Date: Jul 2009
Location: Shakedown Street, Buffalo NY

iTrader: (1)

At 138,500 I finally broke down for a preventative water pump/stat. Also did serp belt/tension again for preventative measure. Beats the shit out of being caught out on the road. This car has been damn good to me, no reason not to continue following a good PM schedule. This car will be in the family long after I am done with it. I'm 35, and have many younger fam members with their eyes on it
__________________
Appreciate 0
      01-26-2014, 12:32 PM   #118
kewlguy210
Private First Class
3
Rep
103
Posts

Drives: 06 330xi
Join Date: Feb 2013
Location: glassboro, nj

iTrader: (1)

I have 06 330xi with almost 55k. No sign of failure or anything. Do you guys think I should do preventative maintenance now? Or just buy water pump and thermostat to leave at home in case.
Appreciate 0
      01-26-2014, 05:31 PM   #119
woodpecka
Major
woodpecka's Avatar
Canada
30
Rep
1,032
Posts

Drives: E91
Join Date: May 2010
Location: Montreal

iTrader: (2)

Quote:
Originally Posted by kewlguy210 View Post
I have 06 330xi with almost 55k. No sign of failure or anything. Do you guys think I should do preventative maintenance now? Or just buy water pump and thermostat to leave at home in case.
I did change my WP as a preventive measure after 125 000 km.

55k is not a lot..
Appreciate 0
      01-27-2014, 12:01 PM   #120
StealYourFace
Lieutenant Colonel
United_States
141
Rep
1,728
Posts

Drives: 2006 330i sport
Join Date: Jul 2009
Location: Shakedown Street, Buffalo NY

iTrader: (1)

Quote:
Originally Posted by kewlguy210 View Post
I have 06 330xi with almost 55k. No sign of failure or anything. Do you guys think I should do preventative maintenance now? Or just buy water pump and thermostat to leave at home in case.
I'd buy the parts if I were you, can keep them in the trunk if you do a road trip more than 100 miles from home, just in case it lets go. It's an electric part that fails at the whim of the motor, unlike a traditional pump that fails more predictably based on miles (and noise and leaks).
__________________
Appreciate 0
      05-01-2014, 04:38 PM   #121
pkdan167
New Member
0
Rep
9
Posts

Drives: 2006 330i MT ZSP, CW
Join Date: Aug 2008
Location: Cleveland, OH

iTrader: (0)

+1

2006 330i with 106k miles on it. Had the yellow warning followed by the red warning this past Monday. After letting it cool down I drove the 2 miles home. Ordered my water pump and screws on Tuesday. Got the delivery today.

I had a low coolant warning this past winter and topped it off. Ran fine til now.

Not sure if it's a symptom or not but I hear a metallic rattling when idling before topping off the coolant. After filling it up it was quiet.

Hopefully I can replace it this weekend. The diys don't make it look too difficult. The one from bavauto seems very helpful too.
Appreciate 0
      05-03-2014, 07:56 PM   #122
Rayden
New Member
0
Rep
25
Posts

Drives: 2008 335i E90; 2007 X5 4.8i
Join Date: Nov 2013
Location: Houston, TX

iTrader: (0)

Looks like mine had just went out as well. Went on limp mode on an exit ramp that forks to North/South Beltway 8 in Houston couple of days ago. The coolant reservoir cap, when opened, had brown gooey slushy stuffs on it, and looking down the reservoir, it looks similar. Anyone had this before?
Appreciate 0
      05-04-2014, 11:11 AM   #123
3.1L Z
Private First Class
3.1L Z's Avatar
12
Rep
178
Posts

Drives: '09 E92, Cobb AP
Join Date: Jul 2012
Location: San Antonio

iTrader: (0)

Add me to the list. 65K. Nice feature of the Cobb unit. Ran the codes and failed water pump. Think I'm going to get the VDO brand unit and save $150 bucks. Certainly nothing great about the OEM unit!!!
__________________

'09 E92, Cobb AP
6 SP/3 Pedal
No Run Flats
DCI, & a 3.1L Stroker Z
Appreciate 0
      05-04-2014, 02:00 PM   #124
Richwm
Captain
Richwm's Avatar
United_States
29
Rep
900
Posts

Drives: 06 E90 330i 6MT, 01 E46 330i
Join Date: May 2006
Location: Canyon Country, CA.

iTrader: (0)

Garage List
2006 (Mar 05 build ...  [4.00]
2014 BMW/ 335i  [0.00]
2001 330i  [4.00]
Quote:
Originally Posted by Rayden View Post
Looks like mine had just went out as well. Went on limp mode on an exit ramp that forks to North/South Beltway 8 in Houston couple of days ago. The coolant reservoir cap, when opened, had brown gooey slushy stuffs on it, and looking down the reservoir, it looks similar. Anyone had this before?
That sounds like Oil in your coolant!
__________________
Mar 05 Build date,2006 E90 330i, Sport Package, Premium Package, TR MT-1's . V-1 Hard-wired power with custom V-1 Concealment Display . Rear fogs, Rear power outlet's, M short shifter knob, BlackLines, BMW Strut tower bar, CDV Delete, Front M3 wishbones + tension struts, BMW Performance shocks and springs, BMW Performance Brake kit F&R, OEM short shift kit. Rear M3 Guide rods and Wishbones.
2006 E-90 330i with 216,000 miles. 2014 F-30 335i 29k miles.
Appreciate 0
      05-04-2014, 03:54 PM   #125
joe__
New Member
0
Rep
25
Posts

Drives: 2007 328XI
Join Date: Jul 2013
Location: United States

iTrader: (0)

Mine went at 52k.

I plan on replacing it again myself around 120 just to be safe.
Appreciate 0
      05-04-2014, 05:04 PM   #126
maupineda
Second Lieutenant
12
Rep
299
Posts

Drives: E87 130i
Join Date: Jul 2012
Location: Mexico City

iTrader: (0)

What you think? Is it time or mileage that affects the most? Mi car is a 130i and it has only 36k miles (57k kms). Is it fine or is the time that kills them?
Appreciate 0
      05-04-2014, 10:41 PM   #127
Big Busa
Private
United_States
5
Rep
78
Posts

Drives: 15' 335i M Sport Saloon, soon!
Join Date: Jun 2013
Location: NC

iTrader: (0)

Garage List
Yup!!! Add me to the list. 07 335i 6mt sport, 80k. Died on Saturday while leaving a restaurant in Charlotte heading to the South Park mall. Was getting no warning but did have reduced power going from 1st to 2nd and 2nd to 3rd. Then at a light waiting to make a left turn, the dreaded yellow temp light, 10 secs later, RED! Good thing at the corner was a gas station. Pulled in going 1 mph because of the limp mode and had her towed home. Ordering the parts tomorrow and will do it myself. Will let you know how it goes.
Appreciate 0
      05-05-2014, 01:52 AM   #128
Rayden
New Member
0
Rep
25
Posts

Drives: 2008 335i E90; 2007 X5 4.8i
Join Date: Nov 2013
Location: Houston, TX

iTrader: (0)

That could be. Think leakage from head gasket?


Quote:
Originally Posted by Richwm View Post
That sounds like Oil in your coolant!
Appreciate 0
      05-05-2014, 10:53 AM   #129
Richwm
Captain
Richwm's Avatar
United_States
29
Rep
900
Posts

Drives: 06 E90 330i 6MT, 01 E46 330i
Join Date: May 2006
Location: Canyon Country, CA.

iTrader: (0)

Garage List
2006 (Mar 05 build ...  [4.00]
2014 BMW/ 335i  [0.00]
2001 330i  [4.00]
Quote:
Originally Posted by Rayden View Post
That could be. Think leakage from head gasket?
Could be, how long did the engine run after the light came on? Also might be the oil cooler gasket. I would drain the oil and look for coolant in your oil before you start the engine again.
__________________
Mar 05 Build date,2006 E90 330i, Sport Package, Premium Package, TR MT-1's . V-1 Hard-wired power with custom V-1 Concealment Display . Rear fogs, Rear power outlet's, M short shifter knob, BlackLines, BMW Strut tower bar, CDV Delete, Front M3 wishbones + tension struts, BMW Performance shocks and springs, BMW Performance Brake kit F&R, OEM short shift kit. Rear M3 Guide rods and Wishbones.
2006 E-90 330i with 216,000 miles. 2014 F-30 335i 29k miles.
Appreciate 0
      05-05-2014, 05:00 PM   #130
pkdan167
New Member
0
Rep
9
Posts

Drives: 2006 330i MT ZSP, CW
Join Date: Aug 2008
Location: Cleveland, OH

iTrader: (0)

just finished up replacing the water pump. less than $400 for the pump and screws from BavAuto. Took me less than 5 hours with this site's DIY and also changed my oil. The hardest part was the top screw on the pump. Drove the car around for 15 miles with no issues. Fan didn't kick in at turbo speed, no warning lights, or power loss.
Appreciate 0
      05-05-2014, 05:09 PM   #131
GoRomeo
Brigadier General
GoRomeo's Avatar
180
Rep
3,080
Posts

Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by pkdan167 View Post
just finished up replacing the water pump. less than $400 for the pump and screws from BavAuto. Took me less than 5 hours with this site's DIY and also changed my oil. The hardest part was the top screw on the pump. Drove the car around for 15 miles with no issues. Fan didn't kick in at turbo speed, no warning lights, or power loss.
Did you replace your thermostat?
Appreciate 0
      05-05-2014, 11:02 PM   #132
pauloxxi
Private
United_States
7
Rep
64
Posts

Drives: 2009 -328i / 2014 -320 XDrive
Join Date: May 2010
Location: Ohio

iTrader: (0)

Kind of bad 1/2 dozen pages in this forum thread dedicated only to failures on the water pump. I'm another one, left stranded outside the road with my wife.
It can happen to all car brands, but some others are not as expensive.
Anyway, I have two BMW in my home, and was decided to replace one of them by an X3. However, I'm now starting to think that I do not need to invest as much, by going to a different brand.

Last edited by pauloxxi; 05-06-2014 at 08:14 AM.
Appreciate 0
Reply

Bookmarks

Tags
tischer, waterpump

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:17 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST