E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > idrive controller not responding



Reply
 
Thread Tools Search this Thread
      06-14-2017, 11:38 AM   #1
davidmc1000
New Member
0
Rep
7
Posts

Drives: BMW 325D 2010 Grey
Join Date: Jun 2017
Location: Wales, UK

iTrader: (0)

Question idrive controller not responding

Hi all, I have a slight problem with the idrive controller. The system it self works as you can hover over the numbers on the radio and displays what you have saved and can and answer calls via Bluetooth. The issue is that the actual controller does not work can't do anything with it none of the buttons work. I've tried anot her controller that was the same part number but still nothing. Prior to the car going to the garage to get a new alternator alternator and battery as the car died, everything was working including the controller but after picking it back up it just doesn't work and the garage say it did when they had it . Can anyone please advise or give me any help I have no idea what else I can do apart fromantic taking it to the stealers and paying alot for it. TIA
Appreciate 0
      06-14-2017, 03:02 PM   #2
Sensible_
Lieutenant Colonel
181
Rep
1,715
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Which generation I drive are we talking about? CCC or CIC?

You should interrogate car with a BMW spec code reader or diagnostic software.

You could just take a punt and get a replacement controller. Better to investigate the problem than guess however.
Appreciate 1
      06-14-2017, 03:44 PM   #3
davidmc1000
New Member
0
Rep
7
Posts

Drives: BMW 325D 2010 Grey
Join Date: Jun 2017
Location: Wales, UK

iTrader: (0)

Not sure on the difference in terms of CCC / CIC. How would I be able to tell which one is which?

I have tried another controller but that also did not work so I presume its not just the controller.
Appreciate 0
      06-14-2017, 03:54 PM   #4
davidmc1000
New Member
0
Rep
7
Posts

Drives: BMW 325D 2010 Grey
Join Date: Jun 2017
Location: Wales, UK

iTrader: (0)

Okay I've just seen the difference between both CCC and CIC.
I have a CIC system if that's any help.
Appreciate 0
      06-14-2017, 04:01 PM   #5
Sensible_
Lieutenant Colonel
181
Rep
1,715
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Quote:
Originally Posted by davidmc1000 View Post
Not sure on the difference in terms of CCC / CIC. How would I be able to tell which one is which?

I have tried another controller but that also did not work so I presume its not just the controller.
Look at the attached pic. It's not e90 but the controllers are the same.

Left is CCC and right is for the newer CIC.

------

Do you have any diagnostic equipment?

Start by checking if the controller is getting a voltage by testing the power wire.

[IMG]https://5series.net/forums/attachmen...ve-gen-1-2.jpg[/IMG]
Appreciate 0
      06-14-2017, 04:10 PM   #6
davidmc1000
New Member
0
Rep
7
Posts

Drives: BMW 325D 2010 Grey
Join Date: Jun 2017
Location: Wales, UK

iTrader: (0)

Yeah its definitely CIC. Currently don't have anything to hand to check and would either need to borrow stuff from a friend at the garage or just pick stuff up to test. Just have no idea as to why it just suddenly stopped working. Would changing the battery and alternator have anything to do with it ?
Appreciate 0
      07-18-2017, 10:45 AM   #7
davidmc1000
New Member
0
Rep
7
Posts

Drives: BMW 325D 2010 Grey
Join Date: Jun 2017
Location: Wales, UK

iTrader: (0)

Exclamation

Hello all again,

just an update on the situation but the controller is still not working even after purchasing another controller and fitted. Restarted the idrive system with the mute and eject button still nothing. Any help again is appreciated. By the looks of it will have to bite the bullet and go to the stealers
Appreciate 0
      09-14-2017, 10:23 AM   #8
Mashman
Private First Class
29
Rep
149
Posts

Drives: E93
Join Date: Apr 2016
Location: Heaven / TX

iTrader: (0)

The controller should have a 4 wire connector, GND/12v/KCan1-Low/KCan1-High - The first thing I would check is to make sure the GND is connecting to ground, and the 12v is actually getting 12v. If there is nothing wrong with those, then the issue is with the kcan wires.

You can splice into the kcan bus (use a twisted pair from a cat-5 cable, and solder connections), and run a new connection to the controller if you need to, but I would try to find where the issue is. What was it in the garage for? Any chance they worked under the center console?
__________________
I keep getting robbed because I leave the front door open..

I could close it but I feel doing so would be a victory for the thieves....
Appreciate 0
      09-25-2017, 04:56 PM   #9
davidmc1000
New Member
0
Rep
7
Posts

Drives: BMW 325D 2010 Grey
Join Date: Jun 2017
Location: Wales, UK

iTrader: (0)

Quote:
Originally Posted by Mashman View Post
The controller should have a 4 wire connector, GND/12v/KCan1-Low/KCan1-High - The first thing I would check is to make sure the GND is connecting to ground, and the 12v is actually getting 12v. If there is nothing wrong with those, then the issue is with the kcan wires.

You can splice into the kcan bus (use a twisted pair from a cat-5 cable, and solder connections), and run a new connection to the controller if you need to, but I would try to find where the issue is. What was it in the garage for? Any chance they worked under the center console?
Thanks for your reply. Sorry for the long delay. Went into the garage for the alternator and battery to be replaced, but later found that they had spilt liquid down near the controller and is quite sticky on the 4 pin wire where the connector is. Luckily no where near the gearbox. So what i'm going to try is to get some electrical cleaner and see if that would help. Since having the tyre pressure pop up i've been unable to reset and is driving me nuts.
Appreciate 0
Reply

Bookmarks

Tags
controller, idrive, not responding

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:06 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST