E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Mis-firing when warm



Reply
 
Thread Tools Search this Thread
      12-13-2017, 11:48 AM   #23
whitelightning
New Member
1
Rep
21
Posts

Drives: 2007 e92 335
Join Date: Jul 2011
Location: Columbia SC

iTrader: (1)

Any update on this? I am headed down this same path with similar symptoms.
Appreciate 0
      12-13-2017, 09:01 PM   #24
torrque
Private First Class
torrque's Avatar
15
Rep
133
Posts

Drives: 335xi sedan
Join Date: Apr 2014
Location: Newton, MA

iTrader: (0)

Garage List
Hi; mine is experiencing a similar issue, no codes, and heavy bucking, or shutdown. My rpm's drop to zero when the shutdown happens, and recover in split second. No codes either.
It has new injectors, plugs, coil packs, both fuel pumps, battery, alternator, walnut blast done. I will report back, but mine is an electrical issue... do some logging and monitor fuel pwm , battery voltage and o2 sensors voltage, see what you get when misfire happens.
__________________
_____________________________
2008 BMW 335xi sedan 6sp manual
2016 Shelby GT350 Track Pack
Appreciate 0
      12-14-2017, 09:21 PM   #25
=C=
Second Lieutenant
New Zealand
21
Rep
200
Posts

Drives: 2007 BMW 335i M-Sports E90
Join Date: Jul 2012
Location: Auckland, New Zealand

iTrader: (0)

Quote:
Originally Posted by rialnet View Post
MOSFETS done, no change.... into BMW we go :-(
Can you send / PM me info on how to check and replace the MOSFETS on a 335i 2007?
Appreciate 0
      12-15-2017, 12:04 PM   #26
torrque
Private First Class
torrque's Avatar
15
Rep
133
Posts

Drives: 335xi sedan
Join Date: Apr 2014
Location: Newton, MA

iTrader: (0)

Garage List
Quote:
Originally Posted by =C= View Post
Can you send / PM me info on how to check and replace the MOSFETS on a 335i 2007?


and here are the mosfets :

https://www.digikey.com/product-deta...MCT-ND/1566830

and one more thing, as an FYI, I swapped the whole DME with a MSD81, and my problem is exactly the same. I ran out of time and good weather (don't have a garage) so I took the car to a BMW shop...
__________________
_____________________________
2008 BMW 335xi sedan 6sp manual
2016 Shelby GT350 Track Pack
Appreciate 0
      12-16-2017, 04:00 AM   #27
=C=
Second Lieutenant
New Zealand
21
Rep
200
Posts

Drives: 2007 BMW 335i M-Sports E90
Join Date: Jul 2012
Location: Auckland, New Zealand

iTrader: (0)

Quote:
Originally Posted by torrque View Post


and here are the mosfets :

https://www.digikey.com/product-deta...MCT-ND/1566830

and one more thing, as an FYI, I swapped the whole DME with a MSD81, and my problem is exactly the same. I ran out of time and good weather (don't have a garage) so I took the car to a BMW shop...
Thanks, I checked all my MOSFETS and they're OK.

This is odd...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:57 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST