E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > e92 335i - Mulf unit has died



Reply
 
Thread Tools Search this Thread
      06-16-2016, 03:57 AM   #1
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

e92 335i - Mulf unit has died

Ive noticed my headunit has been taking a second or 2 to turn on for a few days, then noticed bluetooth wasnt working. tried accessing the menu to turn it on and all i get is "- -" showing on the display.

tried the heatgun fix/oven, but no joy. now the mulf unit is unplugged my radio is now turns on without the 1/2 second delay.

Ive had a look and it looks like people upgrade from mulf1 to a mulf2 from a mini.

Do i actually need any specific version/part number of the mulf 2 unit? i couldn't find a definitive answer from googling, some said you need to match, some don't.

I understand this will need coding, but will research that once the unit has arrived (i already have a laptop with ncsexpert and inpa etc installed on it)

My car already has bluetooth so i presume ill have less coding to do?

im also wondering if its worth upgrading to both aux and usb (i only have an AUX connection in the arm rest) (buying this)

Heres a list of my vin info

S644 - prep for f mobile phone w bluetooth
S663 - Radio BMW Professional
S672 - CD changer for 6 CD's
S676 - HiFI speaker system

Thanks!
Ross.
Appreciate 0
      06-16-2016, 05:13 AM   #2
ZeeWrath
New Member
United Kingdom
0
Rep
12
Posts

Drives: 2006 E92 325i SE
Join Date: Apr 2012
Location: Midlands

iTrader: (0)

on a 05 e90 with bluetooth prep

my mulf died

I tried a mulf2 high basis but the car wouldn't detect it had two dashes on the display next to tel.

I then tried a mulf 2 which functions but it cannot read the address book from my phone so you have to manually enter numbers the first time you use them.

This is all without any coding.
Appreciate 0
      06-16-2016, 06:00 AM   #3
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

Quote:
Originally Posted by ZeeWrath View Post
on a 05 e90 with bluetooth prep

my mulf died

I tried a mulf2 high basis but the car wouldn't detect it had two dashes on the display next to tel.

I then tried a mulf 2 which functions but it cannot read the address book from my phone so you have to manually enter numbers the first time you use them.

This is all without any coding.

Hi Zee,

i can confirm ive read the issues you have above, but i have also seen people fix these issues.

Whats the difference in a mulf 2 and a mulf 2 high basis?

Thanks
Ross.
Appreciate 0
      06-16-2016, 07:33 AM   #4
2real4u
Banned
7
Rep
160
Posts

Drives: bmw
Join Date: Mar 2016
Location: south

iTrader: (0)

USB in armrest
Appreciate 0
      06-16-2016, 08:06 AM   #5
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

Quote:
Originally Posted by 2real4u View Post
USB in armrest

Right, so if i want USB in my arm rest, i need to buy the high basis version. and then the cable i linked previously.

I've already got AUX in my arm rest, and the cd changer in the rear. So im guessing it would be.

1. fit new high basis mulf
2. run USB wire from boot to arm rest
3. plug cd changer in (and any other wiring)
4. code to car.
5. done

Ive checked this on ebay Will this be the sort of thing i need?

thank you!
Appreciate 0
      06-16-2016, 10:33 AM   #6
Aragorn30d
Lieutenant Colonel
111
Rep
1,592
Posts

Drives: E90 330d
Join Date: Mar 2015
Location: Fife

iTrader: (0)

I fitted a Mulf2 Hi in mine, bluetooth worked fine, but not bothered sorting the USB yet.

If it doesnt work, it will need coding. I believe various models were fitted with a MULF2 Hi but didnt have bluetooth enabled, and if you were to just plug that in without coding it wouldnt work.
Appreciate 0
      06-16-2016, 10:41 AM   #7
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

Quote:
Originally Posted by Aragorn30d View Post
I fitted a Mulf2 Hi in mine, bluetooth worked fine, but not bothered sorting the USB yet.

If it doesnt work, it will need coding. I believe various models were fitted with a MULF2 Hi but didnt have bluetooth enabled, and if you were to just plug that in without coding it wouldnt work.
thanks
Appreciate 0
      06-17-2016, 03:33 AM   #8
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

just a quick update.

my aux works flawlessly without the MULF.

im guessing this means my AUX goes directly into the headunit. hopefully that makes installing the USB side of things easier.

mulf unit bought yesterday, so waiting on delivery.

Will update thread with install pics/ coding step by step once it all arrives.
Appreciate 0
      06-17-2016, 08:12 AM   #9
2real4u
Banned
7
Rep
160
Posts

Drives: bmw
Join Date: Mar 2016
Location: south

iTrader: (0)

For mulf with usb, run aux from armrest to mulf.
Appreciate 0
      06-17-2016, 09:29 AM   #10
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

Quote:
Originally Posted by 2real4u View Post
For mulf with usb, run aux from armrest to mulf.

ok so pull headunit and remove aux cable, rewire to new mulf in boot. and the mulf handles the interface presentation to the headunit instead of a direct connection.

or use the cable i listed above and the mulf will choose the new cable instead of re-locating the existing one wired into the back of the headunit
Appreciate 0
      07-01-2016, 05:00 PM   #11
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

just an update,

installed new mulf2 unit (shown below)


cd changer now works without skipping, However im still getting "- -" under the tel option. However ive noticed it just doesnt change at all, whereas my old mulf1 unit it would sometimes flicker the phone pair option.

Can anyone give me an idea on what i may need to do with coding for the bluetooth to enable?

my car had it on from factory. if it helps my cars feb 2007, ive read someone mentioned i need to alter the vin date temporarily etc.

Thanks
Ross.
Appreciate 0
      07-02-2016, 01:26 AM   #12
2real4u
Banned
7
Rep
160
Posts

Drives: bmw
Join Date: Mar 2016
Location: south

iTrader: (0)

I can sort out for you if happy to drive to Southampton.
Appreciate 0
      07-02-2016, 04:16 AM   #13
rossonza
New Member
1
Rep
27
Posts

Drives: e92 335i coupe
Join Date: Apr 2016
Location: united kingdom

iTrader: (0)

Quote:
Originally Posted by 2real4u View Post
I can sort out for you if happy to drive to Southampton.

really appreciate the offier but im a bit too far :-(

is it just a coding job? or does it need fitting into an lci car. coding and then back into mine?

located sutton Coldfield Birmingham.

cheers
Ross
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:41 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST