E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > JB3 HELP!



Reply
 
Thread Tools Search this Thread
      06-28-2009, 01:13 PM   #1
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

JB3 HELP!

Hey guys, I am in need of major help with my jb3. I recently installed a FMIC and since then I have had issues with my car. Dyno's showed the FMIC to flow much better and colder. Pulled 25whp on 91octane and AZ heat.

But lately my car throws the service engine light and goes into limp mode randomely. It's happened under full throttle, and on other ocasions as soon as I hit boost.

I don't have a BT Scan Tool and can't find one to use. I'm going to place an order for one today or tonight but wanted to see if anybody had some helpful input to figure this out...

I also pulled more power on map 3 than map 5 on 91, and I have kept it on map 3 since the dyno. I still have issues.

Keep in mind that before the FMIC install i had no issues with CEL's or limp mode. I ran it on map3 for the most part and map5 with no issues.

What could this be???????????

my car is a 2007 e92. 11,257 miles. pre 29.2 6mt

thanks
Appreciate 0
      06-28-2009, 01:16 PM   #2
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

HPFP or Boost Leak.

I'd start with checking the connections to the FMIC. Make sure you are using t-bolt clamps and that they are tight. Also check the connections to the charge pipe.

Other than that, it sounds like an HPFP problem. A Bav Tech scan will tell you for sure.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 01:22 PM   #3
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

sounds like the BT Scan tool is a must. I've read about the FPFP problems everybody seems to be having...if this is the case...it's covered under warranty...but i would have to take out JB3 for service (not a problem). But does the FMIC void warranty? i've read about it going both ways...

my other mods are DCI and exhaust. Stock DP's...
Appreciate 0
      06-28-2009, 01:23 PM   #4
Gibson6594
Major
563
Rep
1,035
Posts

Drives: 2016 SO M3
Join Date: May 2009
Location: NY

iTrader: (0)

Quote:
Originally Posted by sbdavis1 View Post
sounds like the BT Scan tool is a must. I've read about the FPFP problems everybody seems to be having...if this is the case...it's covered under warranty...but i would have to take out JB3 for service (not a problem). But does the FMIC void warranty? i've read about it going both ways...

my other mods are DCI and exhaust. Stock DP's...
It will only void the warrantly if the dealer can prove it to be the cause of the problem.
Appreciate 0
      06-28-2009, 01:34 PM   #5
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

Quote:
Originally Posted by coldasicex5 View Post
i had a pump replaced with my DCI and FMIC still in, dealer said they're not causes of the FP to go.. make sure you scan your car before bringing it in
thanks for the help. I'm going to orde the BT Scan right now just to make sure...worth the little bit of money to save the warranty.
Appreciate 0
      06-28-2009, 01:37 PM   #6
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

You know the more I think of it, this really does sound like a boost leak...especially if it started right after the FMIC install.

Does the CEL / Limp go away if you power down and restart? Does it only return when you are boosting? If so, that's a leak.

I had this happen because my charge pipe keeps blowing off the throttle body...but it could just as easily be a leak at the FMIC connections.

I would definitely target those areas while waiting on a BT scan.

And it's not the dealer that voids the warranty, it's BMWNA. And yes, even the FMIC can give them cause to do so. Don't listen to people telling you "they have to prove it caused X." At a minimum, if it is HPFP, even your intake can be enough for them to not cover its replacement.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 01:38 PM   #7
chinoxs203
Major
chinoxs203's Avatar
United_States
54
Rep
1,369
Posts

Drives: 08 E92 335xi AW
Join Date: Oct 2007
Location: CT

iTrader: (7)

IMO BT tool is a must with a JB now
__________________

FOR SALE:
Dropbox - please
Appreciate 0
      06-28-2009, 02:05 PM   #8
645Nm
only in it for the torque - awuleth'umshini wami
645Nm's Avatar
South Africa
16
Rep
425
Posts

Drives: sapphire black 335i
Join Date: Apr 2009
Location: nomad

iTrader: (0)

Garage List
2009 335i sedan  [0.00]
2005 120D  [0.00]
2007 335i sedan  [0.00]
Go to someone that can scan the car

I had CEL/limp modes randomly after installing FMIC and it only happened on jb3 map 3 onwards (with increase in boost).

Double check the FMIC connectors (this was my problem), causing boost leak. Connectors were not properly sealed. I reinstalled the FMIC and the car has been running on high boost maps 6 & 7 without any issues.

I don't think it is the JB3 since you haven't had the problem before installing the FMIC.

You could do a BT scan but if the boost leak is due to the FMIC not being properly connected the BT might not show any codes (as in my case) after the car threw MANY random CELs.

Also check the DCI connections especialy the (filter closest to the radiator), which connector might have been pushed out when FMIC was installed.

I know it is a pain to take off mods before going to the dealer. So, i suggest to scan the car as soon as possible - perhaps there is an independent BMW specilaist close to you that could scan it?
Only after you are sure it is not the FMIC/DCI/charpipe connections or JB3 would I take it to the dealer.
In any case the scan will show up if it is the HPFP and if it is take off as many of the mods such as JB3 and DCI before warranty work.

What type of FMIC?

Good luck...
__________________
Appreciate 0
      06-28-2009, 02:21 PM   #9
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

thanks guys for all of the help.

The car runs fine for a little while...then randomely will throw a cel and limp mode. I turn the car off and then it seems to be fine.

Because it's been an issue I have not driven the car hard at all....
Appreciate 0
      06-28-2009, 02:26 PM   #10
David 12
Major
David 12's Avatar
19
Rep
1,014
Posts

Drives: 2014 M5 BSM
Join Date: Jan 2007
Location: Omaha

iTrader: (0)

Time to go ahead and remove as much as possible and take it to the dealer.

It is frustrating, so the sooner the better. If I am not mistaken, you cannot throw a tuner code if you are pre 29.2.
Appreciate 0
      06-28-2009, 02:43 PM   #11
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

BT scan tool will be here this week hopefully. I will be checking for all possible boost leak options tonight and tomorrow. between the FMIC and the DV's, DCI, i hope it's just a small leak that can be sealed and fix the problem.

Should i keep my Jb3 on map3??? I will be driving the car as little as possible. And obviously not hard at all...
Appreciate 0
      06-28-2009, 03:25 PM   #12
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

what about spark plugs? could this be throwing the cel at all? i've read that a lot of the guys running the higher maps switch them out fairly early...

what do you guys recommend to replace them with? Bosch ones? or is there 1 stage cooler for higher boost levels?

how would i know when to change mine?

again 2007 11,2XX miles. SSTT for 5,000 miles...JB3 for last 1,000 miles
Appreciate 0
      06-28-2009, 03:29 PM   #13
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

Quote:
Originally Posted by sbdavis1 View Post
BT scan tool will be here this week hopefully. I will be checking for all possible boost leak options tonight and tomorrow. between the FMIC and the DV's, DCI, i hope it's just a small leak that can be sealed and fix the problem.

Should i keep my Jb3 on map3??? I will be driving the car as little as possible. And obviously not hard at all...
If it's a boost leak, it won't matter what map you're on. You could set the JB3 to map 0 (stock) and as soon as you get into boost you could throw the code.

I would take it to the shop that did your FMIC and have them check all those connections, and all the way up the charge pipe to the throttle body.

There is also a small chance you knocked one of the DV's when doing the intake...or maybe one is just leaking on it's own.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 03:31 PM   #14
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

Regarding plugs, unless you're running el cheapo gas, and/or using fuel additives, they are fine.

I changed mine at 7500 while doing my own oil change just for the fun of it. I've been on a tune since day one and they looked fine. You should be able to go at least 20k before even thinking about plugs.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 03:34 PM   #15
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

I just bought the Forge DV's a few weeks ago. I installed them no problem and had no issues prior to the FMIC install. I will double check all of the connections and have the FMIC looked at tomorrow morning first thing.
Appreciate 0
      06-28-2009, 03:44 PM   #16
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

Quote:
Originally Posted by sbdavis1 View Post
I just bought the Forge DV's a few weeks ago. I installed them no problem and had no issues prior to the FMIC install. I will double check all of the connections and have the FMIC looked at tomorrow morning first thing.
Well that was important info!!!!

I guarantee you that's the problem. The increase boost build and the FMIC...it's a leak. I'd put money on it. It's either the charge pipe where it meets the throttle body or it's the charge pipe and FMIC connection.

After I put on my forge DV's, I was fine for a few days and then POP! Off comes the charge pipe from the throttle body. It's a known problem. Do you remember hearing a pop or bang sound? It would have only happened once.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 04:38 PM   #17
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

sorry for leaving that out!

I dont remember a pop but it's super hot here...even at night. so windows are always up and music usually on as well.

i'm at work now and can't get out to make sure the DV is on there ok....

so you think it's likely to be the charge pipe?
Appreciate 0
      06-28-2009, 04:46 PM   #18
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

Quote:
Originally Posted by sbdavis1 View Post
sorry for leaving that out!

I dont remember a pop but it's super hot here...even at night. so windows are always up and music usually on as well.

i'm at work now and can't get out to make sure the DV is on there ok....

so you think it's likely to be the charge pipe?
Yep. The flow goes FMIC-->Charge Pipe (with DV's)-->Throttle Body

My CP blew right off the Throttle Body. What kind of intake are you running? Depending, it might be pretty easy to run your hand up there and see if the CP is off the TB. Otherwise, it's going to be one of the connections along the way from the CP to the FMIC.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 04:48 PM   #19
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

By the way, here's the thread when my leak started. http://www.e90post.com/forums/showthread.php?t=268734
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 04:51 PM   #20
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

Quote:
Originally Posted by ThorsHammer View Post
Yep. The flow goes FMIC-->Charge Pipe (with DV's)-->Throttle Body

My CP blew right off the Throttle Body. What kind of intake are you running? Depending, it might be pretty easy to run your hand up there and see if the CP is off the TB. Otherwise, it's going to be one of the connections along the way from the CP to the FMIC.
thanks for all the help. i work til 4 then i'll be diving into this....

i'm running the BMS DCI
Appreciate 0
      06-28-2009, 05:21 PM   #21
ThorsHammer
Major
ThorsHammer's Avatar
United_States
47
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

Quote:
Originally Posted by sbdavis1 View Post
thanks for all the help. i work til 4 then i'll be diving into this....

i'm running the BMS DCI
Too easy, then. Even if you have to remove the cones, I'd do it just to check the CP. The CP, where it meets the throttle body, has a pretty thick, brass-colored "clip" that lifts up/pushes down, on the end of the CP. If your CP has come off, just run a flathead screwdriver between the clip and the CP, and pull up. But if it's secure, just leave that alone.

Then, check the other end of the CP. Make sure the CP is pushed all the way into that coupling hose, and make sure any clamps are tight. If that doesn't fix the problem, you might want to put the stock DV's back on, just to see if they might be faulty. By the way, which color springs did you use?
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-28-2009, 06:14 PM   #22
sbdavis1
First Lieutenant
14
Rep
325
Posts

Drives: 335i
Join Date: Jul 2008
Location: tempe

iTrader: (2)

I bought the DV's used. with the Yellow springs installed. The DV closest to the FMIC seems to be lose. I can turn it about a 1/4'' each direction. Doesn't seem to be locking all the way down.

???

I see that the FDV have caused some problems similar to mine...as you experienced. Did you end up keeping the FDV on and upgrading your CP?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST