E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Gauge install help!



Reply
 
Thread Tools Search this Thread
      07-18-2009, 05:08 PM   #1
wonsungnabi
First Lieutenant
9
Rep
355
Posts

Drives: E92 335
Join Date: Dec 2007
Location: Boston MA

iTrader: (7)

Gauge install help!

Hi guys.

I was installing vent gauge, and i did something wrong.



I was trying to pull it right before Y connector. That thing was pretty tight. I pulled harder and i broke the other side.

What do i do? Somebody please help me.

Thanks in advance!


and is it safe to drive?

(I just sent a pm to rix)
Appreciate 0
      07-18-2009, 07:11 PM   #2
turb0
Second Lieutenant
turb0's Avatar
9
Rep
298
Posts

Drives: e92 335
Join Date: Jan 2008
Location: ATL

iTrader: (6)

just get a new T splitter (at any auto parts store) and switch the broken one out..no its not safe to drive like that you will be leaking boost
Appreciate 0
      07-18-2009, 07:28 PM   #3
wonsungnabi
First Lieutenant
9
Rep
355
Posts

Drives: E92 335
Join Date: Dec 2007
Location: Boston MA

iTrader: (7)

Thank you for you reply.
Appreciate 0
      07-18-2009, 07:58 PM   #4
scalbert
Major General
scalbert's Avatar
97
Rep
5,748
Posts

Drives: '13 S4, '15 Q7
Join Date: Feb 2007
Location: Woodstock, GA

iTrader: (8)

As mentioned, just get a new T or Y adapater at an autoparts store. Use a 5/32 inch fittings.
Appreciate 0
      07-18-2009, 09:44 PM   #5
RiXst3r
RiXst3r's Avatar
196
Rep
6,510
Posts

Drives: M235i
Join Date: Sep 2006
Location: Ohio

iTrader: (14)

Send a message via AIM to RiXst3r
You can use the T that came in the vent gauge kit to replace the Y and get you back to stock until you get a replacement.
Appreciate 0
      07-18-2009, 09:57 PM   #6
alextremo
Captain
United_States
23
Rep
951
Posts

Drives: F10 550i
Join Date: Sep 2008
Location: USA

iTrader: (4)

Happened to me too. Here is oem p/n if you want to put it back to stock (thx Rick!) but autozone T worked fine in the interim. BTW , if I recall correctly that part was about $8.

http://www.e90post.com/forums/showpo...68&postcount=3
Appreciate 0
      07-19-2009, 12:03 PM   #7
chiefsotos
Second Lieutenant
chiefsotos's Avatar
16
Rep
276
Posts

Drives: BMW 335 E93
Join Date: Jul 2008
Location: Greece

iTrader: (0)

I were in the same situation as you when i installed a boost gauge. Because i couldn't find a autostore near me, i drove the car about 50km til the dealer. There should be no problem at all, and you wont have any limps as long as you are pressing the gas pedal very gently and stable. No boost rising -> no leak!!!
If you try to remove again the t connections use some kind of oil in spray because it is really dificult to remove it without.
Appreciate 0
      07-19-2009, 06:19 PM   #8
wonsungnabi
First Lieutenant
9
Rep
355
Posts

Drives: E92 335
Join Date: Dec 2007
Location: Boston MA

iTrader: (7)

Yea.. I just put the tee from autozone half way for easy removal. The oem one from tischer is like $5. I will check local dealer to see if they have it in stock or i will order from tischer. Thanks guys for the help.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST