E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Trouble setting up BimmerGeeks Cable



Reply
 
Thread Tools Search this Thread
      12-16-2017, 12:18 PM   #1
azw131
Second Lieutenant
13
Rep
219
Posts

Drives: 2011 335i Xdrive M Sport Coupe
Join Date: Nov 2014
Location: Boston

iTrader: (2)

Trouble setting up BimmerGeeks Cable

Hoping there is a simple fix to this issue. Iím new to coding and trying to set up my bimmergeeks k dcan cable with the bmw V3 Coding Lite VM I am using. Under device manager, there is no ďportsĒ category in the tree. I think this is what I need to configure unless I am mistaken. USB serial devices is a category at the very bottom but doesnít let me change COM settings. Does the cable need a driver which isnít included? Any ideas?
__________________
Current Vehicles: 2014 Porsche Boxster S, 2011 335i Xdrive M Sport Coupe
Past Vehicles: 1983 Porsche 911 "RSR", 2013 Audi S4, 2011 335i Xdrive M Sport Coupe, 2015 M235i, 2011 335i Xdrive Coupe, 2006 330i, 2012 WRX, 2011 Camaro V6, 2004 325Xi
Appreciate 0
      12-16-2017, 12:57 PM   #2
LMB335IS
Sua Sponte
LMB335IS's Avatar
United_States
447
Rep
1,871
Posts

Drives: 2013 LMB 335is
Join Date: May 2008
Location: FOB FL

iTrader: (17)

Garage List
2013 BMW 335is  [4.42]
Quote:
Originally Posted by azw131 View Post
Hoping there is a simple fix to this issue. Iím new to coding and trying to set up my bimmergeeks k dcan cable with the bmw V3 Coding Lite VM I am using. Under device manager, there is no ďportsĒ category in the tree. I think this is what I need to configure unless I am mistaken. USB serial devices is a category at the very bottom but doesnít let me change COM settings. Does the cable need a driver which isnít included? Any ideas?
Do you have the cable plugged in to a USB port on your laptop when you try this?
__________________

335is/DCT/MHD/BQ Tuning
Appreciate 0
      12-16-2017, 01:33 PM   #3
azw131
Second Lieutenant
13
Rep
219
Posts

Drives: 2011 335i Xdrive M Sport Coupe
Join Date: Nov 2014
Location: Boston

iTrader: (2)

Yes i do. It doesnít seem to show up anywhere.
Appreciate 0
      12-16-2017, 01:56 PM   #4
rjahl
Major
rjahl's Avatar
209
Rep
1,165
Posts

Drives: Z4 3.5is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Quote:
Originally Posted by azw131 View Post
Yes i do. It doesnít seem to show up anywhere.
I hate to ask the obvious,

Have you contacted Bimmergeeks?
Appreciate 0
      12-16-2017, 02:04 PM   #5
azw131
Second Lieutenant
13
Rep
219
Posts

Drives: 2011 335i Xdrive M Sport Coupe
Join Date: Nov 2014
Location: Boston

iTrader: (2)

Quote:
Originally Posted by rjahl View Post
I hate to ask the obvious,

Have you contacted Bimmergeeks?
Definitely a valid question. I called them yesterday when I was having trouble getting the cable to work with INPA. They said to change the COM settings which sent me down this rabbit hole. I wanted to check here to make sure there wasnít something rudimentary I was missing before calling them again but thatís probably the route Iíll have to go now.
Appreciate 0
      12-16-2017, 02:24 PM   #6
ctuna
Major General
383
Rep
7,397
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

So what type of computer are you using ?
Why the VM is it and Apple?
Appreciate 0
      12-16-2017, 02:40 PM   #7
rjahl
Major
rjahl's Avatar
209
Rep
1,165
Posts

Drives: Z4 3.5is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Quote:
Originally Posted by azw131 View Post
Definitely a valid question. I called them yesterday when I was having trouble getting the cable to work with INPA. They said to change the COM settings which sent me down this rabbit hole. I wanted to check here to make sure there wasnít something rudimentary I was missing before calling them again but thatís probably the route Iíll have to go now.
You should see something like this in your device manager.

If you are using a VM, you will may need to enable t USB port on the VM
Attached Images
 
Appreciate 0
      12-16-2017, 06:16 PM   #8
azw131
Second Lieutenant
13
Rep
219
Posts

Drives: 2011 335i Xdrive M Sport Coupe
Join Date: Nov 2014
Location: Boston

iTrader: (2)

Quote:
Originally Posted by ctuna View Post
So what type of computer are you using ?
Why the VM is it and Apple?
Correct. It is a Mac that I am using the VM to run Windows in.
Appreciate 0
      12-16-2017, 06:34 PM   #9
azw131
Second Lieutenant
13
Rep
219
Posts

Drives: 2011 335i Xdrive M Sport Coupe
Join Date: Nov 2014
Location: Boston

iTrader: (2)

Quote:
Originally Posted by rjahl View Post
You should see something like this in your device manager.

If you are using a VM, you will may need to enable t USB port on the VM
Well I can’t believe I missed this. Not in the VM itself but in the Oracle VMware settings which I could configure from my Mac, I did not have “USB Serial Ports” checked as an option. Switched it on and got the VM to recognize/see the port. It auto installed a driver, then I changed the port settings to COM1 and latency to 1 as advised. But... INPA still won’t recognize the car as being connected.

EDIT: Bimmergeeks hopped on a screenshare with me and fixed it in 30 seconds. The Ediabis.ini file needed to have the connection type changed.

Last edited by azw131; 12-17-2017 at 11:51 PM.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:36 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST