E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!



Reply
 
Thread Tools Search this Thread
      08-15-2014, 12:57 PM   #1189
vnanh9x1
Registered
0
Rep
1
Posts

 
Drives: good
Join Date: Jul 2014
Location: New York

iTrader: (0)

When I hold the brake for a few seconds before pressing the button I dont get long cranks. Also, when I press the brake I hear something 'warming' up.

http://www.friv4.org.in
http://www.friv2ol.com
Appreciate 0
      08-15-2014, 01:06 PM   #1190
deeLow
Second Lieutenant
deeLow's Avatar
2
Rep
278
Posts

 
Drives: AW 335xi
Join Date: Jan 2014
Location: 732

iTrader: (2)

Quote:
Originally Posted by Kewill0360
Hi guys i have a 328i 07 i install Bms Powerbox on it and start the car since that day my car been revving up and down by itself some times its start and shut down right away took it to the stealer dealer and got told it was the throttle body and the dmtl pump...

ok i replace the throttle body my self since they say it was going to be 1k
and nothing the problem continues the dmtl they say is bad because check engine light is on and is not because is bad is because i did a run with out air intake on....

i dont know what else to think of could it be the HPFP??
Dunno if you ever figured it out but 1: you don't have a hpfp and 2: I highly doubt the dmtl pump is the cause of your problem. It's only function is to pressurize the gas tank and check for evap leaks.
Appreciate 0
      08-29-2014, 06:10 PM   #1191
gigadeath714
New Member
0
Rep
15
Posts

 
Drives: 2007 335i
Join Date: Aug 2013
Location: Orange, CA

iTrader: (0)

HPFP

My HPFP just went out I have an 07' E92 coupe and the odometer had just hit 50,043 miles. I took it to my local mechanic who read the codes as low pressure on the fuel pump, told me it was under warranty, he recomended that they replace the module switch on the fuel rail too as its a part of the entire system. Kuddo's to Steve Kulima @ Westcoast Autobahn in Orange, CA! I went to my local dealer at Crevier BMW and told them that my local guy diagnosed the HPFP. The BMW service advisor Dale was a good dude and said he would get back to me later that day or the following. Sure enough it was the HPFP which currently has a 10 year or, 120k mile warranty, however he said the switch on the fuel rail was not covered so I paid the $145 for the switch and now I'm back on the streets. I have noticed the new FP seems a bit sluggish from my older one, not sure if anyone has felt the same since theirs' were replaced or not but I just thought I would share mine. Also, Im not entirely sure what the warranty is on the new HPFP that they just replaced?
Appreciate 0
      10-19-2014, 08:09 AM   #1192
ChrisForPresident
Enlisted Member
United_States
0
Rep
37
Posts

 
Drives: '07 335i Sedan
Join Date: Jun 2012
Location: Jacksonville, Florida

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
70k, just got her a month ago and this was my first "hard drive".... 1/2 engine. Pull the code, HPFP. So, just call the dealership on Monday, tell them I had a 1/2 engine with HPFP code? I know its covered until 120k right? At least, I attempted to read the thread before commenting...
Appreciate 0
      10-30-2014, 05:30 AM   #1193
Underground6t9
First Lieutenant
Underground6t9's Avatar
4
Rep
335
Posts

 
Drives: BMW 335xi, Audi S4, Lex is250
Join Date: Jan 2014
Location: Cohoes, NY

iTrader: (1)

it looks like my HPFP is on the way out, im getting code cc-id 29. Im gonna take in to get it checked out, we'll see what happens.
Appreciate 0
      10-30-2014, 02:04 PM   #1194
j_mendieta
Registered
0
Rep
3
Posts

 
Drives: e90
Join Date: Oct 2014
Location: baldwinpark/fontana

iTrader: (0)

wasap everyone..

im new to this forum.. i had my 07 335i w/ 114000 miles for about 2 weeks. service enginesoon light and half engine light came on after heavy acceleration on the fwy on ramp..

codes p3090 and p142e came up.
loss of power (i assume limp mode)
engine fan is also on high.
some hesitation and rough idle at cold start this morning.

ive searched around and nones mentioned engine fan turning on...

sound like hpfp issue?

thanx
-jason

pls help me 9092748689
Appreciate 0
      10-30-2014, 02:28 PM   #1195
xcxxr335
New Member
0
Rep
8
Posts

 
Drives: black e90 335
Join Date: Jan 2014
Location: United States

iTrader: (0)

2011?
Appreciate 0
      10-31-2014, 04:08 PM   #1196
bootlip
Registered
0
Rep
2
Posts

 
Drives: 323i
Join Date: Oct 2014
Location: Virginia

iTrader: (0)

Great to read all this and I have the following question:
I am interested in buying a 07 335i sedan but not interested in having hassles
Would your advice to me be "stay away from a 335i completely?

Also could it be driving style that brings on the failures. I mean who can resist the temptation of flooring the car every now and then. Could this problem exist even if you drive the car with care and not floor it just because you can?

Lastly is that 120 miles extension just for the original owner or even valid for the 2nd and 3rd owners?
Appreciate 0
      11-04-2014, 10:19 PM   #1197
skyview
Registered
0
Rep
3
Posts

 
Drives: 2008 328xi Sedan
Join Date: Nov 2014
Location: New York

iTrader: (0)

Appreciate 0
      11-23-2014, 09:54 PM   #1198
Um3r
New Member
Um3r's Avatar
0
Rep
5
Posts

 
Drives: 2011 335i xDrive
Join Date: Nov 2014
Location: Pittsburgh, PA

iTrader: (0)

Garage List
Unhappy Help with diagnosis

I recently purchased my 11 E92 335XI CPO and have started to notice longer than usual crank times. The first one happened a week ago which I thought might be due to cold weather (28F), but I see/notice it happen more frequently now. Its 59F today and I am still getting longer initial cranks.

The first startup always takes longer, however if i turn the car off and back on the car starts up instantly. Waiting for 5 minutes and repeating resets the long/normal crank time cycle.

Before going to the dealer, I just wanted to be sure if it really looks like a problem? I am a little paranoid reading all the threads on the issue. Here are videos from two different days:

Cold Day:


Normal Day (Warmed up engine):


Thank you
Appreciate 0
      12-11-2014, 02:34 AM   #1199
hassanov
New Member
0
Rep
5
Posts

 
Drives: Deer
Join Date: Dec 2014
Location: Iraq

iTrader: (0)

Good post with good explanations.
__________________
Graduated from Soran University with First Class Degree with Honours in Computer Science.
Appreciate 0
      12-18-2014, 11:58 PM   #1200
924er
Lieutenant
9
Rep
407
Posts

 
Drives: 2010 335i coupe
Join Date: Feb 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Um3r View Post
I recently purchased my 11 E92 335XI CPO and have started to notice longer than usual crank times. The first one happened a week ago which I thought might be due to cold weather (28F), but I see/notice it happen more frequently now. Its 59F today and I am still getting longer initial cranks.

The first startup always takes longer, however if i turn the car off and back on the car starts up instantly. Waiting for 5 minutes and repeating resets the long/normal crank time cycle.

Before going to the dealer, I just wanted to be sure if it really looks like a problem? I am a little paranoid reading all the threads on the issue. Here are videos from two different days:

Cold Day:


Normal Day (Warmed up engine):


Thank you
so what ended up happening ? my car cranks long when warm like yours. does anyone else notice that????
Appreciate 0
      12-20-2014, 04:02 AM   #1201
Um3r
New Member
Um3r's Avatar
0
Rep
5
Posts

 
Drives: 2011 335i xDrive
Join Date: Nov 2014
Location: Pittsburgh, PA

iTrader: (0)

Garage List
Got the issue resolved yesterday.
I took it to the dealership for inspection and had to leave it overnight. The tech told me that he could not find any fault codes but said that the symptoms pointed towards fuel pressure issues. He applied a software update (SIB 121713) and now the slow cranks and jitteriness is gone. It also feels a lot more responsive. The best part is that it was covered under warranty

If you put your car in reverse and let it roll on its own do you feel it suddenly accelerating then slowing down randomly or sometimes the rpm fluctuates on idle?

Here is a screenshot of the report:
Attached Images
 
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST