E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > Minor screw up/ SES light on now



Reply
 
Thread Tools Search this Thread
      11-06-2013, 11:27 PM   #1
BB_cuda
First Lieutenant
 
BB_cuda's Avatar
 
Drives: 2011 335D Msport
Join Date: Nov 2011
Location: Clear Lake, Texas

Posts: 381
iTrader: (0)

Minor screw up/ SES light on now

SO, i removed several plastic parts in preparation for possibly removing my intake manifold. Main engine cover, upper and lower microfilter trays, strut braces, rear engine cover. I disconnected a connector just behind the dipstick tube holder that connects to the intake manifold. I stopped at that point had to deal with a non car thing. So, i'm about to resume tonight and realise i need my car much sooner than what time it will take to do proper cleaning and reassembly. So, i go ahead and reassemble everything without a hitch ...I thought.

I start the car and get a picture of an engine in the cluster with diagonally half of it colored yellow. In the NAV screen, it says reduced power. Lastly, SES light on cluster also. At this point, i remember the connector on the intake by the dipstick holder. I had left it unplugged...ARGH said Charlie Brown. Turn car off and plug in connector. Restart car and wierd engine graphic is gone but SES stays lit.

I've read where some of you get a SES light and turn car off and restart and SES light goes away. So, i drove in neighborhood and came home and turned engine off. Restart and SES is on for a brief instant and then goes off and then a couple seconds later comes back on.

Going to leave car locked all night and restart tomorrow morning and hope SES stays off. If not. I will call Indy. I will tell him all of the above. I would feel to possibly compromise warranty if i take it to dealer and tell them the truth. Car has 28,000 miles and 15 months of warranty left.

So, do I just need to clear the code with a BT cable or something equivalent. I don't have one and want to take care of this quickly. Thinking of going to my local INDY who has all of the BMW software and equipment. I presume he can clear this.
BB_cuda is offline  
0
Reply With Quote
      11-07-2013, 08:18 AM   #2
TDIwyse
Captain
 
Drives: 2011 335d
Join Date: Aug 2012
Location: MidWest

Posts: 889
iTrader: (0)

That little thing behind the dipstick is the MAP sensor. With it disconnected the DDE wouldn't know how much boost is being made. That's at least part of the problem for the reduced power mode. Usually you need multiple on/off cycles without the issue appearing again before the light will go off. Or you can just clear it with a tool (BT, Torque, just about any OBD II compatible scan tool, etc).

Good luck.
TDIwyse is offline  
0
Reply With Quote
      11-07-2013, 10:43 AM   #3
AzureHaze
Lieutenant Colonel
 
AzureHaze's Avatar
 
Drives: 2011 335d Sport
Join Date: Mar 2013
Location: SoCal

Posts: 1,503
iTrader: (0)

Nothing to stress about. Just clear the codes and you'll be set.
__________________
Mods: JBD @ 100% | Weisslicht LED side lenses | CF pillar trim | Cyba 4" dry carbon tips | CF trunk spoiler | LUX H8 V3 | 193M w/ Michelin PSS | BMS 12/15mm spacers | LTMW CF interior wrap | BSW Stage 1 | CF shifter trim | CF steering wheel trim | m-sport steering wheel | CF pedal set | CF license plate frames | Ziza LED interior kit | Euro side mirrors | Coded
AzureHaze is offline   United_States
0
Reply With Quote
      11-07-2013, 10:50 AM   #4
joe_planet
Lieutenant
 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

Posts: 567
iTrader: (1)

you could even keep driving until it goes away.. cause it will
you know, if you're lazy like me lol
joe_planet is offline   United_States
0
Reply With Quote
      11-07-2013, 12:24 PM   #5
gruppeM3
Private First Class
 
Drives: E46 M3, 335d M-Sport, 4.8is
Join Date: Aug 2010
Location: SoCal

Posts: 151
iTrader: (0)

Happened to me as well. I was installing a JBD though. For some reason it wasn't working and every time I turned on the car I would get the same problem. Reduced power and SES light. It went off after I turned the car on and off.
gruppeM3 is offline  
0
Reply With Quote
      11-07-2013, 12:39 PM   #6
BB_cuda
First Lieutenant
 
BB_cuda's Avatar
 
Drives: 2011 335D Msport
Join Date: Nov 2011
Location: Clear Lake, Texas

Posts: 381
iTrader: (0)

thanks to all. I drove it this morning again. SES came on after start up. Drove to a restaurant for breakfast. Upon startup when leaving Denny's, SES did not come back on JUST AS YOU ALL STATED. Drama over. I got in too big of a hurry by not reconnecting that harness back. I was very careful to not leave any tools under the hood.

Thanks TDI, i din't know that the manifold had a MAP sensor. I came to the same conclusion though that the sensor was there looking for boost pressure.
BB_cuda is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:40 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST