E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Vibration when turning at low speed?



Reply
 
Thread Tools Search this Thread
      10-15-2014, 02:02 PM   #133
onlyanupam
Registered
0
Rep
1
Posts

Drives: 2011 328i xdrive
Join Date: Oct 2014
Location: Jersey City

iTrader: (0)

2011 328xi

I had same problem and toook it to the dealer three times
1) trip could diagnose
2) changed the power steering pump- didnt fix the problem
3) changed transfer case and increased idle RPM fix 90% of the problem
I personally think it is design issue where the pump/Hydraulics is underpowered.
Appreciate 0
      10-16-2014, 02:28 PM   #134
RazRokz.!
Captain
RazRokz.!'s Avatar
15
Rep
659
Posts

Drives: 07 BMW 328i
Join Date: Aug 2011
Location: California

iTrader: (0)

Quote:
Originally Posted by onlyanupam View Post
I had same problem and toook it to the dealer three times
1) trip could diagnose
2) changed the power steering pump- didnt fix the problem
3) changed transfer case and increased idle RPM fix 90% of the problem
I personally think it is design issue where the pump/Hydraulics is underpowered.

Front strut mounts and tie rods. Mine were shot. Changed them when I had the bmw performance suspension kit installed. Issue is now gone...
Appreciate 0
      04-24-2015, 02:06 PM   #135
Blitzkrieg_e90
padewan
Blitzkrieg_e90's Avatar
0
Rep
44
Posts

Drives: silver 09 E90 335i sdn/dct/lci
Join Date: Apr 2015
Location: phoenix

iTrader: (0)

I am extremely dissapointed that there is no solution for this issue...I made the switch from audi (10 years driving the rings) and I recently bought a cpo 335i msport, at 1st right off the lot it did not do it, 2 weeks into the car and after some well enjoyed spirited driving...this nightmare came up....from what I read on this entire 7 page thread, it bums me out that bmw being as prestigious as they claim, will not fix the issue...I will be looking to trade in for an audi s4, which in my opinion is a more solid overall machine, the 335 is a blast to drive, but it's embarrassing wen I pull out of a crowded parking lot and ppl stare due to the sound and shuttering vibration of the car
Appreciate 0
      12-01-2015, 08:42 AM   #136
esso
New Member
0
Rep
7
Posts

Drives: Bmw E93 2013 conv
Join Date: Oct 2015
Location: Doha

iTrader: (0)

I have the same problem :/
Appreciate 0
      11-02-2016, 12:35 PM   #137
AudiIz4Gayz
Registered
0
Rep
1
Posts

Drives: 07 m coupe 09 m6
Join Date: Oct 2016
Location: Nyc

iTrader: (0)

I've had the issue with both a 07 z4 m coupe and 09 m6. It seems to be worse when I get better quality tires until the tires wear some. Right now I have a new set of Michelin PS 2s on the m6 and passengers think there is something wrong with the car in parking lots but I can drive it 100 mph and take my hands off the wheel and the alignment is perfect.
Appreciate 0
      12-07-2016, 06:20 PM   #138
RSKY65
Private First Class
United_States
10
Rep
100
Posts

Drives: 2008 328i Sedan Monaco Blue
Join Date: Nov 2016
Location: Tulare/Visalia, California

iTrader: (0)

I've had the same problem too after upgrading to M3 control arms, but it does go away a little when on a smoother surface, maybe its true that the PS and Rack are under powered depending on what tires you use currently using Michelin PSS, I guess just live with it.....
Appreciate 0
      01-28-2017, 03:47 AM   #139
BimmerMan2421
Enlisted Member
11
Rep
46
Posts

Drives: E34 525i & E53 X5 & E90 328i
Join Date: Oct 2016
Location: Victorville, CA

iTrader: (0)

Interesting this thread is still alive but I finally found my perfect e90 and purchased it on Tuesday and I noticed the car shudder whenever I turned the wheel all the way and was worried. So is this really a normal design flaw by BMW or has someone actually found a fix? (The RPM thing does make sense because when I turn at around 900 RPM there are no problems, but my E53 idles at 700 RPM when turning and there is zero shuddering). It's kinda embarrassing when you have friends and your BMW makes some shudder while parking into a tight spot. And its even weirder because my E34 and E53 have never had this problem. Also my car is a 2009 328i with 75k miles.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:52 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST