E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Rough Idle



Reply
 
Thread Tools Search this Thread
      04-05-2010, 06:00 PM   #1
BMW's Only
Private First Class
3
Rep
182
Posts

Drives: BMW
Join Date: Mar 2008
Location: Philadelphia, PA

iTrader: (0)

Rough Idle

Hi everyone,

So I've been bringing my car in to two different dealerships for rough idling on cold start and after the engine is warm. The dealerships have both told me that the rough idling is within spec and that it is similar to other 328i's. I have taken it in about 5-6times for this issue already. 49,6xxmiles on the car. Please let me know what your thoughts are on this.

Thanks!
Appreciate 0
      04-06-2010, 12:53 AM   #2
BMW's Only
Private First Class
3
Rep
182
Posts

Drives: BMW
Join Date: Mar 2008
Location: Philadelphia, PA

iTrader: (0)

bump... please help!
Appreciate 0
      04-06-2010, 11:56 PM   #3
e90pilot
Freight Dawg
e90pilot's Avatar
United_States
65
Rep
2,129
Posts

Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

iTrader: (3)

I do have a rough idle sometimes but it's very minor and it's beed doing it since it was new. It goes away after a few seconds. It doesn't seem have an effect on anything.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors

Last edited by e90pilot; 04-07-2010 at 01:31 PM.
Appreciate 0
      04-07-2010, 09:56 AM   #4
Perfectus
Major
Perfectus's Avatar
21
Rep
1,250
Posts

Drives: e92 335i/F10 528XI
Join Date: Jun 2009
Location: NOVA/MD

iTrader: (10)

I'm having the same issue in my 335, it started after my spark plugs were replaced. Two dealers told me it's normal.

Search for "seafoam" I'm going to try using it to clean my valves this weekend.
__________________
2012 528XI Saphire Black
Stock for now
2007 e92 335i - Monaco Blue
Injen DCI w/ Cyba Scoop - M-Tech Rear - ///M3 Rear Lip Spoiler - ///M5 SMG Shift Knob & iDrive Knob - BMW Performance Hand Brake - BMWCCA Member
Appreciate 0
      05-28-2010, 12:37 AM   #5
MCoupeCrazy
New Member
2
Rep
19
Posts

Drives: Z4MC
Join Date: Feb 2010
Location: Harrisburg

iTrader: (2)

I had rough idle in my 330xi which led to stalling, took it to two different dealers who both told me it was bad gas. The second dealer provided a gas analysis showing 15% alcohol in the gas. Switched gas stations (3 tanks ago) and so far no stalling and the idle has improved.
Appreciate 0
      05-28-2010, 12:40 AM   #6
mike3000fl
Banned
No_Country
96
Rep
2,731
Posts

Drives: 06 330i
Join Date: Feb 2010
Location: Tampa

iTrader: (0)

couple others cleared this up with a new airfilter (not the microfilter), fuel injector cleaner and MAF sensor cleaner.
Appreciate 0
      05-28-2010, 12:41 AM   #7
mike3000fl
Banned
No_Country
96
Rep
2,731
Posts

Drives: 06 330i
Join Date: Feb 2010
Location: Tampa

iTrader: (0)

Quote:
Originally Posted by Perfectus View Post
I'm having the same issue in my 335, it started after my spark plugs were replaced. Two dealers told me it's normal.

Search for "seafoam" I'm going to try using it to clean my valves this weekend.
i have heard great things about seafoam and some horror stories. search.
Appreciate 0
      05-28-2010, 09:52 AM   #8
Chriztofor
Colonel
Chriztofor's Avatar
United_States
75
Rep
2,783
Posts

Drives: '06 325i and '13 X5
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

Quote:
Originally Posted by BMW's Only View Post
Hi everyone,

So I've been bringing my car in to two different dealerships for rough idling on cold start and after the engine is warm. The dealerships have both told me that the rough idling is within spec and that it is similar to other 328i's. I have taken it in about 5-6times for this issue already. 49,6xxmiles on the car. Please let me know what your thoughts are on this.

Thanks!
I had the same problem. Fixed it by pouring Chevron Techron fuel injector cleaner in the gas tank. My theory is that the e90 does not have a user friendly way of replacing the fuel filter (it is integrated with the fuel pump and costs over $240 to replace) therefore dirty fuel is fouling up the injectors. Good luck and post an update.

Last edited by Chriztofor; 05-28-2010 at 09:58 AM.
Appreciate 0
      05-28-2010, 10:02 AM   #9
Chriztofor
Colonel
Chriztofor's Avatar
United_States
75
Rep
2,783
Posts

Drives: '06 325i and '13 X5
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

Here are some other suggestions

http://www.e90post.com/forums/showth...=1#post7371785
Appreciate 0
      06-01-2010, 11:26 PM   #10
Chriztofor
Colonel
Chriztofor's Avatar
United_States
75
Rep
2,783
Posts

Drives: '06 325i and '13 X5
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

Fyi, autozone is having a sale. Chevron Techron, buy 1 get 1 free
Appreciate 0
      06-03-2010, 11:24 AM   #11
rothwem
Captain
United_States
99
Rep
710
Posts

Drives: 2009 E91 328xi 6mt
Join Date: Apr 2009
Location: Raleigh, NC

iTrader: (0)

Garage List
Quote:
Originally Posted by BMW's Only View Post
Hi everyone,

So I've been bringing my car in to two different dealerships for rough idling on cold start and after the engine is warm. The dealerships have both told me that the rough idling is within spec and that it is similar to other 328i's. I have taken it in about 5-6times for this issue already. 49,6xxmiles on the car. Please let me know what your thoughts are on this.

Thanks!
haha, I'm sure they'll find the problem once you go out of warranty.
Appreciate 0
      06-03-2010, 11:36 AM   #12
Chriztofor
Colonel
Chriztofor's Avatar
United_States
75
Rep
2,783
Posts

Drives: '06 325i and '13 X5
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

^ boy that is sooooo true. I would bring it back after the warranty expires (maybe take it to another dealer before the warranty expires) and then they will tell you that you need all your injectors replaced. I would then whip out all my past complaints and see if they will repair it for free. If not, I would ask to see the general manager and then take it up with BMW NA.
Appreciate 0
      06-05-2010, 08:42 PM   #13
AW4GC
Captain
AW4GC's Avatar
United_States
23
Rep
700
Posts

Drives: 435 GranCoupe
Join Date: Dec 2009
Location: Orlando

iTrader: (7)

rough ride

i had the same problem. After i took it in two times before warranty was up. Said everything was good. Now that I am out of warranty today the belt tensioner bolt head was broken off. the belt was loose thats why it was riding rough this should be interesting come Monday.
Appreciate 0
      06-08-2010, 10:41 AM   #14
funk74
Second Lieutenant
funk74's Avatar
39
Rep
274
Posts

Drives: 2007 e90 335i
Join Date: Jun 2007
Location: Houston

iTrader: (0)

Garage List
I have been having a similar problem (2007 335i), but only on cold start ups usually in the morning or when i'm leaving work after a long day (problem is exagerrated when i start the car when it is parked in a front down angled position in the lot. At first if i gave it a little gas, the problem would just go away. Then one day i let it continue to idle by itself and eventually a engine malfunction light came on. It said engine malfunction, reduced power. Drive with caution and take it to the dealership. I then powered off the car and powered it back on an the problem went away.

I have about 33k miles on it and have taken it to the dealer 3 times now. First time they replaced the fuel pump and reprogrammed the car. Then it happened again, and they said the reprogramming can sometimes cause that and they had to replace a sensor. Now it happened again, coincidentally on the day i had the appointment as i was getting ready to go to the dealership. So this time instead of turning it off and restarting it, I kept it like that and drove it there with the malfunction light on. There was a big difference in driving it, I had no power to accelerate fast at any speed. They are saying it is probably the fuel pump and will check it out, but to me it seemed as if the turbo didn't kick in.

We'll see what they say about this.
Attached Images
  
Appreciate 0
      06-21-2010, 10:21 PM   #15
JBE9006
New Member
United_States
0
Rep
21
Posts

Drives: E90 330i/JB/Prem/Sport/STEP
Join Date: Oct 2009
Location: Brownsville, TX

iTrader: (0)

I wouldn't worry about rough idle @ cold start on N52's. My 330i had this but I haven't noticed it lately.

It would do a "brm brm brm brm brm brm and (then a normal) brrrrrrrrrrrrrrrrrrrrrrrrrrr

I started using shell 93 octane fuel and maybe that helped get rid of it.

BTW I'm at 77k mi.

Funk74, yours seems to be the HPFP.
Appreciate 0
      07-26-2010, 09:36 PM   #16
DoPedUpM3
El Carpe Diem
DoPedUpM3's Avatar
United_States
5
Rep
219
Posts

Drives: Porsche Turbo/ 335i Coupe
Join Date: May 2010
Location: Southern Cali.

iTrader: (4)

Garage List
2008 335i  [0.00]
Send a message via AIM to DoPedUpM3 Send a message via Yahoo to DoPedUpM3
Quote:
Originally Posted by funk74@hotmail.com View Post
I have been having a similar problem (2007 335i), but only on cold start ups usually in the morning or when i'm leaving work after a long day (problem is exagerrated when i start the car when it is parked in a front down angled position in the lot. At first if i gave it a little gas, the problem would just go away. Then one day i let it continue to idle by itself and eventually a engine malfunction light came on. It said engine malfunction, reduced power. Drive with caution and take it to the dealership. I then powered off the car and powered it back on an the problem went away.

I have about 33k miles on it and have taken it to the dealer 3 times now. First time they replaced the fuel pump and reprogrammed the car. Then it happened again, and they said the reprogramming can sometimes cause that and they had to replace a sensor. Now it happened again, coincidentally on the day i had the appointment as i was getting ready to go to the dealership. So this time instead of turning it off and restarting it, I kept it like that and drove it there with the malfunction light on. There was a big difference in driving it, I had no power to accelerate fast at any speed. They are saying it is probably the fuel pump and will check it out, but to me it seemed as if the turbo didn't kick in.

We'll see what they say about this.
Please give an update on your 335i. I experienced the same issues. Did you take it in? Thank you!
Appreciate 0
      07-30-2010, 08:33 PM   #17
DoPedUpM3
El Carpe Diem
DoPedUpM3's Avatar
United_States
5
Rep
219
Posts

Drives: Porsche Turbo/ 335i Coupe
Join Date: May 2010
Location: Southern Cali.

iTrader: (4)

Garage List
2008 335i  [0.00]
Send a message via AIM to DoPedUpM3 Send a message via Yahoo to DoPedUpM3
Alright! I just picked up my e92 335i equiped with a new HPFP. Thanks BMWNA!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:08 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST