E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Battery cable connector recall thread



Reply
 
Thread Tools Search this Thread
      04-19-2013, 05:05 PM   #89
sukh
New Member
Canada
0
Rep
7
Posts

Drives: E92 335i
Join Date: Nov 2012
Location: vancouver

iTrader: (0)

getting mine done on monday
Appreciate 0
      05-22-2013, 05:14 PM   #90
Stinger
Major
Stinger's Avatar
United_States
57
Rep
1,040
Posts

Drives: 2007 335i Convertible
Join Date: Apr 2007
Location: Southern California

iTrader: (1)

Garage List
2007 335i E93  [3.50]
1993 318is  [0.00]
1996 Z3 1.9  [0.00]
Quote:
Originally Posted by Temonio View Post
I'm affected. Had an issue that cost me $2200. My service guy called and told me that ill be getting it all back. Took the car up there today for basic paperwork.

Btw, what happened was a complete power outage. I couldn't even lock the doors. They replaced the junction box. Happened again two weeks later. Battery cable was melted to the frame. I was pretty ticked off as it happened just after the warranty expired. But I'm feeling a lil better now that I'm getting it all back. Only if the wifey didn't already know it...sigh
Did you ever get it all back? I had paid $1,700 back in fall 2011 when it failed on me, but then was told I may get a portion of it back. Got it fixed but then was told I get $0 back because the work I had done didn't replace the part with the new part from the recall because that part didn't "exist last year." So now I'm off to fight this with BMWNA after a bad experience with Century BMW in Alhambra, CA.
__________________
Appreciate 0
      05-23-2013, 06:45 AM   #91
CharlieBear
Second Lieutenant
4
Rep
236
Posts

Drives: 08 e92 white red sold bc uknow
Join Date: May 2012
Location: Cali

iTrader: (2)

got mine done. all good. odometer was reset, obviously.
Appreciate 0
      06-02-2013, 01:07 AM   #92
Lincoln30
Second Lieutenant
Lincoln30's Avatar
United_States
77
Rep
201
Posts

Drives: 2017 BMW M2
Join Date: Dec 2011
Location: Fort Worth, Tx

iTrader: (1)

Garage List
2017 BMW M2  [0.00]
Picked up my car today after getting the recall done and a water pump (under the CPO warranty). The water pump just locked up the other day and the car went into limp mode, I limped it about half a block to my garage and had it towed the next day.

The reason for my post, did anyone notice any difference in the car electrically??? I've had my V1 piggybacked on fuse 12 (ABS) for almost 18 months and it used to turn on with ACC (equal to position 1 on a car with a key). I plugged in the V1 after I picked up the car and noticed that it no longer turns off when the car shuts down (locking the doors). I check power at the fuse panel and 12 is now hot all the time. So, either the behavior of circuit 12 changed or the tech took it out and then forgot were it had been??? I found a good IGN circuit to move it to (equal to key position 2) but was wondering about the change?
__________________
2017 BMW M2 AW 6MT
2017 GMC Sierra Denali
1997 MB SL500, 19"AMG replicas
Past BMWs: E30 323i, E36 325is, E36 M3, E46 M3, E39 M5, E46 325i, E90 335i, F80 M3
Appreciate 0
      06-07-2013, 04:07 PM   #93
magungo
Private First Class
United_States
4
Rep
113
Posts

Drives: Honda Civic
Join Date: Aug 2009
Location: San Jose

iTrader: (4)

My SA just told me that this recall does not apply to diesels. Anyone else hear the same?
Appreciate 0
      06-07-2013, 06:08 PM   #94
TrentOSU
Lieutenant
United_States
8
Rep
599
Posts

Drives: 11' AW e90 335i M-Sport
Join Date: Aug 2012
Location: Corvallis, Oregon

iTrader: (1)

I just went in..I did receive a letter but went in and finished it.
Appreciate 0
      06-23-2013, 05:04 AM   #95
insane79
Major
insane79's Avatar
No_Country
46
Rep
1,091
Posts

Drives: E90 lci
Join Date: Apr 2012
Location: Earth

iTrader: (0)

got it done on my car yesterday, i got the battery discharge warning on the idrive & noticed it while driving back from the dealer, but after i reseted the clock the warning went, weird..
Appreciate 0
      07-08-2013, 12:03 PM   #96
Bash328I
Enlisted Member
United_States
6
Rep
44
Posts

Drives: 2009 328I Monaco Blue
Join Date: Feb 2012
Location: Bothell Wa

iTrader: (0)

Got my calbe replaced a few weeks ago and now i get a Service Engine Soon light on my car(I checked my gas cap and its screwed on Tightly)...i am not sure if they are related..Going in tomorrow to pay my 50$ to the dealership since i am on extended warranty now.
Appreciate 0
      07-12-2013, 04:41 PM   #97
Bash328I
Enlisted Member
United_States
6
Rep
44
Posts

Drives: 2009 328I Monaco Blue
Join Date: Feb 2012
Location: Bothell Wa

iTrader: (0)

The moment the SA said a few fuse were blown in my car i said to my self may be the cable thing caused it but turns out it was a shorted crank case ventilation heater.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:33 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST