E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Northwest > Question on Forge DVs installation



Reply
 
Thread Tools Search this Thread
      04-06-2010, 06:01 PM   #1
thwgw24
Major
thwgw24's Avatar
Taiwan
23
Rep
1,062
Posts

Drives: RB PWRED E90 N54 6MT
Join Date: Aug 2006
Location: Bellevue, WA

iTrader: (19)

Garage List
07' E90 335i  [0.00]
Question on Forge DVs installation

Installed Forge DVs and took the car out for a spin. The peak boost I was getting was 12.7 psi instead of 15.x psi or 16.1 psi prior to the installation. I'm currently running JB3 2.0 map 7. Seems like I'm getting a boost leak. As instructed, I turned the gray rings counterclockwise before I snap in the valves. I don't have to turn the gray clips clockwise after the valves are in place, do I? I'm not getting any check engine light or limp mode at this moment. So what is going on with the car?
__________________
RB Turbo/Procede V5/Vishnu PWM Meth Injection Kit/Vishnu DCI/AR Catless DP/AE Performance Exhaust(Sold)/Helix FMIC/Forge DVs/Rixster Vent Boost Gauge/Wavetrac LSD/KW V3/ACT Street Clutch Kit
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST