E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Vibration while braking at high speed



Reply
 
Thread Tools Search this Thread
      03-30-2015, 10:32 AM   #23
VFitzyR
Registered
0
Rep
3
Posts

Drives: 2007 BMW 335i SP LP WP
Join Date: Jan 2014
Location: United States

iTrader: (0)

Having the same annoying problem with my 07 335i (111K miles). Just replaced the front rotors(Power Stop slotted/drilled) and ceramic pads all around. This helped, but I still get the shake when braking at highway speed. When switching over from winter to summer wheels/tires yesterday, I noticed that I could feel the front brake pads making contact periodically when spinning the wheel. I suspect this points to warped rotors since I cleaned the hubs before putting the rotors on and the wheels were bolted down. The next step for me is to bring the new rotors to be resurfaced. The car is so nice, except for the brake vibration.
Appreciate 0
      09-10-2015, 10:58 AM   #24
SwissCheeseHead
Second Lieutenant
SwissCheeseHead's Avatar
2
Rep
239
Posts

Drives: '11 328it
Join Date: Feb 2013
Location: Madison, WI

iTrader: (0)

Bumping this thread up. I've been noticing this on my 2011 328i with 50K miles on it. Just doing a bit of research before I start replacing parts. Any help would be appreciated!
Appreciate 0
      09-10-2015, 02:34 PM   #25
dmv-ck
Private
1
Rep
66
Posts

Drives: 2010 335i Coupe
Join Date: Aug 2014
Location: Washington D.C.

iTrader: (0)

I'm at 55K miles and had similar issues. For me swapping out the rotors and pads resolved the issue.
__________________
2010 335i Coupe w/Sport Pkg, 6MT, BurgerTuning CDV, Dinan Intercooler, Dinan CAI, Dinan Exhaust, Dinan Oil Cooler, Dinan SSK, and Dinan Stage 3 Tune
Appreciate 0
      09-11-2015, 07:50 AM   #26
SwissCheeseHead
Second Lieutenant
SwissCheeseHead's Avatar
2
Rep
239
Posts

Drives: '11 328it
Join Date: Feb 2013
Location: Madison, WI

iTrader: (0)

Quote:
Originally Posted by dmv-ck View Post
I'm at 55K miles and had similar issues. For me swapping out the rotors and pads resolved the issue.
That was my first thought, but after reading this thread, it seems like that might not be the case. It's probably due for a brake job anyway, even though the warning light has not come up from the brakes already.

What did you end up using for brake parts? I was thinking about just getting OE replacement rotors and ceramic pads.
Appreciate 0
      09-15-2015, 11:09 AM   #27
dmv-ck
Private
1
Rep
66
Posts

Drives: 2010 335i Coupe
Join Date: Aug 2014
Location: Washington D.C.

iTrader: (0)

Quote:
Originally Posted by SwissCheeseHead View Post
That was my first thought, but after reading this thread, it seems like that might not be the case. It's probably due for a brake job anyway, even though the warning light has not come up from the brakes already.

What did you end up using for brake parts? I was thinking about just getting OE replacement rotors and ceramic pads.
I ended up getting meyle rotors and pagid red pads. OEM replacement would be fine as well - it all depends on your budget.
__________________
2010 335i Coupe w/Sport Pkg, 6MT, BurgerTuning CDV, Dinan Intercooler, Dinan CAI, Dinan Exhaust, Dinan Oil Cooler, Dinan SSK, and Dinan Stage 3 Tune
Appreciate 0
      09-15-2015, 11:42 AM   #28
feuer
Colonel
feuer's Avatar
United_States
287
Rep
2,315
Posts

Drives: e90 335i
Join Date: Apr 2015
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by dmv-ck View Post
I ended up getting meyle rotors and pagid red pads. OEM replacement would be fine as well - it all depends on your budget.
Hopefully the Mayle rotors will be trouble free!
http://www.e90post.com/forums/showpo...55&postcount=3
Appreciate 0
      09-15-2015, 12:47 PM   #29
neverdone
Captain
56
Rep
734
Posts

Drives: 128i
Join Date: Jun 2014
Location: calgary

iTrader: (0)

This must be a known issue by now. The amount of people experiencing the exact same issue at the exact same speed and all the necessary fixes makes me wonder.

My 2011 335 xDrive has done the same thing since I bought it. It goes away when speed drops to about 40mph.
Appreciate 0
      09-16-2015, 01:11 PM   #30
SwissCheeseHead
Second Lieutenant
SwissCheeseHead's Avatar
2
Rep
239
Posts

Drives: '11 328it
Join Date: Feb 2013
Location: Madison, WI

iTrader: (0)

Quote:
Originally Posted by dmv-ck View Post
I ended up getting meyle rotors and pagid red pads. OEM replacement would be fine as well - it all depends on your budget.
Just want to be able to brake without vibrations. It's my wife's DD.

Quote:
Originally Posted by feuer View Post
Hopefully the Mayle rotors will be trouble free!
http://www.e90post.com/forums/showpo...55&postcount=3
Dead link

Quote:
Originally Posted by neverdone View Post
This must be a known issue by now. The amount of people experiencing the exact same issue at the exact same speed and all the necessary fixes makes me wonder.

My 2011 335 xDrive has done the same thing since I bought it. It goes away when speed drops to about 40mph.
If it's a brake issue, then it's a wear issue, and BMW won't do anything about that. The big question is why there are so many different fixes for a similar problem. I'll probably do this in a month or so. I'll update when it's done.
Appreciate 0
      10-07-2015, 12:48 PM   #31
SwissCheeseHead
Second Lieutenant
SwissCheeseHead's Avatar
2
Rep
239
Posts

Drives: '11 328it
Join Date: Feb 2013
Location: Madison, WI

iTrader: (0)

Just to update, I ordered a rotor and pad kit from Rock Auto, and did all four rotors and pads, last weekend. Did a pad bed-in and the vibrations seem to be gone. The car had 50K miles on them. There was still a lot of pad material on the old pads though but I'm glad it fixed the vibrations.
Appreciate 0
      10-12-2015, 10:52 PM   #32
fmzip
Private
6
Rep
86
Posts

Drives: 2008 328xi, 2001 530i
Join Date: Dec 2012
Location: CT

iTrader: (0)

chasing shimmy issues is not fun!

On my E39 I literally replaced EVERY front end part and still had the shimmy. Turned out to be a bad rear tire.
Appreciate 0
      12-28-2015, 05:06 PM   #33
new0rder
Lowlife Republic
4
Rep
108
Posts

Drives: 06 325XI Monaco Blue
Join Date: Sep 2005
Location: NYC

iTrader: (0)

Garage List
2006 325xi  [0.00]
very interesting, My 325xi got 87000 miles on it, and I changed the brakes 2.5 years ago. and at 55+ mph it vibrates when braking, but at lower step 40mph- is ok. I will try to replace the front rotors see how it goes.
__________________
06 Monaco Blue Metallic 325xi
Appreciate 0
      01-07-2016, 02:20 PM   #34
Dommyem
New Member
United Kingdom
3
Rep
6
Posts

Drives: 335i E92 JB4
Join Date: Oct 2015
Location: Braintree Essex

iTrader: (0)

I have this issue (2007 335i 90k). Braking from 100 down to 70 seems to give the worst vibrations. I cant really notice much vibration under 50. I have had new discs all round, new pads, new bushes, all 4 wheels balanced, and still have the issue. My mechanic is getting despondent with the issue and it's really frustrating that we cannot solve it.
Appreciate 0
      01-07-2016, 10:51 PM   #35
E90Graphite07
Lieutenant
E90Graphite07's Avatar
United_States
22
Rep
523
Posts

Drives: 07 E90 335i
Join Date: Dec 2007
Location: Texas

iTrader: (0)

Quote:
Originally Posted by Dommyem View Post
I have this issue (2007 335i 90k). Braking from 100 down to 70 seems to give the worst vibrations. I cant really notice much vibration under 50. I have had new discs all round, new pads, new bushes, all 4 wheels balanced, and still have the issue. My mechanic is getting despondent with the issue and it's really frustrating that we cannot solve it.
Wheel(s) may be bent or out-of-round, bad wheel bearing/axle, defective tire (sidewall bubble, etc.); was it road-force balanced? Do the vibrations happen while braking? What shakes, the pedal and/or steering wheel?
__________________
2007 BMW 335i & 2006 Jeep Commander Limited HEMI
Join us on Facebook:
E90Post - Houston
Houston BMW DIY Services
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:57 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST