E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > When did your turbos fail?



View Poll Results: When did your turbos fail?
They haven't. 28 57.14%
0-50,000mi 1 2.04%
50k-75k 9 18.37%
75k-100k 6 12.24%
100k-125k 2 4.08%
125k++ 4 8.16%
Multiple Choice Poll. Voters: 49. You may not vote on this poll

Reply
 
Thread Tools Search this Thread
      09-01-2016, 01:39 PM   #1
stafebak
Enlisted Member
5
Rep
44
Posts

Drives: 2008 335XI Coupe
Join Date: Aug 2015
Location: Saint Paul, Minnesota

iTrader: (0)

When did your turbos fail?

Just curious what everyone is seeing and at what mileage? Did some searching and couldn't find a poll on it. Feel free to post mods if you feel like it.
Appreciate 0
      09-01-2016, 02:04 PM   #2
fredcase
Lieutenant
Canada
82
Rep
509
Posts

Drives: 2007 335i xdrive sedan
Join Date: Mar 2014
Location: edmonton ab

iTrader: (1)

Turbos are fine wastegates are on last legs

150k km

Dinan stage 2 since new

Fbo since 100k km
Appreciate 0
      09-01-2016, 02:22 PM   #3
techwhiz
Colonel
techwhiz's Avatar
United_States
223
Rep
2,726
Posts

Drives: e90 335i Sedan - Arctic
Join Date: Feb 2012
Location: Bay Area, Ca

iTrader: (4)

140K miles. Mostly freeway.
Cobb tuned.
No turbo noise.
__________________
Arctic Metallic\CF Splitters, Spoiler, Mirror Covers\LED Tails\LSD\Tinted\Coded\Apex EC7-19"\LED Angel Eyes\Gloss Black Grill\Integrated V1 & Galaxy Tab\M-Performance Brakes\Cobb Tuned\Resonator Removed and -> is your friend.
Appreciate 1
      09-01-2016, 02:26 PM   #4
Yourredness
New Member
2
Rep
17
Posts

Drives: 2007 335i
Join Date: Apr 2014
Location: VA Beach

iTrader: (0)

I upgraded to RB turbos at 85k. waste gates were going bad
Appreciate 0
      09-01-2016, 03:11 PM   #5
GaryR13G
Enlisted Member
7
Rep
30
Posts

Drives: 07 335i M6
Join Date: Aug 2015
Location: Eastern PA

iTrader: (0)

Are you asking about wastegates or the turbos themselves? My turbos pull fine now that I adjusted the wastegates, but I fear it's only a temporary fix. The turbos themselves are fine though and make great boost when the wastegates close.
Appreciate 0
      09-01-2016, 03:13 PM   #6
AZEgg3
335 Newb
AZEgg3's Avatar
United_States
3
Rep
27
Posts

Drives: 2010 335i XDrive M-Sport
Join Date: Aug 2014
Location: Phoenix AZ

iTrader: (0)

My front turbo wastegate failed at about 58k, it was stuck partially open. You could agitate the actuator to free it up, but it wouldnt last 5 minutes on the road. Dealer replaced both turbos under extended warranty.
Appreciate 0
      09-01-2016, 03:14 PM   #7
L0B5TA
I cant swim!
L0B5TA's Avatar
United_States
25
Rep
46
Posts

Drives: 335i
Join Date: Jun 2015
Location: NYC

iTrader: (0)

72k I have wastegate rattle but that's all
__________________
Appreciate 0
      09-01-2016, 05:09 PM   #8
335is-dct
Private First Class
89
Rep
189
Posts

Drives: 335is
Join Date: Dec 2015
Location: south florida

iTrader: (0)

My front turbo sheared it's turbine shaft at 51k.
Appreciate 0
      09-01-2016, 05:16 PM   #9
mxchris727
Lieutenant
mxchris727's Avatar
United_States
70
Rep
498
Posts

Drives: E93 335i, E39 (Both 6-speed)
Join Date: Aug 2012
Location: Wilton, CT/Boston, MA

iTrader: (0)

30K back in 2010. Turned out to be bad actuators, but they replaced both turbos anyways
__________________

BMW GT1 (INPA, DIS, WinKFP, ect..), ISTA/P & /D is up and running! PM me if you want to stop by and code your car.
Appreciate 0
      09-01-2016, 06:11 PM   #10
thakid22
Lieutenant
United_States
120
Rep
437
Posts

Drives: 2010 BMW E60 535i Sport
Join Date: May 2013
Location: Little Rock

iTrader: (0)

Min failed at 81k. Just in time for me to slide in under warranty.
Took the car in with 30ff code and wastegate rattle at idle. The code and the rattle appeared overnight, all of a sudden.
Every subsequent restart produced the 30ff at more than half throttle.

Dealer first replaced the boost solenoids. But kept the car an extra week to also replace the turbos.
I suspect the solenoids were fine to begin with, and the replacement turbos fixed the issue.
Appreciate 0
      09-02-2016, 12:21 PM   #11
ritzzzzzwik
Captain
ritzzzzzwik's Avatar
109
Rep
658
Posts

Drives: 2007 335i MT
Join Date: Oct 2014
Location: NOVA

iTrader: (0)

didnt really fail. Replaced due to excessive wastegate rattle. Was holding boost fine. Replaced at 110K miles, with another set of OEM. No issues 20K miles on them since. Mods the same.
__________________
2007 335i E92 MT | MFactory LSD | MHD/Wedge Tuned 93Oct | Stg2 lpfp BoostConcepts | VRSF DPs | VRSF 5" SteppedFMIC | DCI | VRSF CP | BMW SSK | Billstein PSS Coilovers | M3 Control Arms | Whiteline Rear SF Inserts | M219s + PSS | PE Mod
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:36 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST