E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Input on if O2 sensor problem or something else



Reply
 
Thread Tools Search this Thread
      02-02-2018, 03:16 AM   #1
tan_rich
Private First Class
7
Rep
117
Posts

Drives: 2013 335is
Join Date: Feb 2016
Location: OC

iTrader: (0)

Input on if O2 sensor problem or something else

Hi, well i have been chasing this weird O2 sensor, lambda, mixture control, idk anymore error for the past week. I've posted this on the MHD "take a look at my log thread" and gotta some help but they're unsure as well. Any input on what could be wrong would be greatly appreciated.

To note:
No downpipe fix is installed
New Primary O2 sensors
FBO
Double checked the O2 sensor locations and connection and they all seem good.
Injectors seem to be good, Index 11

Whats happened so far:
dec 20th
got the car back from dealer after they replaced both primary O2 sensors and OFHG

dec 20-27
was in Australia so car was sitting

jan 6th
i installed downpipes

jan 7th
i put in 2 gals e85
In this log my fuel scalars seem to be off but that may be due to the 2 gallons of e85
https://datazap.me/u/tanrich/mhd-sta...og=0&data=3-22

jan 13th
normal full tank of acn 91

jan 17th
i get a 2e90 fuel mixture error code, did a readapted for the Lamda, mass air, fuel, throttle to see if it fixes the issue.

jan 18th
did a log, noticed is my ltft bank 1 is on avg 3% higher at 15-17% vs bank 2 at 11-14% while cruising. I haven't gotten a SES or 2e90 code yet
https://datazap.me/u/tanrich/log-151...16-17-22-23-24

jan 19th
Bank 1 stft look high for having no more e85, lean after the shift
https://datazap.me/u/tanrich/log-151...og=0&data=3-22

jan 24th
Getting LTFT into WOT
https://datazap.me/u/tanrich/log-151...24-25-26-30-31

jan 29th
Got a 2C31: Oxygen Sensor emission control
https://datazap.me/u/tanrich/log-151...ata=3-16-17-24
https://datazap.me/u/tanrich/log-151...20-21-24-25-26

jan 31st
Here is a various partial throttle log on my way to school. What freaked me out is my LTFT1 went really low and my STFT started to shoot high.
I get a 29E0: Mixture control and 2C31: Oxygen Sensor emission control error as well.
https://datazap.me/u/tanrich/log-151...20-21-24-25-26

I was thinking maybe my secondary o2 sensors are going bad for my bank 1 system that seems to be the problem bank. The primaries should be okay since they are basically new, however they could have been damage or installed improperly.

Last edited by tan_rich; 02-03-2018 at 12:26 AM.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:07 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST