BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!

Thread Tools Search this Thread
      08-26-2015, 08:10 AM   #1233

Drives: 2008 335i Coupe
Join Date: Aug 2015
Location: Gulf Breeze, FL

iTrader: (0)

Hey guys!

My problem seems to have some of the symptoms explained in the HPFP problem, but other warnings lead me to believe it is something else. While driving to work last week my 335i jerked for a second while on the freeway and the "service engine soon" light came on for a second. The car ran fine until I got ready to leave work and a bunch of messages came on the idrive, the half engine showed up on the dash, and the car went into limp mode. These are the messages that I got:

Engine malfunction - reduced power
Malfunction in transmission
DSC malfunction
Start-off assistance malfunction
DBC malfunction

I'm taking the car to the dealership to get a diagnostics test this morning. Any suggestions on whether this is HPFP related or something else? Maybe the battery or alternator (Battery is about 1.5 years old).

I had the alternator/battery tested at O'reilly's and since they couldnt hook directly to the battery in the trunk, they had to use the connection under the hood. The said the battery tested out fine, but the alternator voltage regulator failed... I'm just not sure how accurate this test is since it was performed in the engine bay.

One last thing. The service history shows that the HPFP was changed back in 2010.
Appreciate 0
      10-04-2015, 11:07 AM   #1234
New Member

Drives: 08 335i
Join Date: Oct 2014
Location: Palm Beach, Fl

iTrader: (0)

So Ive been getting an awful lot of 2cf7-Throttle Body Potentiometer codes as well as a bunch of 29F1-Fuel Pressure Plausibility codes. As well as some Cylinder misfiring codes. I can clear all but the 2cf7 codes. Last night it caused the car to shut down completely and not even idle. I need my car. I'm on trauma call at a hospital quite often and need this taken care of.

I have done quite a lot of reading on here and have replaced the spark plugs. I have bought a new throttle body. I've replaced the battery. Im almost out of options. Is there any way this is the HPFP?! It's driving me insane!! Also, I bought the car at a used car dealer. I'm not the first owner. So I'm assuming the dealership wont do anything for me with extending any kind of warranty. Correct? Its an 08 335i.

Thanks for any help in advance!
Appreciate 0
      10-07-2015, 08:36 PM   #1235
JStang's Avatar

Drives: FBO E92 335i
Join Date: Dec 2010
Location: St. Petersburg, FL

iTrader: (8)

I'm happy to say that up until this point, I am one of the lucky ones who hasn't had to visit this thread. I recently started getting really rough starts with Code 29F2 and half engine symbol on cold starts. This would usually happen if the car sat for 36+ hours at a time.

I have replaced injectors with index 12 so injectors are not the issue. I had to clear the code when uninstalling my Cobb tune and the dealer won't replace the HPFP without the code even though it has started rough for them the last couple of mornings. Symptoms are there, but no code. The tech stated that there was smoke from the exhaust and brought up the injectors. Would the fuel pump leak overnight causing these rough cold start misfires?

When I turn off the car and clear the code the car runs perfectly.
Appreciate 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:25 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST