E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > Still throwing codes after CBU and software update.



Reply
 
Thread Tools Search this Thread
      04-03-2018, 03:37 PM   #45
koden
Enlisted Member
United_States
3
Rep
37
Posts

Drives: 2011 335d
Join Date: Oct 2016
Location: Portland, OR

iTrader: (0)

Garage List
2011 BMW 335d  [0.00]
I'm going to reset the codes and drive it for another 100 miles or so and see what happens. The rough idle is not as bad as before but its not perfect. Hopefully the injectors just need some time to adapt but I have my doubts.

They did upgrade the software.
Appreciate 0
      04-07-2018, 12:01 AM   #46
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Quote:
Originally Posted by koden View Post
I'm going to reset the codes and drive it for another 100 miles or so and see what happens. The rough idle is not as bad as before but its not perfect. Hopefully the injectors just need some time to adapt but I have my doubts.

They did upgrade the software.
I'm still confused on if "updating the software" included the DDE software. I've never witnessed updating of the software, but they seem to indicate all modules get updated when they do it.
Appreciate 0
      04-08-2018, 01:28 AM   #47
Mtntom3005
Registered
0
Rep
3
Posts

Drives: 2011 335d
Join Date: Nov 2017
Location: PDX

iTrader: (0)

Quote:
Originally Posted by octalon7 View Post
Is your whole car on extended warranty? If not, curious if they ran you around the block charging you for various things before going to a warranty route. Funny how the CBU instructions specifically say now for dealers to not replace the injectors. Sounds like that was a default next step but maybe that was getting costly and not fixing anything. Hope you have success, please let us know!
The first time they wanted to charge me for a CBU clean. I took it in for the active tank But I had that done else where. The second time they kept plugging away at it. BMW authorized an impressive list of repairs under the emissions warranty.

Got the car back on Friday. So far so good. It runs incredibly well now.
Appreciate 0
      04-08-2018, 11:29 AM   #48
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Quote:
Originally Posted by Mtntom3005 View Post
The first time they wanted to charge me for a CBU clean. I took it in for the active tank But I had that done else where. The second time they kept plugging away at it. BMW authorized an impressive list of repairs under the emissions warranty.

Got the car back on Friday. So far so good. It runs incredibly well now.
So this was still BMW of PDX? Hmm, I had avoided dealers because I just imagine them wanting to do a bunch of other stuff not under warranty before ever trying to do warranty work.

What codes was your car displaying? Did you like your service tech? Maybe I should call the same person?
Appreciate 0
      04-12-2018, 01:58 AM   #49
3wis3m3n
Enlisted Member
United_States
0
Rep
39
Posts

Drives: 2011 BMW 335d
Join Date: Apr 2018
Location: Los Angeles, Ca

iTrader: (0)

Quote:
Originally Posted by Mtntom3005 View Post
The first time they wanted to charge me for a CBU clean. I took it in for the active tank But I had that done else where. The second time they kept plugging away at it. BMW authorized an impressive list of repairs under the emissions warranty.

Got the car back on Friday. So far so good. It runs incredibly well now.
Wait, sorry to interrupt but can you give the lists of the things that dealership replaced under the emission warranty ?
My understanding thereís only an extended warranty for the NOx sensors and the Active tank. (120k Miles)
So did the dealer also replaced all of your injectors as part of that extended warranty ? And what about the DDE ? Were there actually a recall for the DDE ?
Appreciate 0
      04-12-2018, 02:38 AM   #50
3wis3m3n
Enlisted Member
United_States
0
Rep
39
Posts

Drives: 2011 BMW 335d
Join Date: Apr 2018
Location: Los Angeles, Ca

iTrader: (0)

Quote:
Originally Posted by octalon7 View Post
See you car out front. Chris said it's a really clean car.

He's updating my software again (apparently a new version is available even since they upgraded a few months ago) and reset all the adaptations. We are going to see if that helps resolve any of the codes before considering next steps.

If you donít mind Iím curious to know what version of software are you running now ? When the last software update you did for the car ?
And did the dealer update your latest software or did you actually did it
yourself ?

I couldnít find the latest software available online so if anyone have info on the latest available software update pls let me know
Thanks
Appreciate 0
      04-12-2018, 08:05 AM   #51
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Quote:
Originally Posted by 3wis3m3n View Post
If you donít mind Iím curious to know what version of software are you running now ? When the last software update you did for the car ?
And did the dealer update your latest software or did you actually did it
yourself ?

I couldnít find the latest software available online so if anyone have info on the latest available software update pls let me know
Thanks
Not sure I have the tools to find what software build it was upgraded to, unless the Foxwell can dig there. This was done at an indy a ~month ago.
Appreciate 0
      04-14-2018, 09:32 PM   #52
koden
Enlisted Member
United_States
3
Rep
37
Posts

Drives: 2011 335d
Join Date: Oct 2016
Location: Portland, OR

iTrader: (0)

Garage List
2011 BMW 335d  [0.00]
I took my car back in Friday. They tested all the injectors and they all tested good both electrically and flow testing. It is not an injector issue.

I asked them to make sure the increment wheel adaption was reset. The software they use does all the resets automatically but they did the increment wheel reset manually just to be sure. When they did it gave them an error and the DDE would not allow the reset.

We have determined it is the DDE. They will be contacting BMW next week to see if there is a software solution or if I need a new DDE. It sounds like there is a software bug in the DDE that wont allow the adaptation to be reset. Hopefully I will know more late next week.
Appreciate 0
      04-14-2018, 11:56 PM   #53
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Quote:
Originally Posted by koden View Post
I took my car back in Friday. They tested all the injectors and they all tested good both electrically and flow testing. It is not an injector issue.

I asked them to make sure the increment wheel adaption was reset. The software they use does all the resets automatically but they did the increment wheel reset manually just to be sure. When they did it gave them an error and the DDE would not allow the reset.

We have determined it is the DDE. They will be contacting BMW next week to see if there is a software solution or if I need a new DDE. It sounds like there is a software bug in the DDE that wont allow the adaptation to be reset. Hopefully I will know more late next week.
Chris told me he BMW has responded to any of his calls/email to inquire about the DDE, he recommended I touch base with BMW of Portland. Haven't had a chance yet.

I also asked about reseting the wheel adaptation and was told the same thing, that all of them are automatically reset.

I think we might be in the same boat here. I'm leaning toward DDE as well although also wonder if my car might need a new MAF...
Appreciate 0
      04-16-2018, 02:04 PM   #54
koden
Enlisted Member
United_States
3
Rep
37
Posts

Drives: 2011 335d
Join Date: Oct 2016
Location: Portland, OR

iTrader: (0)

Garage List
2011 BMW 335d  [0.00]
the week before I took it back in I reset the codes and after a week of driving I was only getting 4592.

I'll follow up with them later in the week. Maybe now that they have 2 examples of the same issue BMW will be more helpful. I think they are trying to talk with BMW of Portland and they are less than helpful. Maybe Kuni would be better (or BMW NA directly).

I do think Chris made progress by identifying that manually trying to reset the increment wheel adaptation gave them an error (which didnt sound like it was reporting the error in the automated routine). My fear is that if it is a bug in the DDE software it will require a long process for BMW to fix.
Appreciate 0
      04-16-2018, 03:19 PM   #55
charlie fairmont
Second Lieutenant
31
Rep
230
Posts

Drives: 2011 335d
Join Date: May 2015
Location: Jax, FL

iTrader: (0)

I was screwing with adaptations a while back. I successfully reset all the adaptions related to new injectors. Soon after, I was having an issue and reset the adaptations again to try to rule something out. Second time around, the incremental wheel reset wouldn't "take." I wonder if there has to be a certain amount of elapsed time in between resets. Not sure why there would be, but who knows...I certainly don't. I do know I have no codes or lights so it could be a red herring. Good luck
Appreciate 0
      04-17-2018, 12:04 AM   #56
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Quote:
Originally Posted by koden View Post
the week before I took it back in I reset the codes and after a week of driving I was only getting 4592.

I'll follow up with them later in the week. Maybe now that they have 2 examples of the same issue BMW will be more helpful. I think they are trying to talk with BMW of Portland and they are less than helpful. Maybe Kuni would be better (or BMW NA directly).

I do think Chris made progress by identifying that manually trying to reset the increment wheel adaptation gave them an error (which didnt sound like it was reporting the error in the automated routine). My fear is that if it is a bug in the DDE software it will require a long process for BMW to fix.
My car is due for emissions testing in a couple of months. Starting to run out of patience/time. I haven't called BMW of Portland yet, just fearing I'll get a service (aka salesman) advisor who is basically going to tell me I need to bring it in and will ignore all my indications of what's been done so far to try to give me a service plan before they do their own diagnostics. I understand their play here, but I really just want to hear from a SA that can actually outline some ideas before I come in.
Appreciate 0
      04-17-2018, 11:15 AM   #57
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

If you are reading this thread, might be worth reading this one as well:

http://www.e90post.com/forums/showthread.php?p=23069895
Appreciate 0
      04-20-2018, 06:41 PM   #58
koden
Enlisted Member
United_States
3
Rep
37
Posts

Drives: 2011 335d
Join Date: Oct 2016
Location: Portland, OR

iTrader: (0)

Garage List
2011 BMW 335d  [0.00]
I figured I would keep adding to this thread. Let me know if you want me to revive one of my old posts and separate our troubles...

My SES light came back on today. I pulled the codes:

4592
4C09
4D16
4B16
459B

Still idling really rough off and on.

I have downloaded the entire ISTA VM and hope to get the software running over the weekend. Not sure I should reset any adaptations at this point due to having a shop work on it and voiding their warranty. Still waiting for a response from the indy on next steps.
Appreciate 0
      04-20-2018, 09:15 PM   #59
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Do they even have a warranty? I don't think resetting would impact any work. I contacted them about coming by today to try the wheel adaptation specifically, but didn't hear back. Maybe next week.
Appreciate 0
      05-07-2018, 08:41 PM   #60
octalon7
Private First Class
United_States
7
Rep
107
Posts

Drives: 2011 335d
Join Date: May 2016
Location: Portland, OR

iTrader: (0)

Welp, pulled a few new to me codes today along with the typical codes (smooth running controller for 2 & 4, zero quantity for 4, and air mass:

4868 (DDE: Air system, air to EGR mass flow, plausibility) - No clue
4596 & 459C: Added a few more cylinders to the smooth running issue (3 and 1 now)
E2C7 (K-can communication fault) - ?

What in the heck is going on...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:29 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST