E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > 330i VANOS Solenoid/ Rough Idle/ AFE Intake-Service Engine Light?



Reply
 
Thread Tools Search this Thread
      07-15-2014, 04:56 PM   #1
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Question 330i VANOS Solenoid/ Rough Idle/ AFE Intake-Service Engine Light?

Hey guys,

My 06 330i is starting to give me issues all of a sudden. Ever since I had an airbag sensor recall fixed at the dealer, I've been having these problems.

My Service Engine Soon Light has come on and goes on and off every 3 or 4 times turning the car on. The light will come on when the car is idling, RPM will then spike up to 3,500 or so and then drop back down and shudder a little, and then the light will pop on.

Took it to my service shop and they read the code (don't know which code exactly) as an intake vanos solenoid issue. Ended up having both vanos solenoids replaced. This worked for about 15 hours. Then while at a red light idling I had the same issue and the SES light came on and continued to idle rough on an off.

My 330i has the BMS Powerbox, AFE Stage 2 Intake, and the BMW Performance exhaust. I've read on here that this particular intake has causes some problems, but was unable to find a solution on the forums.

Anyone have any ideas? Any input is appreciated.

This is what we're trying to save

Last edited by Leather_Lung; 07-29-2014 at 04:31 PM.
Appreciate 0
      07-15-2014, 05:21 PM   #2
TheAxiom
Major General
TheAxiom's Avatar
872
Rep
5,416
Posts

Drives: E92 6 Speed
Join Date: Nov 2013
Location: Florida

iTrader: (3)

Without knowing the codes, we are going to have a tough time helping you. Have you checked the Valvetronic Eccentric Shaft sensor?

Also, when did you install the intake? When did the problems start happening?
__________________
E92 Msport
Appreciate 0
      07-15-2014, 05:34 PM   #3
Tim603
Lieutenant Colonel
Tim603's Avatar
United_States
118
Rep
1,855
Posts

Drives: 2007 335i E90
Join Date: Feb 2012
Location: North Canton, OH

iTrader: (8)

Garage List
2007 335i  [0.00]
Stage 2 aFe is your problem, the Maf is placed too low so you need a spacer to raise it up. I know because I had the same problem!

http://www.e90post.com/forums/showth...=574347&page=2

Scroll to the bottom, that is what you need. I think i put a diagram on one of the pages with dimensions/specs so you can get a machine shop to make it.
__________________
Appreciate 0
      07-15-2014, 05:35 PM   #4
Tim603
Lieutenant Colonel
Tim603's Avatar
United_States
118
Rep
1,855
Posts

Drives: 2007 335i E90
Join Date: Feb 2012
Location: North Canton, OH

iTrader: (8)

Garage List
2007 335i  [0.00]
Oh and beautiful car by the way I have the same hood
__________________
Appreciate 0
      07-15-2014, 05:37 PM   #5
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

I asked the shop and they weren't able to give me the code that it was presenting when I brought it in

I have not checked the Valvetronic Eccentric Shaft sensor yet.

The intake has been installed for about 2 years now and next had any problems until very recently. It all started when the dealer reset my computer after doing the recall.
Appreciate 0
      07-15-2014, 05:39 PM   #6
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Quote:
Originally Posted by Tim603 View Post
Stage 2 aFe is your problem, the Maf is placed too low so you need a spacer to raise it up. I know because I had the same problem!

http://www.e90post.com/forums/showth...=574347&page=2

Scroll to the bottom, that is what you need. I think i put a diagram on one of the pages with dimensions/specs so you can get a machine shop to make it.
Are you still able to have them fabricated?
Appreciate 0
      07-15-2014, 05:47 PM   #7
Tim603
Lieutenant Colonel
Tim603's Avatar
United_States
118
Rep
1,855
Posts

Drives: 2007 335i E90
Join Date: Feb 2012
Location: North Canton, OH

iTrader: (8)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by Leather_Lung View Post
I asked the shop and they weren't able to give me the code that it was presenting when I brought it in

I have not checked the Valvetronic Eccentric Shaft sensor yet.

The intake has been installed for about 2 years now and next had any problems until very recently. It all started when the dealer reset my computer after doing the recall.
Eccentric Shaft sensor is very easy to check, just remove engine cover and unplug it, if you see oil in there it is bad.

Well here is the thing with the aFe stage 2. The problems might not be that noticeable when everything else is operating correctly but when something else goes wrong like intake vanos, it may put emphasis on the problems caused by the aFe making it more noticable (power surging, CEL, etc).

I cant sell them since im not a vendor but any machine shop will make them for about $65-70 and all you need is some RTV red to seal it to the intake tube and longer bolts
__________________
Appreciate 0
      07-15-2014, 06:18 PM   #8
TheAxiom
Major General
TheAxiom's Avatar
872
Rep
5,416
Posts

Drives: E92 6 Speed
Join Date: Nov 2013
Location: Florida

iTrader: (3)

Put on the stock box and see how the car runs.
__________________
E92 Msport
Appreciate 0
      07-15-2014, 09:20 PM   #9
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Having a buddy of mine fabricate that spacer.

Unfortunately, I don't have the stock box. The AFE intake was installed when I bought the car.
Appreciate 0
      07-22-2014, 07:10 PM   #10
koches
Captain
United_States
18
Rep
642
Posts

Drives: 2006 E90 330xi
Join Date: Jul 2013
Location: Baltimore, MD

iTrader: (0)

Garage List
2006 E90 330xi  [5.00]
In the mean while, I would clean the MAF with some CRC MAF cleaner. Couldnt hurt. I had some codes thrown with my Service Engine Light a couple days ago, but mine was more of a MAF sensor/running too lean ordeal. Nevertheless, the light went off after cleaning the sensor.

BTW: What hood is that and where can I get one and for how much?
__________________
Koches
AA Exhaust AA Headers AA Tune
Appreciate 0
      07-23-2014, 03:44 PM   #11
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Still waiting on the spacer to be fabricated...

Hood is a Carbon fiber m3 rep made my NRG

This is not the website I purchased mine from but is the same one.
http://www.dashzracing.com/06-08-bmw...h-be90-m3.html
Appreciate 0
      07-24-2014, 06:37 PM   #12
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

So I got the spacer in place. Cleaned my intake, filter, and MAF sensor.
It definitely improved my situation, but still not 100%. I can leave it idling for quite some time without any issues, but randomly I will have RPM fluctuation and a little engine shudder (greatly less than before). My service engine light did come on once but after resetting it (turn on/off method) it has not come back on since.

Still haven't checked the Eccentric Shaft Sensor. That's next.
Appreciate 0
      07-29-2014, 04:45 PM   #13
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

So here's my Valvetronic Eccentric Shaft Sensor



I cleaned it with some MAF sensor cleaner and some aerosol to get this. Figured I might get a temporary fix enough to diagnose it as the problem.



However, I still have the same issues.

Heres some clips of my car when it feels normal and when it's in "lag" or "limp" mode.
Both videos I'm hitting the throttle equally

Normal

http://tinypic.com/player.php?v=a4o4...8#.U9gFwvldWSo


Laggy mode-
I can hear something different about the engine revving when it's in this mode. Almost like a suction or something closing off.
You can hear the delay of me hitting the accelerator and when it actually revs up.

http://tinypic.com/player.php?v=r27r...8#.U9gFxPldWSo



Last edited by Leather_Lung; 07-29-2014 at 07:08 PM.
Appreciate 0
      07-29-2014, 05:05 PM   #14
GoRomeo
Colonel
GoRomeo's Avatar
43
Rep
2,601
Posts

Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Interesting. Thanks for sharing. Most likely you will need to replace your Valvetronic Eccentric Shaft Sensor.
Appreciate 0
      07-30-2014, 03:19 PM   #15
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Friday I will be installing the OEM Euro Air box. I'll share the results.
Appreciate 0
      08-05-2014, 02:42 PM   #16
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

So here's the update.
Euro Air Box w/ Pipercross filter Installed

Had my Valvetronic Eccentric Shaft Sensor Replaced

And.......Problem persists.

Anyone have any ideas?

Between the air intake and replacing all of these sensors I'm out $1700 with No Improvements

Car is also throwing code 2A82 (intake vanos), however, both vanos solenoids were replaced.
Appreciate 0
      08-05-2014, 02:51 PM   #17
TheSt|G
Resident Tamed Racing Driver
TheSt|G's Avatar
United_States
165
Rep
4,735
Posts

Drives: 911, 130is, E39 M5, E36 M3
Join Date: Mar 2008
Location: Outside Philly

iTrader: (2)

Quote:
Originally Posted by koches View Post
In the mean while, I would clean the MAF with some CRC MAF cleaner. Couldnt hurt. I had some codes thrown with my Service Engine Light a couple days ago, but mine was more of a MAF sensor/running too lean ordeal. Nevertheless, the light went off after cleaning the sensor.

BTW: What hood is that and where can I get one and for how much?
MAF cleaner generally prematurely fails MAFs.
__________________
130is MSport 6MT/ SuperSprint Headers & Exhaust with Swain Tech Race Coat / DISA Manifold / EVOLVE Tune / TCK DA Coilovers / Euro CF Intake/Box / BMW v1 Wheel / BBS RGRs with PSS / F30 Brake Shield / BMW CF Spoiler & Diffuser / Blackline Tails / Rear Fogs Enabled / Front Fogs Delete / CDV Delete / BMW Black Kidneys / M5 Illuminated Knob / BMW Stripe
Appreciate 0
      08-05-2014, 04:28 PM   #18
TheAxiom
Major General
TheAxiom's Avatar
872
Rep
5,416
Posts

Drives: E92 6 Speed
Join Date: Nov 2013
Location: Florida

iTrader: (3)

Have you tried removing the PBX...and checking the fuses, cleaning the vanos sensors and maf?

Oh, and try resetting adaptations and clearing codes too, otherwise you'll have to wait for the car to clear it on it's own.
__________________
E92 Msport
Appreciate 0
      08-05-2014, 04:50 PM   #19
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Quote:
Originally Posted by TheAxiom View Post
Have you tried removing the PBX...and checking the fuses, cleaning the vanos sensors and maf?

Oh, and try resetting adaptations and clearing codes too, otherwise you'll have to wait for the car to clear it on it's own.
That's yes to everything.

Car still turns to limp mode after driving a short time.
Appreciate 0
      08-05-2014, 05:13 PM   #20
BMW..
Captain
38
Rep
799
Posts

Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

I am in a similar situation as you. I think the next thing I will be doing is a smoke test to check for leaks. Get rid of the aFe intake man it will only continue to cause problems I learned that the hard way
__________________
Mystic Blue E90
Phoenix Yellow E46
South Florida BMW Coding
Appreciate 0
      08-05-2014, 05:32 PM   #21
Leather_Lung
Private First Class
Leather_Lung's Avatar
20
Rep
173
Posts

Drives: E90 330i
Join Date: Jan 2014
Location: RI

iTrader: (2)

Quote:
Originally Posted by BMW.. View Post
I am in a similar situation as you. I think the next thing I will be doing is a smoke test to check for leaks. Get rid of the aFe intake man it will only continue to cause problems I learned that the hard way
I don't have the AFE anymore. Now I have the OEM Euro Air Box.
Appreciate 0
      08-05-2014, 06:38 PM   #22
TheAxiom
Major General
TheAxiom's Avatar
872
Rep
5,416
Posts

Drives: E92 6 Speed
Join Date: Nov 2013
Location: Florida

iTrader: (3)

Quote:
Originally Posted by Leather_Lung View Post
I don't have the AFE anymore. Now I have the OEM Euro Air Box.
Oh boy, I would go have the dealer reflash the ECU to a newer program. Long term with that piggyback could have caused potential issues.
__________________
E92 Msport
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:35 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST