E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > 330i starter replaced, dme issue,no start, solved!!



Reply
 
Thread Tools Search this Thread
      08-25-2014, 12:30 PM   #1
shykiemn
Registered
 
Drives: 2006 330i
Join Date: Aug 2014
Location: Miami, FL

Posts: 2
iTrader: (0)

330i starter replaced, dme issue,no start, solved!!

Hey guys ever since I've been on these forums (as a guest) I have not seen the solution to my problem anywhere online. I've been searching for 2 months but oh well maybe I missed the solution somewhere. So this thread is for a person who has my similar issues to get some answers. Now hey, I've had some recent "bad luck" in general and I'm not a mechanic so yes I have made some mistakes with my car so Id like to get that in the open before you guys judge me. I chose to be honest so that others can learn from my mistakes. My car is a 2006 330i 107000 miles.

My car has been amazing since I got it, no issues just the normal stuff. On this day of my problem I noticed that the car was starting slower than usual. What I mean is that the starter seemed labored during the previous three starts. Then at night, I went to a gas station one day and upon sitting back in my car and pressing start, now I just heard a "click". I thought my battery was dead as I've recently replaced it twice since November. Usually I would get some jumper cables and get a jump from somebody but as I tried it this time there was no start, just the click. All my instruments would work and it was if the battery was at full power. I did some research and found out it was my starter. I called a local mechanic that my friend with a Mercedes e350 had Used and recommended. I got a Bosch starter for $128 and he went to put it in. He got my intake manifold off within 30 min and took out my starter. Then comparing the two we noticed that my new starter was the wrong one. I went back to the parts store and they didn't have another. So I went to another store and ended up getting the correct one even cheaper. The mechanic went to put it in again and shocked himself. I said yo did you disconnect the battery? He said no. Well once the starter was in, the car did start however the idle was erratic. It was going up and down pretty rapidly. He checked the hoses to see if one was damaged and didn't find a bad one. He drove the car for 10 min and it still stayed erratic. He said that the PC needed to be reset and called his friend to do it. He said he would be back the next day but didn't come back. I didn't pay him of course. I had two bmw certified mechanics(friends) come over from the local bmw dealer and they couldn't fix it and blamed the battery. I took out the battery, got it charged overnight and put it back in. Now my car WOULDNT START AT ALL. The bmw certified mechanics came again and still couldn't fix it. Then I took it to a local bmw mechanic shop nearby and they blamed the starter. I told them that I put in a new starter but they still wanted $1000 to put in one of there own. On top of that they said I needed a new wiring harness and throttle body. Knowing that a new starter wouldn't fix my problem, and catching them in a couple lies, I took my car back. The other two certified bmw mechanics from the dealer came to my house again to look at my car with a bmw scanner and cleared my fault codes. Still no start. They even took apart the car piece by piece to get to the starter again, check every thing and put it back together just in case something was missed. Nothing. Finally I took my car to another bmw local mechanic a little bit farther away. These guys did everything the previous shop said to do (throttle body, gas petal, sensors, thermostat). Just to make sure and still no start. I wasn't until they went over the car and found a couple fuses that were in the wrong place and a relay that wasn't seated properly and boom the car starts. It starts and was idling fine but the engine would rec really so. From 1k to 3k it would be as if an old lady were revving the car. They told me I needed a NEW DME!!!!! They told me $1400 for the dme and $200 for labor. I called my friends at the dealer and they got me a deal on a new dme for $900. But instead of buying it, I just felt that I should just go get my car and drive it like an old lady to get to work. I went and picked up my car and it didn't drive so bad, just a check engine light so I went to take it to a car wash. After they washed and waxed it I went to start the car and notice that my check engine light was gone. Bam!! I had full power again. I called my "certified" friends and they told me that the DME re-aligned itself after the first guy messed it up when he shocked himself. Yes I should have taken my car to the dealer in the first place but the bottom line is that nobody knew what to do or what was wrong with my car!!!!!
shykiemn is offline  
0
Reply With Quote
      08-25-2014, 01:09 PM   #2
MarkkyyMan
Lieutenant
 
MarkkyyMan's Avatar
 
Drives: 2010 BMW 128i
Join Date: Dec 2009
Location: Indiana, U.S.

Posts: 578
iTrader: (0)

Wow, sorry for your troubles. Hopefully things go smoother for you from here on out.

Last edited by MarkkyyMan; 08-25-2014 at 01:17 PM.
MarkkyyMan is online now   United_States
0
Reply With Quote
      08-25-2014, 01:26 PM   #3
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,211
iTrader: (0)

Garage List
2006 330i  [2.83]
Thanks for sharing but man what kid of mechanic is this, where it does not disconnect the battery when a starter job is performed? That's the first and most important step in the process. He should be lucky he did not fry your DME!!
GoRomeo is offline  
0
Reply With Quote
      08-25-2014, 10:13 PM   #4
e90ben
Lieutenant
 
e90ben's Avatar
 
Drives: No more Beemer
Join Date: Apr 2010
Location: Vancouver, BC

Posts: 475
iTrader: (7)

Crazy!

Good thing you kept at it! Know the feeling when your able to enjoy the car instead of dealing with stuff like this!
e90ben is offline   Canada
0
Reply With Quote
      08-26-2014, 12:04 PM   #5
shykiemn
Registered
 
Drives: 2006 330i
Join Date: Aug 2014
Location: Miami, FL

Posts: 2
iTrader: (0)

Thanks guys hopefully my list of problems and pattern of how things went can help somebody else one day. With all the towing, paying for labor, and loss of my job due to this, I paid about 900 and loss a lot of money I could be earning right now. Anybody hiring for lineman work? Lol
shykiemn is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST