E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > How can I tell what Progman Version I have?



Reply
 
Thread Tools Search this Thread
      12-23-2007, 02:37 PM   #1
gentooguy
Enlisted Member
gentooguy's Avatar
United_States
2
Rep
43
Posts

 
Drives: 2007 BMW 335i Alpine White
Join Date: Sep 2007
Location: VA

iTrader: (0)

Send a message via AIM to gentooguy Send a message via Yahoo to gentooguy Send a message via Skype™ to gentooguy
How can I tell what Progman Version I have?

Recently I took my car in for a Progman update. I had specifically asked for the latest update which VOB of Rockville apparently has. They had my car for several days and claimed that they have updated the software to 27.02.01
Yet I can't seem to verify that this is indeed the case. I read one forum in which a user claims when hitting Auto for the AC the I-Drive unit displays fan speed for 5 seconds. Can anyone else confirm this or any other strong identifying factors for Progman v27.02.01 even some clear pics of the interface would be nice in order to differentiate from other versions like v25
I just want to be sure that the stealership is not pulling a fast one on me.
Appreciate 0
      12-23-2007, 06:04 PM   #2
zenmaster
Lieutenant Colonel
United_States
18
Rep
1,617
Posts

 
Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

Hit auto on the A/C. v25 does nothing in i-drive.
Appreciate 0
      12-23-2007, 07:23 PM   #3
gentooguy
Enlisted Member
gentooguy's Avatar
United_States
2
Rep
43
Posts

 
Drives: 2007 BMW 335i Alpine White
Join Date: Sep 2007
Location: VA

iTrader: (0)

Send a message via AIM to gentooguy Send a message via Yahoo to gentooguy Send a message via Skype™ to gentooguy
Thanks zenmaster! Unfortunately, this confirms that the VOB sucks and they have indeed lied to me. My I-drive does nothing when the AC Auto button is pressed. This is despite the fact that they have even written down on paper that the version they updated to was 27.02.01. They also wrote down that the status level is 07-09-521. It is really frustrating as I paid money for this upgrade as well when it is supposed to be covered under warranty. Moral of the story I guess is if you love your BMW stay far away from VOB in Rockville, MD.
Appreciate 0
      12-23-2007, 09:25 PM   #4
myfirstbmw335i
myfirstbmw335i
myfirstbmw335i's Avatar
United_States
6
Rep
349
Posts

 
Drives: 335i 6-Speed, NAV, Sport
Join Date: Nov 2006
Location: Nashville, Tennessee

iTrader: (0)

Send a message via Yahoo to myfirstbmw335i
my car was built Oct. 26th, 2006.....my dealer lied to me 3 times telling me I did have v27....
I bitched 4 times heavily about the problems I was having until they finally gave it to me....
if you have NAV and you do not have POI search then you have a version prior to v25
Also, v27 has a different colors/graphics as well
Here is what the v27 update corrected for my car....
1. NAV Arrow POP UP display....when you are using NAV, the ARROW POP UP should appear on the small right screen when you get close to an intersection...
2. CD player...prior to update, it would not remember the previous track...
3. RTTI...real time traffic got stuck in search mode prior to update...
4. VOICE commands...prior to update 90% of the command would not work...they work perfect now....
5. my car had a "blip" in the idle approx every 20 seconds and it no longer does...
6. when using steering wheel button * or <> to select audio options am/fm/cd/sat it would not go to the AUX. option....it now does....

There is a service bulletin that shows a v25 update as some of the above issues as "known" problems......

don't give up.....after the update, I went back to the dealer and thanked the service rep and GM of the dealership for listening to my concerns...even though the "diagnostic" system did not find a problem.....the update was like getting a completely new car.......I love my car more than ever....

good luck....
__________________
2007 335i 6-SPD Sport, Jet Black, Coral Red, Premium, NAV, Cold Weather, Park Distance & Comfort Access, Active Autowerke, Clear Reflectors
IFORGED Essen, Flat Black w/Polished Lip, General Exclaim UHP 19 x 10 275/30/19 (ZERO RUBBING) and 19 x 8 235/35/19, H&R Sport Springs
Appreciate 0
      12-23-2007, 10:40 PM   #5
cobradac
First Lieutenant
cobradac's Avatar
13
Rep
374
Posts

 
Drives: '05 645Ci Coupe
Join Date: Oct 2005
Location: Titusville, FLA

iTrader: (0)

Garage List
2005 645Ci  [0.00]
Quote:
Originally Posted by gentooguy View Post
Thanks zenmaster! Unfortunately, this confirms that the VOB sucks and they have indeed lied to me. My I-drive does nothing when the AC Auto button is pressed. This is despite the fact that they have even written down on paper that the version they updated to was 27.02.01. They also wrote down that the status level is 07-09-521. It is really frustrating as I paid money for this upgrade as well when it is supposed to be covered under warranty. Moral of the story I guess is if you love your BMW stay far away from VOB in Rockville, MD.
You of course asked for and received a copy of the Final Report or Measures Plan. They tell you the previous version and the new version TDS. The fact that one thing or another does not work does not invalidate what the dealer installed. There are no "visual" differences between v25 and v27.
__________________
Member - Knights of the Roundel (bimmerdriver s.com)
Over 58 runs of the ToD (or 18,444+ curves)
Appreciate 0
      12-23-2007, 11:25 PM   #6
gentooguy
Enlisted Member
gentooguy's Avatar
United_States
2
Rep
43
Posts

 
Drives: 2007 BMW 335i Alpine White
Join Date: Sep 2007
Location: VA

iTrader: (0)

Send a message via AIM to gentooguy Send a message via Yahoo to gentooguy Send a message via Skype™ to gentooguy
Thanks for the informative replies. I am sure that this will help out others as well. I will be going back to the dealer to speak with both my service rep and the tech who did the update on the car. I am actually more upset about the fact that they flat out lied verbally and on paper about which update they were performing.
Appreciate 0
      01-02-2008, 10:23 AM   #7
asif163
Captain
asif163's Avatar
United_States
13
Rep
702
Posts

 
Drives: '11 M3, '14 Range Rover Sport
Join Date: Nov 2007
Location: Jersey City, New Jersey

iTrader: (0)

Send a message via AIM to asif163 Send a message via MSN to asif163
Quote:
Originally Posted by myfirstbmw335i View Post
my car was built Oct. 26th, 2006.....my dealer lied to me 3 times telling me I did have v27....
I bitched 4 times heavily about the problems I was having until they finally gave it to me....
if you have NAV and you do not have POI search then you have a version prior to v25
Also, v27 has a different colors/graphics as well
Here is what the v27 update corrected for my car....
1. NAV Arrow POP UP display....when you are using NAV, the ARROW POP UP should appear on the small right screen when you get close to an intersection...
2. CD player...prior to update, it would not remember the previous track...
3. RTTI...real time traffic got stuck in search mode prior to update...
4. VOICE commands...prior to update 90% of the command would not work...they work perfect now....
5. my car had a "blip" in the idle approx every 20 seconds and it no longer does...
6. when using steering wheel button * or <> to select audio options am/fm/cd/sat it would not go to the AUX. option....it now does....

There is a service bulletin that shows a v25 update as some of the above issues as "known" problems......

don't give up.....after the update, I went back to the dealer and thanked the service rep and GM of the dealership for listening to my concerns...even though the "diagnostic" system did not find a problem.....the update was like getting a completely new car.......I love my car more than ever....

good luck....

So I just took delivery of my 335i Coupe on New Year's Eve and my NAV does indeed have an arrow pop up on the small right screen when I get close to an intersection. This definitely confirms that I have the newest version correct?
Also, how often do new versions come out?
__________________
2011 E92 M3 / Acquired: 11.08.2010
2014 Range Rover Sport / Acquired: 06.08.2013
Retired: 2011 BMW X3, 2009 Infiniti G37S Coupe, 2006 Audi A4 S-Line 2.0T Quattro, 2008 E92 335i, 2005.5 Audi S4 V8
Appreciate 0
      01-02-2008, 12:53 PM   #8
E92Fan
Moderator
E92Fan's Avatar
United Kingdom
103
Rep
5,492
Posts

 
Drives: .
Join Date: Aug 2007
Location: .

iTrader: (0)

Quote:
Originally Posted by gentooguy View Post
Thanks for the informative replies. I am sure that this will help out others as well. I will be going back to the dealer to speak with both my service rep and the tech who did the update on the car. I am actually more upset about the fact that they flat out lied verbally and on paper about which update they were performing.
wait a sec - I have V27.02.01 progman on mine, verified by seeing the coding machine as it was doing it, and when pressing the auto button on the a/c nothing shows up in the idrive at all... it never has done either?!
Appreciate 0
      01-02-2008, 06:29 PM   #9
cobradac
First Lieutenant
cobradac's Avatar
13
Rep
374
Posts

 
Drives: '05 645Ci Coupe
Join Date: Oct 2005
Location: Titusville, FLA

iTrader: (0)

Garage List
2005 645Ci  [0.00]
Quote:
Originally Posted by E92Fan View Post
wait a sec - I have V27.02.01 progman on mine, verified by seeing the coding machine as it was doing it, and when pressing the auto button on the a/c nothing shows up in the idrive at all... it never has done either?!
I agree - what is this claim all about anyway? If valid, someone needs to detail (preferably w/pics please) or at least the screen/conditions/response when "Auto" makes this magic appearance in iDrive
__________________
Member - Knights of the Roundel (bimmerdriver s.com)
Over 58 runs of the ToD (or 18,444+ curves)
Appreciate 0
      01-02-2008, 06:31 PM   #10
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Help Menu --> About

jkjk
Appreciate 0
      01-03-2008, 10:42 PM   #11
gentooguy
Enlisted Member
gentooguy's Avatar
United_States
2
Rep
43
Posts

 
Drives: 2007 BMW 335i Alpine White
Join Date: Sep 2007
Location: VA

iTrader: (0)

Send a message via AIM to gentooguy Send a message via Yahoo to gentooguy Send a message via Skype™ to gentooguy
Just an update. I went to a different dealer and explained the issue I was having in which they then updated what they claim to be v27.02.01
However, hitting Auto on my dash still doesn't do anything in I-Drive. Oh well maybe only certain builds can perform this function. The build of my car is 09/06.
In any case my i-drive has had enough. I got a freeze up of the I-drive probably due to the update that the new dealer put on. I did the 3 button reset (hold down volume button, nav eject button and cd eject button at the same time) and it hasn't frozen up since but I am keeping my fingers crossed.
Appreciate 0
      01-03-2008, 10:51 PM   #12
cobradac
First Lieutenant
cobradac's Avatar
13
Rep
374
Posts

 
Drives: '05 645Ci Coupe
Join Date: Oct 2005
Location: Titusville, FLA

iTrader: (0)

Garage List
2005 645Ci  [0.00]
Quote:
Originally Posted by gentooguy View Post
Just an update. I went to a different dealer and explained the issue I was having in which they then updated what they claim to be v27.02.01
However, hitting Auto on my dash still doesn't do anything in I-Drive. Oh well maybe only certain builds can perform this function. The build of my car is 09/06.
In any case my i-drive has had enough. I got a freeze up of the I-drive probably due to the update that the new dealer put on. I did the 3 button reset (hold down volume button, nav eject button and cd eject button at the same time) and it hasn't frozen up since but I am keeping my fingers crossed.
And again you asked for and received the Measures Plan or Final Report so that you could satisfy yourself with knowledge of your pre upgrade and post upgrade versions. If you did at least you could speak with absolute knowledge rather that relying on myths and legends from internet boards
__________________
Member - Knights of the Roundel (bimmerdriver s.com)
Over 58 runs of the ToD (or 18,444+ curves)
Appreciate 0
      01-04-2008, 08:07 AM   #13
nyc3r
Colonel
nyc3r's Avatar
United_States
33
Rep
2,589
Posts

 
Drives: E90
Join Date: Jun 2006
Location: USA

iTrader: (24)

Quote:
Originally Posted by asif163 View Post
So I just took delivery of my 335i Coupe on New Year's Eve and my NAV does indeed have an arrow pop up on the small right screen when I get close to an intersection. This definitely confirms that I have the newest version correct?
Also, how often do new versions come out?
the pop up arrow is from v25+
Appreciate 0
      01-07-2008, 02:58 AM   #14
AltecBX
Colonel
AltecBX's Avatar
United_States
106
Rep
2,636
Posts

 
Drives: BMW 335xi Sedan
Join Date: Nov 2007
Location: NYC

iTrader: (0)

How long does it take the dealer to upgrade the Progman? Will I have to get a loaner?
Appreciate 0
      01-07-2008, 09:11 AM   #15
335er
Second Lieutenant
335er's Avatar
3
Rep
225
Posts

 
Drives: Was 335 e90 6M Now G35S 6M
Join Date: Nov 2006
Location: Rockville, MD

iTrader: (1)

Quote:
Originally Posted by gentooguy View Post
Thanks zenmaster! Unfortunately, this confirms that the VOB sucks and they have indeed lied to me. My I-drive does nothing when the AC Auto button is pressed. This is despite the fact that they have even written down on paper that the version they updated to was 27.02.01. They also wrote down that the status level is 07-09-521. It is really frustrating as I paid money for this upgrade as well when it is supposed to be covered under warranty. Moral of the story I guess is if you love your BMW stay far away from VOB in Rockville, MD.
Oh boy. That's where I bought my car and take it for service. Did you ever get ProgMan updated? If so, how did you pull it off?
Appreciate 0
      01-07-2008, 06:20 PM   #16
Humtek
Vishnu Powered
Humtek's Avatar
United_States
28
Rep
2,205
Posts

 
Drives: 335xi, S1000RR
Join Date: Nov 2007
Location: Proceding

iTrader: (7)

My build is a 11/07 and when I hit the auto ac button it takes it to a screen in idrive to select the auto settings: "soft, normal, intensive"

I have no idea what version of progman I have. I know some say the latest progman will pop up letters when scrolling through your ipod and mine does not do this.
Appreciate 0
      01-10-2008, 06:55 PM   #17
FaintReality
NoUSE4aName
5
Rep
325
Posts

 
Drives: 08 AW e92
Join Date: Sep 2007
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by gentooguy View Post
I read one forum in which a user claims when hitting Auto for the AC the I-Drive unit displays fan speed for 5 seconds. Can anyone else confirm this or any other strong identifying factors for Progman v27.02.01 even some clear pics of the interface would be nice in order to differentiate from other versions like v25
I just want to be sure that the stealership is not pulling a fast one on me.



Mine does this but I have no clue what program version I have
Appreciate 0
      01-11-2008, 09:18 AM   #18
cobradac
First Lieutenant
cobradac's Avatar
13
Rep
374
Posts

 
Drives: '05 645Ci Coupe
Join Date: Oct 2005
Location: Titusville, FLA

iTrader: (0)

Garage List
2005 645Ci  [0.00]
Quote:
Originally Posted by FaintReality View Post
Mine does this but I have no clue what program version I have
Well you indicate you have a MY08 so build date is no earlier than September 07. That means your PROGMAN version is no older than 27.00.00.

How about equipment. How is your car equipped? Does the e92 (3 series) have more than one version of A/C? Do you have NAV? The key here is to be specific to compare "apples" to "apples".
__________________
Member - Knights of the Roundel (bimmerdriver s.com)
Over 58 runs of the ToD (or 18,444+ curves)
Appreciate 0
      02-11-2008, 07:02 PM   #19
Mystic330
Enlisted Member
0
Rep
36
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: US

iTrader: (0)

What about a post on another thread about -
Holding the Reset button (trip odometer reset) and the brake pedal for 10 secs???

(http://www.e90post.com/forums/showpo...3&postcount=51)

Does this show anything? (I haven't tried (obviously) yet).
Appreciate 0
      02-11-2008, 08:34 PM   #20
Mystic330
Enlisted Member
0
Rep
36
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: US

iTrader: (0)

I just tried both the A/C button and the reset w/ brake thing....

Neither does a damn thing on my 330 w/ V28.02.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST