E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Idrive Screen going Black



Reply
 
Thread Tools Search this Thread
      02-11-2008, 12:00 PM   #1
combatcarry
Private First Class
 
combatcarry's Avatar
 
Drives: '06 325i
Join Date: Nov 2005
Location: Utah

Posts: 176
iTrader: (3)

Idrive Screen going Black

Yet another problem with my car. This car has had more problems than anything I've ever owned!

About 1 out of every 10 starts my I-drive screen is completely black. I don't have any radio, or I-drive whatsoever. It appears to try to reboot while driving because the screen will flash gray then turn back off. The only way to remedy the problem is to stop the car for 5-10 minutes for it to reset.

Anybody else have this problem? My car is about out of warrantee so I have got to get this fixed and pray that this is my last problem before the warrantee runs out! I'm so frustrated with this car...
combatcarry is offline  
0
Reply With Quote
      02-11-2008, 12:16 PM   #2
BMWMC
Lieutenant
 
Drives: '09 528i Sedan and X5 4.8i SAV
Join Date: Jan 2008
Location: SC

Posts: 487
iTrader: (0)

Take back to the dealer !! might just be a minor software upgrade!
__________________
Mine --> '14 BMW 535i - Alpine White / Black
Wife --> '14 BMW X5 3.5i - Space Gray / Mocha
Personal--> '08 GMC Yukon XL Denali - Dark Slate Black / Gray
Personal--> '09 Nissan Maxima 3.5SV - Winter Frost / Charcoal
BMWMC is offline  
0
Reply With Quote
      02-11-2008, 02:39 PM   #3
SoYank
Major General
 
SoYank's Avatar
 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

Posts: 7,496
iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
There are a number of threads on this phenomenon over in the Technical Forums under iDrive / Navigation Related Discussion.

http://www.e90post.com/forums/showth...&highlight=CCC
http://www.e90post.com/forums/showth...&highlight=CCC
http://www.e90post.com/forums/showth...&highlight=CCC
http://www.e90post.com/forums/showth...&highlight=CCC

to name a few.

A quick synopsis. The CCC could be bad. The software could be bad. The phone system could be incompatible, if only partially.
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
SoYank is offline   United_States
0
Reply With Quote
      02-11-2008, 03:11 PM   #4
magmd
Major General
 
magmd's Avatar
 
Drives: '06 330i
Join Date: Aug 2005
Location: Torrance, CA

Posts: 5,272
iTrader: (13)

Garage List
2006 330i  [0.00]
Buy the extended warranty if you are going to keep the car.
__________________
2006 330i | Black Sapphire Metallic | Step Auto | Navi with iDr | Sports Pkg |OEM Rear Spoiler | 3M CS35 Tint | H&R Sport Springs | Koni Yellows | Advan RS Racing Hypersilver: 19x9 et22 19x10 et20
magmd is offline   United_States
0
Reply With Quote
      02-11-2008, 03:13 PM   #5
MadDog
Careful, I Bite.....
 
MadDog's Avatar
 
Drives: 2006 325i
Join Date: Dec 2006
Location: S.F. Bay Area

Posts: 504
iTrader: (0)

Garage List
2006 325i  [3.75]
Quote:
Originally Posted by magmd View Post
Buy the extended warranty if you are going to keep the car.
+1. If you've had that many problems, it'd be worth it.
MadDog is offline   United_States
0
Reply With Quote
      02-11-2008, 05:46 PM   #6
dim
Enlisted Member
 
dim's Avatar
 
Drives: 2007 E90 335i
Join Date: Aug 2006
Location: Vancouver, BC

Posts: 48
iTrader: (0)

I experienced the same problem with I-drive screen starting up blank and flashing white once every 1-2 min. This often happened when I restarted the car within 5-10 min interval. Furthermore, restarting the car when I-drive was not booting proved fruitless unless I waited over 15+ min.

The dealership intially flashed my car to latest progman (in early Jan 07). However, the problem remained.

In late January, per PUMA, the dealership performed boot file reconstruction (relatively quick procedure since I got the car back the next morning). I-drive hasn't failed since.
__________________
E90 335i | Black Sapphire | Black on Burl | All Canadian Options
Added: Hardwired V1 | PIAA Rings | Xenesis Fogs | OEM CF Lips | OEM Spoiler | Blacklines
dim is offline   Canada
0
Reply With Quote
      02-13-2008, 09:33 PM   #7
combatcarry
Private First Class
 
combatcarry's Avatar
 
Drives: '06 325i
Join Date: Nov 2005
Location: Utah

Posts: 176
iTrader: (3)

No extended warrantee for me

Extended warrantees can only be purchased by the original owner of the car. I already tried.

The reconstuction of the boot file sounds like the most probable cause. It only started doing this after my latest Progman update. This leads me to believe it is software, not hardware related. I HOPE!
combatcarry is offline  
0
Reply With Quote
      02-14-2008, 01:18 AM   #8
zamboni
I want to drive a Zamboni
 
zamboni's Avatar
 
Drives: 09 E82 128i 13 E93 M3
Join Date: Mar 2006
Location: Monte Sereno, CA

Posts: 3,079
iTrader: (5)

Garage List
2013 BMW E93 M3  [0.00]
2009 E82 128i  [0.00]
Have you try after market program and see if they allow you to purchase the protection plan ?
__________________
13 E93 M3 Melbourne Red DCT/Premium/EDC/NAV/220M wheel
12 E93 Space Gray ( Retired BMW buy back )
09 E82 Space Gray/Black int/Steps/Sport/Nav/Premium/Xenon/Phone Int/Hifi/269 wheel
2006 E90 ( sold )
My next vehicle would be a Zamboni
zamboni is offline   United_States
0
Reply With Quote
      02-19-2008, 12:13 PM   #9
riguy
Second Lieutenant
 
riguy's Avatar
 
Drives: '15 X3 M-Sport 28i
Join Date: Aug 2007
Location: Rhode Island

Posts: 244
iTrader: (0)

Garage List
Just had this issue with our 530i. Happened a few times, dealer replaced the CCC right off the bat. No issues so far (fingers crossed).
riguy is offline   United_States
0
Reply With Quote
      03-10-2008, 11:38 AM   #10
nawtyxes
First Lieutenant
 
nawtyxes's Avatar
 
Drives: Black Sapphire E90
Join Date: Jul 2005
Location: Bowie, MD

Posts: 302
iTrader: (0)

MAKE NOTE AND TAKE IT IN IMMEDIATELY

I had my control unit replaced a year and half ago. Just last month the issue came up again. This time the fuse panel needed replacement.
__________________
8/23/05 2006 325i Black Sapphire-Terra Interior-Burl Trim-Nav Idrive-Xenon-ZSP-ZPP-wind deflector-chrome exhaust-PDC
nawtyxes is offline  
0
Reply With Quote
      07-16-2008, 09:48 AM   #11
nyc3r
Colonel
 
nyc3r's Avatar
 
Drives: E90
Join Date: Jun 2006
Location: USA

Posts: 2,589
iTrader: (24)

day 2 at the dealers and they can't figure it out, said they already did boot file reconstruction.
nyc3r is offline   United_States
0
Reply With Quote
      07-16-2008, 01:48 PM   #12
SoYank
Major General
 
SoYank's Avatar
 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

Posts: 7,496
iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
Since the reconstruction didn't work have they tried the software update? On mine they tried numerous things that seemed to work for a day or two. Mine was in the shop eight days over a 14 day period for this type of problem. The last time was last September when they updated the software. Third time but it seems to have worked.
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
SoYank is offline   United_States
0
Reply With Quote
      07-20-2008, 12:40 PM   #13
robdsl17
Enlisted Member
 
robdsl17's Avatar
 
Drives: 07 350z, 06 330xi, 09 335xi
Join Date: Jan 2006
Location: CT

Posts: 43
iTrader: (0)

I had the same problem less than 2 weeks ago..

Idrive would reboot randoml while driving.
The next day, it rebooted about 5 times in a 20 minute period. then, it just shut off completley, the SOS and check engine lights came on. Radio, sounds, everything was dead.

on the plus side, the stupid seat belt stopped beeping!

Dealer replaced the CCC (i dont know what it stands for, but its the idrive computer).
robdsl17 is offline  
0
Reply With Quote
      09-09-2008, 09:09 AM   #14
E90SLAM
Supreme Allied Commander
 
E90SLAM's Avatar
 
Drives: A BBS WHORE
Join Date: Jul 2007
Location: .

Posts: 60,967
iTrader: (6)

Garage List
2006 330i  [4.67]
took a video clip and showed to the SA....
the dealership ran computer tests and cannot pin point wat was wrong to the iDrive given it wasn't fail when i dropped for service yesterday....

and this morning...bam...dead on me again...
E90SLAM is offline   Hong Kong
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:28 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST