E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Number plate bulbs, need help!!



Reply
 
Thread Tools Search this Thread
      04-18-2008, 12:37 AM   #1
Ninjaoz
Captain
 
Ninjaoz's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Melbourne

Posts: 925
iTrader: (0)

Garage List
2007 BMW X5 3.0d  [5.00]
2011 BMW 320d  [5.00]
Number plate bulbs, need help!!

Hey guys

has anyone tried to change their original number plate bulbs to LED?

i bought a pair of LED Xenon Feston Dome and realised the bulbs are rated at 12V bulb whereas the original yellow bulbs are 5W. as a result, the fuse blown (10A 32V).

i was thinking as a 12V LED bulb installed a 5V socket, it should not blow the fuse because the LED resistante is much higher than fillament bulbs but the fuse blown!

any quick solution to the problem?

cheers
leon

Last edited by Ninjaoz; 04-18-2008 at 05:42 AM.
Ninjaoz is offline   Australia
0
Reply With Quote
      04-18-2008, 09:02 AM   #2
VGR00
Major
 
VGR00's Avatar
 
Drives: 125I Edition Sport Carbon Blk
Join Date: Feb 2007
Location: Brisbane - Australia

Posts: 1,494
iTrader: (1)

Lets clarify things first.

1. Standard bulbs are 12v and rated at 5W power consumption
2. You have blown the 10A fuse when you replaced the standard bulb with this LED Xenon Feston.
3. There is no 5V socket that powers your number plate bulb - only 12V

So...

Are the new LED Xenon Feston rated at 12V or 5V ??

If 12V, did you install taking note of the polarity. You dont have to worry about polarity on bulbs but LEDs you do. Make sure positive (+ ve) is connected to the correct side of the LED (it should be marked)

If 5V, you need to run a resistor in series with the positive line. Confirm what you have first and then I can work out what you need.
VGR00 is offline   Australia
0
Reply With Quote
      04-19-2008, 05:07 AM   #3
Ninjaoz
Captain
 
Ninjaoz's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Melbourne

Posts: 925
iTrader: (0)

Garage List
2007 BMW X5 3.0d  [5.00]
2011 BMW 320d  [5.00]
sorry for the confusion, just to clarify my eariler post:

the LED bulbs are festoon type rated at 1W at 12V, everything worked initally but i think one of the LED wasn't secured properly and fell off, i put it back on again, all of the sudden the whole right hand side of the tail-light, instrument, parking lights were gone, then i knew ive blown the fuse!

anyway it is working fine now, thanks for your help!

cheers
leon
Ninjaoz is offline   Australia
0
Reply With Quote
      04-19-2008, 05:25 AM   #4
VGR00
Major
 
VGR00's Avatar
 
Drives: 125I Edition Sport Carbon Blk
Join Date: Feb 2007
Location: Brisbane - Australia

Posts: 1,494
iTrader: (1)

AH ... OK .... sound like you shorted out something out as you were putting it back together
VGR00 is offline   Australia
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:01 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST