E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > The complete E90 problems tracking thread



Reply
 
Thread Tools Search this Thread
      06-19-2005, 01:40 PM   #1
Gnosis
Private
 
Drives: 330i on order :-)
Join Date: May 2005
Location: Earth

Posts: 90
iTrader: (0)

The complete E90 problems tracking thread

Hello everyone!

Since there seem to be a fair amount of people who are having problems with their E90:s I thought that we could try and list them all here.

If you have a problem with your car (ac, nav, transmission etc) please write a short reply and tell us about your car and the nature of the problem.

The point of this thread is NOT to try and solve the problems - please do that in the rest of the forum - but to see how many that has a certain problem. Then maybe we can see if it's a general problem or just an isolated event.

If something turns out to be a general problem then those who are affected can feel that they have some backup if they want to complain/use the warranty etc. And maybe we can even get BMW to fix something quicker if we are lucky...

Here is a form you can use when describing the problem:

-------------------------------------------------------------

Model:
Country:
Automatic transmission (yes/no):
I-Drive (yes/no):
Active Steering (yes/no):
Comfort Access (yes/no):

Problem description:

-------------------------------------------------------------

Also jwocky - this might be a suitable sticky thread... do as you please.

Last edited by Gnosis; 06-19-2005 at 01:46 PM.
Gnosis is offline  
0
Reply With Quote
      06-19-2005, 03:21 PM   #2
CC 330i
Captain
 
CC 330i's Avatar
 
Drives: 330i SG/Blk/Alum
Join Date: May 2005
Location: Orange County, CA

Posts: 722
iTrader: (0)

I guess I will get things started:
Model: 330i
Country:USA
Automatic transmission (yes/no):No
I-Drive (yes/no):No
Active Steering (yes/no):No
Comfort Access (yes/no):No

Problem description:Fog Lights did not work upon delivery. Dealer thought they checked them prior to delivery but I have my doubts. No resolution yet.
CC 330i is offline  
0
Reply With Quote
      06-19-2005, 03:46 PM   #3
AudiA4
Private First Class
 
Drives: '06 330i 6M, Sport
Join Date: May 2005
Location: Little Rock, AR USA

Posts: 153
iTrader: (0)

Model: 330i
Country:USA
Automatic transmission (yes/no):No
I-Drive (yes/no):No
Active Steering (yes/no):No
Comfort Access (yes/no):No

Problem description: Air Conditioning failed at 1,800 miles

Problem description: Bluetooth not operating (Service Measure B84 213 05 - says dealer must "Encode the complete car with CIP16.1 or later")
AudiA4 is offline  
0
Reply With Quote
      06-20-2005, 01:19 AM   #4
joewillie
The Writer
 
Drives: 2006 330i
Join Date: May 2005
Location: Pampa, Texas

Posts: 1
iTrader: (0)

wheel sensor out

Brake and traction control lights on dash. Dealer said wheel sensor was out. It took me a week to get the car into the dealer. He couldn't work on the car when I brought it by. Had to come back (dealer is 60 miles away). They said it was probably the wheel sensor. I brought it back. They checked it. Yeah, the wheel sensor was out. But, they didn't have one in stock. Had to order it. Now, I have to go back again.
joewillie is offline  
0
Reply With Quote
      06-20-2005, 01:40 AM   #5
CC 330i
Captain
 
CC 330i's Avatar
 
Drives: 330i SG/Blk/Alum
Join Date: May 2005
Location: Orange County, CA

Posts: 722
iTrader: (0)

Quote:
Originally Posted by CC 330i
I guess I will get things started:
Model: 330i
Country:USA
Automatic transmission (yes/no):No
I-Drive (yes/no):No
Active Steering (yes/no):No
Comfort Access (yes/no):No

Problem description:Fog Lights did not work upon delivery. Dealer thought they checked them prior to delivery but I have my doubts. No resolution yet.
UPDATE: After installing my factory alarm, my foglights started working. I think it had more to do with removing the negative battery cable for a short time than it did with installing the alarm, though. So I guess I don't have to take it in for that problem, but I still have to take it in to have the software updated so the alarm is activated.
CC 330i is offline  
0
Reply With Quote
      06-20-2005, 08:54 AM   #6
UncleWede
Long Time Admirer, First Time Owner
 
UncleWede's Avatar
 
Drives: E90 325i Arctic
Join Date: Jun 2005
Location: Oxnard, CA

Posts: 2,317
iTrader: (0)

Passenger airbag sensor

-------------------------------------------------------------

Model: 325i
Country: USA
Automatic transmission (yes/no): Y
I-Drive (yes/no): N
Active Steering (yes/no): N
Comfort Access (yes/no): N

Problem description: Indicator that airbag on passenger side has been disabled while wife is belted into that seat. She exceeds the weight required to activate the seat. Will take to dealer on 6/25 (hopefully)

-------------------------------------------------------------
UncleWede is offline   United_States
0
Reply With Quote
      06-20-2005, 09:08 AM   #7
chrisbin
Colonel
 
chrisbin's Avatar
 
Drives: M-Benz C250CDi Est
Join Date: May 2005
Location: S.Wales, UK

Posts: 2,328
iTrader: (1)

Quote:
Originally Posted by UncleWede
-------------------------------------------------------------

She exceeds the weight required to activate the seat. Will take to dealer on 6/25 (hopefully)

-------------------------------------------------------------
Surely that should be that she doesn't exceed the weight....???

Maybe she will feel better about that too....
chrisbin is offline  
0
Reply With Quote
      07-01-2005, 05:49 AM   #8
Dave C. '06 330i
Private
 
Drives: Saphire Black 330i
Join Date: Jun 2005
Location: Florida

Posts: 71
iTrader: (0)

Quote:
Originally Posted by chrisbin
Surely that should be that she doesn't exceed the weight....???

Maybe she will feel better about that too....

Actually, it he has it right. She has to exceed the weight to enable the air bag. If there is only slight weight in the seat, it disables the air bags thinking there is a small child or child seat there. Once a certain weight is exceeded then the air bag enables and the warning light goes out.

-Dave C. '06 330i
Dave C. '06 330i is offline  
0
Reply With Quote
      07-01-2005, 11:58 AM   #9
jiggax23
Private First Class
 
Drives: e90
Join Date: Apr 2005
Location: so. california

Posts: 169
iTrader: (0)

Ok, im fed up w/ the rattling stuff, took it to my dealer 3 times already, and the problem is still there and has gotten more severe. Someone please tell me who i need to speak to in order to fix this problem, im gonna have to start demanding a new car or a refund soon, the rattling is just too much now. Its coming from new locations, and the prior locations are rattling more severely now. I'm starting to become irate.
jiggax23 is offline  
0
Reply With Quote
      07-21-2005, 10:52 AM   #10
neo_eon
New Member
 
neo_eon's Avatar
 
Drives: Bmw 320d (E90)
Join Date: Jul 2005
Location: Madrid (Spain)

Posts: 6
iTrader: (0)

Model: 320d
Country: Spain
Automatic transmission (yes/no): N
I-Drive (yes/no): N
Active Steering (yes/no): N
Comfort Access (yes/no): N

Problem description:

Turbo-compressor, damaged and replaced, to 1800 Km
we are 5 in 1 month
__________________
Saludos.


neo_eon is offline  
0
Reply With Quote
      07-21-2005, 11:16 AM   #11
Thavash
Private First Class
 
Drives: Arctic 320i
Join Date: May 2005
Location: Johannesburg, South Africa

Posts: 162
iTrader: (0)

Garage List
2005 320i  [0.00]
-------------------------------------------------------------

Model: 320i
Country: South Africa
Automatic transmission (yes/no): N
I-Drive (yes/no): N
Active Steering (yes/no): N
Comfort Access (yes/no): N

Problem description: The car started leaking fuel after 2 weeks. It would only happen with the engine running . Investigations revealed that it was coming out of the overflow pipe, and a faulty breather valve was responsible. BMW has replaced the part and the car is now fine.

Note to other owners : If you smell fuel after filling up and especially after a long drive , you could have the same problem.

-------------------------------------------------------------
Thavash is offline  
0
Reply With Quote
      07-22-2005, 07:08 AM   #12
Hornet
First Lieutenant
 
Hornet's Avatar
 
Drives: 420d
Join Date: May 2005
Location: Finland

Posts: 392
iTrader: (0)

Quote:
Originally Posted by neo_eon
Turbo-compressor, damaged and replaced, to 1800 Km
we are 5 in 1 month
The turbo of our dealers demo 320d also broke down.

We drove it when it arrived and it didn't feel as powerful as I expected. The low-rev torque was non-existant.

Later we heard that the car had its turbo replaced due to a problem with the variable turbinegeometry.
Hornet is offline   Finland
0
Reply With Quote
      07-22-2005, 09:44 AM   #13
nexus66
Second Lieutenant
 
Drives: 325iSE
Join Date: Apr 2005
Location: Scotland

Posts: 228
iTrader: (0)

-------------------------------------------------------------

Model: 325iSE (2.5 litre)
Country: UK
Automatic transmission (yes/no):N
I-Drive (yes/no):N
Active Steering (yes/no):N
Comfort Access (yes/no):N

Problem description:
Engine flatspot somewhere between 3K and 3.5K rpm. Not always repeatable - may depend on accelerator position! Still to get round to visiting dealer again!

-------------------------------------------------------------
nexus66 is offline  
0
Reply With Quote
      07-25-2005, 02:25 PM   #14
daniel
Registered
 
Drives:
Join Date: Apr 2005

Posts: 1
iTrader: (0)

Model: 320d
Country: Spain
Automatic transmission (yes/no): N
I-Drive (yes/no): y
Active Steering (yes/no): N
Comfort Access (yes/no): N

Problem description:

Turbo-compressor, damaged and replaced, to 1800 Km
Compressing conditioned air to 2400km :mad: :mad:
daniel is offline  
0
Reply With Quote
      07-26-2005, 12:01 AM   #15
bzzbenz
First Lieutenant
 
bzzbenz's Avatar
 
Drives: 2011 E93
Join Date: Apr 2005
Location: Orange County

Posts: 368
iTrader: (0)

Send a message via AIM to bzzbenz
Quote:
Originally Posted by jiggax23
Ok, im fed up w/ the rattling stuff, took it to my dealer 3 times already, and the problem is still there and has gotten more severe. Someone please tell me who i need to speak to in order to fix this problem, im gonna have to start demanding a new car or a refund soon, the rattling is just too much now. Its coming from new locations, and the prior locations are rattling more severely now. I'm starting to become irate.

This is also driving me crazy! I don't know how much more I can stand all the rattles. I try to drive with my radio really loud, but I am afraid it will just make something else rattle.
__________________
| 2006 325i | Jet Black | Black ette | 6spd manual| Nav | Xenon | Burl | Chrome Tips | 545 sport wheels | Blacklines|
|DOB 6/2/05|Delivered 7/14/05 |
bzzbenz is offline  
0
Reply With Quote
      07-26-2005, 02:22 AM   #16
ziv
Private
 
Drives: 330i, SG, Sport
Join Date: Mar 2005
Location: CA

Posts: 84
iTrader: (0)

so no one has had this on their E90? I have a 330i with sports:

* drive on the highway
* accelerate past 85MPH (please, you'll survive, trust me)
* do you hear a whistling sound coming from the air vents?
* it's as if side-wind is making this noise... Really annoying.

Didn't want to take the car to the dealer because I didn't think they could easily track and fix it.

Any ideas?

Thanks :-)
ziv is offline  
0
Reply With Quote
      07-27-2005, 05:57 PM   #17
UncleWede
Long Time Admirer, First Time Owner
 
UncleWede's Avatar
 
Drives: E90 325i Arctic
Join Date: Jun 2005
Location: Oxnard, CA

Posts: 2,317
iTrader: (0)

-------------------------------------------------------------

Model: 325i
Country: USA
Automatic transmission (yes/no): Y
I-Drive (yes/no): N
Active Steering (yes/no): N
Comfort Access (yes/no): N

Problem description: Indicator that airbag on passenger side has been disabled while wife is belted into that seat. She exceeds the weight required to activate the seat. Will take to dealer on 6/25 (hopefully)

-------------------------------------------------------------

Updated: Got the sensor fixed via a software refresh.
UncleWede is offline   United_States
0
Reply With Quote
      08-01-2005, 04:47 PM   #18
CC 330i
Captain
 
CC 330i's Avatar
 
Drives: 330i SG/Blk/Alum
Join Date: May 2005
Location: Orange County, CA

Posts: 722
iTrader: (0)

Quote:
Originally Posted by CC 330i
UPDATE: After installing my factory alarm, my foglights started working. I think it had more to do with removing the negative battery cable for a short time than it did with installing the alarm, though. So I guess I don't have to take it in for that problem, but I still have to take it in to have the software updated so the alarm is activated.
Update #2: Fog lights stopped working again after a while, so I took it back to the dealer and they replaced the switch and so far, so good. Also got my alarm activated... finally!
CC 330i is offline  
0
Reply With Quote
      08-05-2005, 12:15 PM   #19
arnie
New Member
 
Drives: BMW 330d auto
Join Date: May 2005
Location: cape town sa

Posts: 29
iTrader: (0)

330i
south africa
auto sport
sg, ca, sunroof, etc
problem: noise in steering wheel when turning it, dealer don't know what's wrong. please help, very annoying.
arnie is offline  
0
Reply With Quote
      08-08-2005, 09:31 AM   #20
Tor330
Registered
 
Drives: 2006_330i
Join Date: May 2005
Location: Virginia

Posts: 4
iTrader: (0)

Ticking Noise

Model: 330i
Country:USA
Automatic transmission (yes/no):No
I-Drive (yes/no):No
Active Steering (yes/no):Yes
Comfort Access (yes/no):No

Problem: Ticking noise in driver's side seat belt assy - directly next (even with) dirver's left ear. Noise is distracting and annoying.
Tor330 is offline  
0
Reply With Quote
      08-12-2005, 10:21 PM   #21
sergiodimarco
Enlisted Member
 
Drives: 330I
Join Date: May 2005
Location: YUL

Posts: 30
iTrader: (0)

Model: 330i
Country:Canada
Automatic transmission (yes/no):No
I-Drive (yes/no):No
Active Steering (yes/no):Yes
Comfort Access (yes/no):No
kick ass car: (yes/no): Yes

Problem: 1) Subtle clacking noise from rear seat area, on bumpy roads.
It may be rear cup holders, will verify .
2) Sqeaky rubbing noise from metal trim on dash
(after aircondition is on for a while)

Anyone have similar probs?

Comment:
Although i love the car in general, I think the interior trim is probably poorly assembled or thought out! I've never had a car that had as many interior vibration issues.
sergiodimarco is offline  
0
Reply With Quote
      08-12-2005, 11:25 PM   #22
segfault
Private First Class
 
Drives: No longer own a BMW
Join Date: Apr 2005
Location: .

Posts: 137
iTrader: (0)

Model: 325i Sport
Country: USA
Automatic transmission (yes/no): No
I-Drive (yes/no): No
Active Steering (yes/no): No
Comfort Access (yes/no): No

Problem description: Low-battery warning after running accessories (but no headlights/parking lights) for ~5 minutes after the car is turned off. If I remove the key, the radio will power on for less than one second if I press the radio power button with the key out. The battery reads approximately 12.45 volts with a voltmeter when this condition occurs.

Problem description: Sounds as if a spring is loose in the drivers' seatbelt assembly or door.

Problem description: Wipers work in light rain, but skip and chatter during a heavy downpour. Tried cleaning the windshield but they still chatter.
segfault is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:21 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST