E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > The complete E90 problems tracking thread



Reply
 
Thread Tools Search this Thread
      04-26-2009, 07:47 AM   #133
Bimmer Al
Lieutenant
Canada
8
Rep
597
Posts

 
Drives: 2010 335xi Coupe MSport, 6MT
Join Date: Aug 2007
Location: Ontario, Canada

iTrader: (0)

Quote:
Originally Posted by ab325i View Post
Model: 325i
Country: USA
Automatic transmission (yes/no): yes
I-Drive (yes/no): no
Active Steering (yes/no): no
Comfort Access (yes/no): no

Problem description:

1) Annoying rattling sounds from the driver side seat belt assembly area. I have alredy taken the car to the dealership to be fixed but the sound keeps coming back.
2) Rattling/whistling and wind sounds from the center of the dash at 65mph or higher.
3) Serious heat buildup under the gear selector area. After driving for more than 45 minutes, the heat buildup is bad enough where you cannot touch it. If there is any plastic or metal in the ashtray, the plastic will melt or the metal will get too hot to touch

Taking the car to the dealer again for the fixes. If satisfactory repairs are not made, I have a good mind to refund the car or ask for a new one.
What did the dealer say about the "heat build up?"
__________________
2010 335i xDrive Coupe, Titanium Silver, MSport 6MT
2006 325i Sparkling Graphite Sport Package 6MT Retired
1999 323i Titanium Silver, Sport Package, 5MT Retired
Appreciate 0
      04-26-2009, 07:50 AM   #134
Bimmer Al
Lieutenant
Canada
8
Rep
597
Posts

 
Drives: 2010 335xi Coupe MSport, 6MT
Join Date: Aug 2007
Location: Ontario, Canada

iTrader: (0)

Quote:
Originally Posted by khor01 View Post
(anti-flame suit on)

Model: E92 328i
Country: USA
Automatic transmission (yes/no): no
I-Drive (yes/no):no
Active Steering (yes/no):no
Comfort Access (yes/no):no
Options: ZSP

Problem description:
Lots of wind noise in driver side window seal at 160MPH. Passender side is air-tight and quiet.
lol
__________________
2010 335i xDrive Coupe, Titanium Silver, MSport 6MT
2006 325i Sparkling Graphite Sport Package 6MT Retired
1999 323i Titanium Silver, Sport Package, 5MT Retired
Appreciate 0
      04-27-2009, 03:15 PM   #135
BlackSheep343
No Stress!!
BlackSheep343's Avatar
United_States
1
Rep
61
Posts

 
Drives: 2006 330i
Join Date: Apr 2009
Location: Jersey Shore

iTrader: (0)

Send a message via AIM to BlackSheep343
anyone have problems with the premium seat control's on the driver side? the horizontal one, to lift/drop the front/back. not the whole seat at once, just either or...??? they just dont work... i can mash the button, and finally the front will raise and wont stop, the only way to get it back down is to use my presets... craptastic!!!
__________________
"Quick, turn on the windshield wipers, act normal!"
Appreciate 0
      04-27-2009, 03:42 PM   #136
zerox_guru
Super User!!
zerox_guru's Avatar
Philippines
10
Rep
579
Posts

 
Drives: JB E90/Gixxer
Join Date: Jan 2009
Location: So Cal. Simi Valley

iTrader: (1)

tranny gasket leak at 38k on AT
__________________
Appreciate 0
      05-09-2009, 08:57 PM   #137
Ebby1600
Registered
0
Rep
3
Posts

 
Drives: 325xi
Join Date: May 2009
Location: Camden NY

iTrader: (0)

While turning the steering wheel a click can be heard. The dealer noticed the noise too but stated it may not be covered under warranty and did not offer a possible solution. The noise sounds like it is being made by a plastic material.
Appreciate 0
      05-13-2009, 04:16 PM   #138
Phil G
Dominator of Deep South curvy roads
Phil G's Avatar
United_States
10
Rep
297
Posts

 
Drives: '07 335i Coupe
Join Date: Apr 2006
Location: Atlanta, GA

iTrader: (0)

I'll contribute too:

Model: 2007 335i E92
Country: USA
Automatic transmission (yes/no):N
I-Drive (yes/no):Y
Active Steering (yes/no):N
Comfort Access (yes/no):Y
X-Drive (YES/NO) N

42,000 miles, 2/07 build

Problems:

1: DSC malfunction - Sensor in steering column had to be replaced.

2: Left brake lamp malfunction - This has been handled twice and still comes and goes, very annoying.

3: Wastegate rattle issue - Car spent a week at the dealership and was fixed completely under warranty.

This car is nothing like my '97 4Runner I owned before in terms of reliability, but this still could have been worse. No HPFP issues yet, and thankfully that now is warranted up to 120k miles!
__________________
'07 335i coupe - Space Grey/Black Dakota/Dark Burl - 6MT/ZPP/ZSP/Nav/CA/Heated Seats. ED'd in Munich

Mods: Koni Sport shocks/struts, Cool Carbon street/track pads, R1Concepts Premium rotors, E46 ZHP shift knob.
Appreciate 0
      05-25-2009, 01:38 PM   #139
mikey3028
New Member
0
Rep
10
Posts

 
Drives: BMW E90 325i Sport
Join Date: Feb 2009
Location: Bristol

iTrader: (0)

Quote:
Originally Posted by dguzman70 View Post
2006 325i
The auto doorlocks are not working on the front passenger door and the check engine soon light is on. I took it into the shop and it read a super fine leak code which might be a gas cap I hope. I cant figure out what is wrong with the door locks though
The door locks are crap. Ive had the fault before and now ive got it again. How crap is it that ive got to open the window and get out like the dukes of bloddy hazzard. And with people watching and pressumably thinking, flash sod had broken his car. lol.

Oh and a faulty cam shaft sensor.

BTW the cars only done 26K miles.
Appreciate 0
      11-24-2009, 03:21 PM   #140
NiceAndSlow
Viet Cong
NiceAndSlow's Avatar
4
Rep
255
Posts

 
Drives: Black Metalic 335i
Join Date: Jul 2008
Location: Toronto

iTrader: (0)

Garage List
2007 C2  [0.00]
2001 Boxster  [0.00]
2006 VW Touareg v6  [0.00]
2007 BMW 335i  [0.00]
Model: 2007 335i
Country: Canada
Automatic transmission (yes/no): yes
I-Drive (yes/no): no
Active Steering (yes/no): no
Comfort Access (yes/no): no

Problem description: Lost of Power when acceleration.. Engline Lights on.. Turns out to be a high pressure fuel pump. Got this replaced, and 2 months again, same thing. High Pressure fuel pump went for the second time. Speaker Grill falling on driver side falling off. Long crank to start up, engine rpm inconsistent on startup and while idling. Fluctuates up and down like it has a mind of it's own. Original diagnosed as a low pressure fuel sensor, and final fuel injectors. Had the car for 5 days now and looks like the problem is back again. Still waiting for diagnostics. And finally, mirrors do not remember settings. It goes all over the place when the car is unlock and never stays in the same position.
Appreciate 0
      11-24-2009, 04:07 PM   #141
hotnikks
Private First Class
hotnikks's Avatar
United_States
1
Rep
142
Posts

 
Drives: E90 330 6MT
Join Date: May 2009
Location: NY/NJ

iTrader: (1)

^ Wow ^ Electrical gremlins...
__________________
Appreciate 0
      11-25-2009, 01:09 AM   #142
prototyp
Second Lieutenant
United_States
3
Rep
282
Posts

 
Drives: '06 330i
Join Date: May 2005
Location: Danville + SF, CA

iTrader: (2)

Garage List
2006 330i  [5.00]
Model: 2006 330i E90
Country: USA
Automatic transmission (yes/no):N
I-Drive (yes/no):N
Active Steering (yes/no):Y
Comfort Access (yes/no):N
X-Drive (YES/NO) N

52,800 miles, 4/05 build


Previously, and still present:
Rear brakes squeaking at low speeds after duration of heavy stop/start traffic.

Rattling sunroof. Tedious... (failed to rattle the two times I had the car in to get looked at... it's actually flopping around quite a bit now)

Rattling/ticking center console radio/HVAC unit. Dealer added felt tape... needs more work but I still cannot get the damn thing out of the dashboard. Will be fashioning prying tools out of crowbars soon...


And some new ones to add since this time last year:

Transmission replaced @52k on account of intermittent 2nd gear grind.

Undiagnosed oil leak (need to pull belly pans to investigate).

Suspect right front wheel bearing (twitchy handling at speed, wheel has slight play and clunk when pulled from the top. ew.)
__________________
2006 330i SGM/black, ZSP, ZPP, 217, HuberOps, M Splits, K Lines, AS 3 on EC-7. Since Sep'08.
Appreciate 0
      12-30-2009, 09:32 PM   #143
AlbAtRoS
Gestapo
0
Rep
84
Posts

 
Drives: E90 330i
Join Date: Dec 2009
Location: Boston MA

iTrader: (0)

:l ol::happyani m:: thumsup:
Quote:
Originally Posted by 2008 323i View Post
2007 e90 328i
canada
man.
bought the car new first week tire light came on they checked it and it didn't happen again
4 times on 3m
5000km the engine had valve ticking did bleed down one week later happened again
replaced top end of engine
9700km 3 rd gear was gone you shift it it grinds is you coast for a bit then its fine
got them to give me a differnt car
2008 335i
manu. sports package
gas cap door will not shut, turbo (power) come and goes 3 times thus far
front drivers wheel once in a while like the control arm is lose
3 m pealing
2 night ago started the car a loud hum or stackit sound over the rear speaker
shut the car off it stayed on for 20min after the car was off
BMW does not make a good car
very let down. Im to the point to make them take it back or I will put sticker on my car with detail list of problems I have had so when its at the dealer other people will know how shitty service @ calgary bmw is and how bad these car are
Appreciate 0
      12-30-2009, 09:33 PM   #144
AlbAtRoS
Gestapo
0
Rep
84
Posts

 
Drives: E90 330i
Join Date: Dec 2009
Location: Boston MA

iTrader: (0)

u dont know others car problems
Appreciate 0
      12-30-2009, 10:04 PM   #145
wsybert
First Lieutenant
wsybert's Avatar
United_States
6
Rep
327
Posts

 
Drives: 2009 BMW M3 Vert
Join Date: Sep 2009
Location: Pittsburgh

iTrader: (13)

Model: 2007 335i E90
Country: USA
Automatic transmission (yes/no):N
I-Drive (yes/no):N
Active Steering (yes/no):N
Comfort Access (yes/no):N
X-Drive (YES/NO) N

11/06 Build

Wastegate rattle and subsequent turbo replacement at 49,9xx (both turbos)
Wastegate actuator bushing was worn.
Thread here. http://www.e90post.com/forums/showthread.php?t=313612

The steering wheel trim was replaced at the same time. Peeling.
Both the trim and turbos replaced under warranty.

I bought the car with 48k on it, so no other history.

No tune that I know of, completely stock when I got it.

Add'l info: Pkg's, Cold weather, sport, premium.
__________________
2014 JGC Summit 5.7
2009 M3 Vert (Fun in the sun)
2005 M3 Vert (Sold)
Too many more to list....
Appreciate 0
      01-01-2010, 06:50 PM   #146
bad monkey
Registered
0
Rep
1
Posts

 
Drives: 08 335i
Join Date: Oct 2009
Location: Frankfort, KY

iTrader: (0)

Model: 2008 335i E90 Sport Package (35,000 miles)
Country: USA
Automatic transmission (yes/no):Y
I-Drive (yes/no):Y
Active Steering (yes/no):
Comfort Access (yes/no):
X-Drive (YES/NO) N

Problem: During cold start up in the morning, the motor detonates and the Service Engine Soon light comes on. It runs like a desiel and sounds horrible. I cut it off, and sometimes it takes a few cycles then runs normal.

When I bought the car at BMW as a CPO two months ago I noticed it had a fuel pump replaced. Not a big deal, but i remembered that since this is going on. After I bought it I got the problem above. They replaced the Low Pressure Fuel sensor last and did an update on the software. Started the car again this morning and its doing it again. Get the engine light and service engine soon, and continues to beat itself up. At tempurature it appears to run fine, with the SES light on in the background. But before it runs fine it bangs on itself pretty hard. Something else is bound to fail if this keeps up.

I use 93 octane gas from top tier stations. Nothing else. Calling on Monday and taking it back to the dealer again for the same issue.
Appreciate 0
      01-03-2010, 08:12 AM   #147
hotnikks
Private First Class
hotnikks's Avatar
United_States
1
Rep
142
Posts

 
Drives: E90 330 6MT
Join Date: May 2009
Location: NY/NJ

iTrader: (1)

My turn

Model: 2006 330i E90
Country: USA
Automatic transmission (yes/no):N
I-Drive (yes/no):N
Active Steering (yes/no):N
Comfort Access (yes/no):N
X-Drive (YES/NO) N

42,600 miles, 6/05 build

bought used with 36k

steering wheel and doors peeled (replaced by dealer in warranty)

seatbelt light problem x2 (reprogram and replaced battery wire in warranty)

condensation in both headlights after major rainstorm in september(cleared by itself)
^^
caused adapative headlight failure(headlight stuck to the right out of warranty and not fixed)

Been a good car the past 9 months up until recently..

Update:
02/02/2010
47k miles

replaced both headlight covers (Diy)
AHL control module replaced(Diy) the module was corroded on the inside smh. Still needs programming but fault gone.
She's purring like a champ minus the electronic issues
__________________

Last edited by hotnikks; 02-02-2010 at 11:19 AM. Reason: update
Appreciate 0
      01-12-2010, 01:48 AM   #148
adrswe
ADR Software Engineering
United_States
0
Rep
1
Posts

 
Drives: 2006 E-90 330xi
Join Date: Jan 2010
Location: Maryland

iTrader: (0)

Problems

Bought this car used at dealer auction with 50 K miles and purchased extended warranty

Model: 330xi
Country:USA
Automatic transmission (yes/no):Yes
I-Drive (yes/no):No
Active Steering (yes/no):No
Comfort Access (yes/no):Yes

Problem description: Driver's door handle light not working - bad connector inside door

Problem description: Driver's side headlight lens foggy and intermittent adaptive headlight fault - replaced headlight assembly

Problem description: Leaking windshield washer fluid tank - Replaced tanks and pumps

Problem description: Driver side Sport Seat Air Bag Fault

Last edited by adrswe; 11-24-2012 at 08:05 PM. Reason: Updating
Appreciate 0
      01-12-2010, 07:10 AM   #149
mr-tdi
New Member
Denmark
0
Rep
7
Posts

 
Drives: E90 - 330D
Join Date: May 2008
Location: Denmark

iTrader: (0)

Model: 2006 330d
Country: Denmark
Automatic transmission (yes/no): yes
I-Drive (yes/no): yes
Active Steering (yes/no): no
Comfort Access (yes/no): yes

I have a problem with the locks in right front door. When pressing the unlock on the remote the door doesn't open - but all other doors are opening. After opening the door from the inside and leaving the car - the lock when pressing lock on the remote (all doors).

My question is if this problem is a programming thing on the car of if the dealer needs to split the door to fix?

/Martin
Appreciate 0
      01-14-2010, 11:13 PM   #150
Bmuenster02
New Member
1
Rep
11
Posts

 
Drives: 09 Alpine White 335i xdrive
Join Date: Jun 2009
Location: Northern Virginia

iTrader: (0)

Model:2009 335xdrive coupe
Country: USA
Automatic transmission (yes/no): yes
I-Drive (yes/no): yes
Active Steering (yes/no): yes
Comfort Access (yes/no):no

HELP ME PLEASE! Purchased brand new from dealership 19 miles on the dash, 12000 miles now on dash. i installed a JB3 and AFE intake and did the gold tee mod. the car will drive fine at slow speeds as soon as pressure is applied to the gas all acceleration is lost in the car (engine service soon light is on) and feels like the car is "bogging" out. After that happens i slow the car down and it drives like a diesel with 200k miles and feels like it has 15hp and will barely pull away. oil was changed at 10k. would like to get it to the dealership in the morning for diagnostics, will my upgrades affect bmw warranty on the repair or is this a completely diff issue?
Appreciate 0
      01-16-2010, 08:11 PM   #151
M3fan
New Member
0
Rep
19
Posts

 
Drives: G35
Join Date: Mar 2008
Location: Brooklyn, NY

iTrader: (0)

^ they will Void your warranty since you have JB3 installed. I would take it off and then take it to the dealer unless you have connections at the dealer.
Appreciate 0
      01-20-2010, 06:30 PM   #152
Beau
Enlisted Member
Beau's Avatar
0
Rep
34
Posts

 
Drives: BMW
Join Date: Nov 2009
Location: LA

iTrader: (0)

Quote:
Originally Posted by Bmuenster02 View Post
Model:2009 335xdrive coupe
Country: USA
Automatic transmission (yes/no): yes
I-Drive (yes/no): yes
Active Steering (yes/no): yes
Comfort Access (yes/no):no

HELP ME PLEASE! Purchased brand new from dealership 19 miles on the dash, 12000 miles now on dash. i installed a JB3 and AFE intake and did the gold tee mod. the car will drive fine at slow speeds as soon as pressure is applied to the gas all acceleration is lost in the car (engine service soon light is on) and feels like the car is "bogging" out. After that happens i slow the car down and it drives like a diesel with 200k miles and feels like it has 15hp and will barely pull away. oil was changed at 10k. would like to get it to the dealership in the morning for diagnostics, will my upgrades affect bmw warranty on the repair or is this a completely diff issue?
Contact BMS - your car is going into limp mode. You might have installed the jb3 incorrectly.
Appreciate 0
      02-01-2010, 02:40 PM   #153
DT Fan
New Member
0
Rep
26
Posts

 
Drives: 2006 330xi
Join Date: Jun 2009
Location: Pittsburgh

iTrader: (0)

Model: 330xi
Country: USA
Automatic transmission (yes/no): no
I-Drive (yes/no): yes
Active Steering (yes/no): yes
Comfort Access (yes/no): no

Driving home, freezing cold (9F I think). Engine cuts out while at speed, approx 45mph. Pull car off to side, crank but no start. Haven't heard from dealer in last 48 hours, they will not return calls (customer service says SAs are all busy). From another BMW tech, friend of family in another state, he says possiblity that timing belt is broken, or much less likely, bent valves. 40k miles. Had the ticking problem, but didn't know there was an issue, let it go. Anyone heard of this before??
Appreciate 0
      02-02-2010, 11:24 AM   #154
hotnikks
Private First Class
hotnikks's Avatar
United_States
1
Rep
142
Posts

 
Drives: E90 330 6MT
Join Date: May 2009
Location: NY/NJ

iTrader: (1)

^^
He told you that without even seeing or hearing the car??

Keep us all updated please..I have never heard of a timing chain breaking on these cars especially with 40k. It should outlast the car actually...
__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:31 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST