E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > The complete E90 problems tracking thread



Reply
 
Thread Tools Search this Thread
      02-02-2010, 05:45 PM   #155
ozgur_ustuner
0
New Member
 
ozgur_ustuner's Avatar
 
Drives: bmw 320d
Join Date: Nov 2005
Location: izmir_Turkey

Posts: 23
iTrader: (0)

Garage List
2006 320d  [0.00]
my door locks failed too 320d (2006) i changed front left and right door locks but still broken sometimes. i dont understand ! and bmw doesnt do anything about it.all i found about solution is this link .

http://www.bmwtis.com/tsb/bulletins/...p/B511907g.htm
ozgur_ustuner is offline   Turkey
Appreciate 0
Reply With Quote
      02-05-2010, 11:58 AM   #156
DT Fan
0
New Member
 
Drives: 2006 330xi
Join Date: Jun 2009
Location: Pittsburgh

Posts: 26
iTrader: (0)

Quote:
Originally Posted by hotnikks View Post
^^
He told you that without even seeing or hearing the car??

Keep us all updated please..I have never heard of a timing chain breaking on these cars especially with 40k. It should outlast the car actually...
Update:

Ok so it has been a week and I finally got some solid info from the Service Advisor. I definitely don't like what I heard.

They first thought it was a battery or alternator. Replaced battery, tested charging system, still no start.

They thought it was a cam bolt. Replace cam bolt, still no start.

They now think there was damage to valvetrain caused by me. They are saying I overreved the engine, and they're sending out a different BMW rep to tear it down, take pictures, run tests, and basically are saying I'm going to be without a car for two more weeks. On top of that, they are saying that I might not be covered by warranty. I purposely bought a CPO vehicle with warranty/maintainence at the dealer, and paid a premium for it, to make sure that if anything happened with this vehicle (which I'm not as familiar with, and don't own the tools to work on myself), the dealer would take care of it. I'm so confused?!?!?


My dad is a mechanic in my hometown and I grew up in his shop. Unfortunately, that's 8 hours away from where I live now. He's pretty upset that they took this long to say anything, especially after having me rent a car and saying they'll reimburse me. He's advising me to call BMWNA and talk to someone there to see if this is a usual way to be treated.

Anyone else have advice?
DT Fan is offline  
Appreciate 0
Reply With Quote
      02-12-2010, 10:10 PM   #157
unxgkgrl
0
Registered
 
Drives: 2008 328i Sport Pkg
Join Date: Feb 2010
Location: US, Florida

Posts: 2
iTrader: (0)

Angry SZL Failure, continued equiptment failure

Model: 328i
Country: USA
Automatic transmission (yes/no): yes
I-Drive (yes/no): no
Active Steering (yes/no): no
Comfort Access (yes/no): no

1. Complained of roaring noise from tires (like when brakes go bad). Was told I needed an alignment. I paid $269.00 as its not covered under warrenty...Lie 1. (it was crap I had the bridgestone crap RFT tires they didn't bother to tell me that)
2. BMW Assist worked for 2 days after purchase. then failed it was out for 4 mos.
was told it was because I had tried to pair my bluetooth phone and it blew it upthe SZL that is. (Bull Crap)
3. 14,000 Miles dashboard starts lighting up
A. Brake Failure lights
B. Tire Pressure warning ( pressure was fine)
C. Dashboard lights would all light up then all go off
This required 4 or 5 trips to BMW....when they would read the key it never showed the errors when I would take it by. I started taking pictures with my cell phone to prove it.

3. Finally drove to dealer while whole dasboard was all lit up.
they had the car for 9 days couldn't determmine problem. They Contacted the folks over seas. They had them replace SZL (located in the steering column)

4. I only thought I had problems before. After SZL replacement.

Auto sensing windsheild wipers quit working
Auto door locks quit working
I was told that the doorlocks and auto sensing wipers didn't work because of window tint........bull...they all worked before SZL replacement with same tint

head lights were almost to dimm to drive at night. (dangerously so.... on brights people didn't flash me)
Auto correcting steering system would snatch me off the road.


while they had the car to replace SZL I told them it needed an service they told me I was wrong ( car said -4000 miles, but their system said different) so I missed a service and the new service advisor told me I was wrong for not having the service done.

Took car to dealer to fix the wipers, locks, lights etc. on the way home the car kinda coughed twice rolling up to red light..the dashboard blinked twice the display readers came back on but not dash lights. Called dealer and was told that he had had that happen several times today because it had been raining heavily....

Any ideas any similar problesm
unxgkgrl is offline  
Appreciate 0
Reply With Quote
      03-24-2010, 08:45 PM   #158
AlbAtRoS
0
Gestapo
 
Drives: E90 330i
Join Date: Dec 2009
Location: Boston MA

Posts: 84
iTrader: (0)

Quote:
Originally Posted by zerox_guru View Post
tranny gasket leak at 38k on AT
mine too..45k
AlbAtRoS is offline  
Appreciate 0
Reply With Quote
      04-10-2010, 10:19 AM   #159
golfer29
0
New Member
 
Drives: 335i e90
Join Date: Jul 2005
Location: Toronto

Posts: 10
iTrader: (0)

Quote:
Originally Posted by zerox_guru View Post
tranny gasket leak at 38k on AT
Mine too at 30K (48K KM) - transmission connector seal leaking. Fixed under warranty

Model: 2007 335i
Country: Canada
Automatic transmission (yes/no):Y
I-Drive (yes/no):N
Active Steering (yes/no):N
Comfort Access (yes/no):N
X-Drive (YES/NO) N
golfer29 is offline  
Appreciate 0
Reply With Quote
      04-12-2010, 09:21 PM   #160
Carthief
0
New Member
 
Carthief's Avatar
 
Drives: 2011 BMW 335i Sedan M Sport
Join Date: Aug 2009
Location: Los Angeles

Posts: 16
iTrader: (0)

Broken radio?

Model: 2007 335i Sedan (nov '06 production)
Country: USA
Automatic transmission (yes/no): Y w/ paddles
I-Drive (yes/no): n
Active Steering (yes/no): n
Comfort Access (yes/no): n

Problem description: My radio is on, but I hear no sound. All the channel settings have been reset, but the EQ has remained unchanged. I checked the amp fuse, with no problems found. The speakers worked this morning, but now they don't. I have been using the AUX jack in the arm rest (no USB in my production run) so maybe that has something to do with it. I really don't feel like taking it to the dealer if it's some button I need to push or something...

Thanks
__________________

______________________________________________
2011 Alpine White e90 M Sport
ZMP/ZPP/iDrive/Burl Walnut Trim (want metal)
Carthief is offline   United_States
Appreciate 0
Reply With Quote
      04-12-2010, 10:00 PM   #161
JayKay335i
50
Banned
 
Drives: ///M323 DCT
Join Date: Apr 2009
Location: North Dakota; its best DUHHHHHH

Posts: 5,047
iTrader: (1)

I got a flat tire. I'm going to sue, lemon it, and make them give me a new M5.
JayKay335i is offline   Egypt
Appreciate 0
Reply With Quote
      06-11-2010, 10:10 AM   #162
xtremecruiser
3
First Lieutenant
 
xtremecruiser's Avatar
 
Drives: 08 Waterfall Vert
Join Date: Aug 2008
Location: SC

Posts: 317
iTrader: (0)

Such a great thread
xtremecruiser is offline  
Appreciate 0
Reply With Quote
      06-14-2010, 10:49 PM   #163
andrewkirkby
0
Registered
 
Drives: Problematic E90 320i
Join Date: Jun 2010
Location: Sydney, Australia

Posts: 3
iTrader: (0)

Quote:
Originally Posted by xtremecruiser View Post
Such a great thread
Pity about the cars...

I'd happily buy another 1999 E36 M3 or 1995 E34 525i or even another 2000 M Roadster. All of those cars gave me Zero problems and plenty of "sheer driving pleasure"
Dad also had a 1999 E39 528i, 1990 520i and currently a 2005 X5 3.0d - all with no problems.
andrewkirkby is offline  
Appreciate 0
Reply With Quote
      06-16-2010, 06:09 PM   #164
andrewkirkby
0
Registered
 
Drives: Problematic E90 320i
Join Date: Jun 2010
Location: Sydney, Australia

Posts: 3
iTrader: (0)

Oh, i've got another oil leak. Plumes of smoke are coming from under the hood as of yesterday.

Just another thing for the mechanic to look at.

- vacuum pump seal failure, apparently wear and tear item. Replaced.

Last edited by andrewkirkby; 05-20-2012 at 09:13 PM. Reason: updated information
andrewkirkby is offline  
Appreciate 0
Reply With Quote
      06-16-2010, 07:26 PM   #165
fdriller9
70
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by andrewkirkby View Post
Oh, i've got another oil leak. Plumes of smoke are coming from under the hood as of yesterday.

Just another thing for the mechanic to look at.
lol sound like you got a lemon....
fdriller9 is offline   United_States
Appreciate 0
Reply With Quote
      06-27-2010, 10:20 PM   #166
Fang
0
New Member
 
Drives: 2007 328i
Join Date: Nov 2007
Location: Irvine, CA

Posts: 14
iTrader: (0)

2007 328i

I've had a few problems with my car so far...some major and some minor.

1. at about 15k miles my car would randomly turn off at low speed. When it turns off, I'm talking about complete turn off like power-steering, ac, brakes and all that stuff. Took it to dealer, they told me they couldn't duplicate the problem...(obviously it's not going to happen on command)

SA told me they updated my software or something and I never had the problem again until I hit about 40k miles. This problem happened again though less sparingly. Took it to dealer got same response.

Not sure what it could be cause it happens so rarely. Maybe one day if this problem happens and causes me to get in an accident, they'll be hearing from me.

2. Both cup holders and seatbelt extenders broke (warranty)

3. Rear brake lamp malfunction (warranty)

4. The peeling outer layers on interior panels that multiple people complain about (warranty)

5. Today while wiping my interior, I noticed that my entire ac vent panel is coming unglued. (will be taking it to the dealer)

I have 49,500 miles on my car so I've been giving it the warranty check-up...lol...
Fang is offline  
Appreciate 0
Reply With Quote
      06-28-2010, 07:14 AM   #167
Saintor
23
Colonel
 
Saintor's Avatar
 
Drives: E90
Join Date: Sep 2005
Location: MTL, Canada

Posts: 2,389
iTrader: (1)

Model: 2007 E90 323i (Euro 2.5L detuned at 200HP) - bought it at 4100km now at 60500km / 26 months
Country: Canada
Automatic transmission (yes/no): Yes
I-Drive (yes/no): No
Active Steering (yes/no): No
Comfort Access (yes/no): No

Problems description:
-------------------------------------------------------------
- Battery drain; they kept it for a total of 2 weeks, diagnostic was not easy it was the driver's door lock.

- fading logo on the steering wheel; whole airbag replaced (!) It is fading again.

- sunroof operating erratically; whole cartridge replaced.

- ticking engine on cold starts; exhaust valves replaced.

- rough cold start recently at 60000km; Oxygen sensor (lambda) for cyl. 4-6 replaced

- on the last intervention, they took on their own to reset the automatic transmission & battery ("intermittent problem of DME adaptation") - the only complain I did was 2 years ago that it going in 2-1 could be jerky in rare circumstances.

- right door molding misplaced; reinstall.

- creaking noises around the doors; I think they just lubed the rubbers.

- plastic covers under the car are relatively fragile in snowy environment (more of that with a lowered car)... I spent 538$ to fix those... Car&Driver reported the same $ repair for their long term M3.

I would give the car 7/10 for reliability alone.
__________________
2007 E90 AW 323i Step | Lowered 1.25"/1" | BMW Performance Exhaust | Debadged | Scangauge II | Style 162 18" & 161 17" wheels & rear 15mm spacers

Last edited by Saintor; 06-28-2010 at 07:37 AM.
Saintor is offline  
Appreciate 0
Reply With Quote
      06-29-2010, 10:24 PM   #168
bimbopper
0
Car Guy for life
 
bimbopper's Avatar
 
Drives: '10 E90 328xi
Join Date: Mar 2010
Location: Mid-Atlantic

Posts: 27
iTrader: (0)

Model: 2010 E90 328i xDrive
Country:USA
Automatic transmission (yes/no):Yes
I-Drive (yes/no):Yes
Active Steering (yes/no):No
Comfort Access (yes/no):No

Problem Description - Vibration from rear of car at 60 MPH and higher. At 1000 miles, dealer performs wheel alignment, it does nothing to fix the problem, but shows they did not do an alignment prior to delivery. (Note to self, always require wheel alignment prior to delivery.) At 3000 miles, take car to local shop for wheel balance, they find rear tire (16" Continental runflat) has a bad high spot, other tires have lesser out of round issues. Call dealer, they say "we are not a tire dealer and cannot help you." Go to respected tire shop (Radial Tire in Silver Spring, MD) where they replace one tire under warranty and dismount, remount and rebalance the other three tires. Problem solved. They said it is not uncommon for cars with runflats that have sat on the dealer lot for a few months (like my car) to have the tires shift on the rim and need a dismount and remount. They said the out of round tire replaced under warranty is less common.
bimbopper is offline   United_States
Appreciate 0
Reply With Quote
      07-16-2010, 12:05 PM   #169
Tijash
0
New Member
 
Drives: 2007 335i
Join Date: May 2010
Location: Wellington, FL

Posts: 10
iTrader: (0)

Just had this happen to my 2007 335i. Taking it in tomorrow


http://www.bmwtis.com/tsb/bulletins/...p/B511907g.htm
Tijash is offline   United_States
Appreciate 0
Reply With Quote
      07-20-2010, 08:19 AM   #170
YIMMA2k5
1
Private First Class
 
YIMMA2k5's Avatar
 
Drives: 2006 Monaco Blue Metallic 330i
Join Date: May 2010
Location: Westchester, NY

Posts: 104
iTrader: (0)

Garage List
2003 BMW 3series  [0.00]
2006 330I  [0.00]
2006 E90 330i  [0.00]
Model: 2006 330i
Country: USA
Automatic transmission (yes/no):No
I-Drive (yes/no):No
Active Steering (yes/no):YE$
Comfort Access (yes/no):No
X-Drive (YES/NO) No

problems: creeking noise from the interior cabin, INTERIOR PANELS ARE COMING OFF/ pealing? WTF! not bmw quality..... and front nose is too low I live in a hilly part of the neighborhood tons of pot holes and un grooved pavements, not to mention lots of hills and dips and are not too pleasing to the front bumpers. I love how the car performs just, idk why they have to design it so low in the front that it cant even clear most drive ways with out scraping the bottom of your bumper. and Sheer worrying/ trying to take care of your car and trying to have fun at the same time really kills the joy of thinking this is the ultimate machine.
YIMMA2k5 is offline   United_States
Appreciate 0
Reply With Quote
      07-20-2010, 05:33 PM   #171
Pieter Uys
0
Registered
 
Drives: E90 320i
Join Date: Jul 2010
Location: South Africa

Posts: 1
iTrader: (0)

Hey Andrew

I see you wrote about a rattle in the engine bay while idle,and is worse with start up.What was cuase of the rattle as my car does the same?

please send me a mail at pieteruys@ctecg.co.za

Best wishes
Pieter Uys
Pieter Uys is offline  
Appreciate 0
Reply With Quote
      07-23-2010, 12:25 PM   #172
E90-Norway/UK
0
Registered
 
Drives: E90
Join Date: Jul 2010
Location: Norway

Posts: 1
iTrader: (0)

E90 (2005)
60,000miles (full service history with BMW)
AUTOMATIC (sometimes snatches at the gears)
1.) I had varied power response from the throttle and a loss of power the mechanic handed me the variable timing coil in two pieces today.

2.) The air conditioning needs to be decontaminated as the smell is becoming terrible.

3. Does not start first time takes 3 to 4 attempts or needs mechanical intervention.

4. The adaptive headlight are great when working but fail every couple of months leaving me with no frontal lights (great in the dark and dealer can't find the fault)

5. Rust has appeared close to the front window seals (Note should be covered under warranty)

6. Worst problem was an oil leak from the gasket causing white smoke to fill the cabin.

General note this is the fourth BMW I have owned and the worst!
BMW'S of old had far superior build quality and new broke down on me.
Having issues of the above removes the title of premium car if it was a Jaguar I could forgive asyou expect this kind of thing but a BMW no.

I must point out my farther has the M sport e92 and lots of points regarding build quality appear to have been resolved since the E90 was first introduced.
E90-Norway/UK is offline   Norway
Appreciate 0
Reply With Quote
      07-26-2010, 09:58 PM   #173
Saintor
23
Colonel
 
Saintor's Avatar
 
Drives: E90
Join Date: Sep 2005
Location: MTL, Canada

Posts: 2,389
iTrader: (1)

Complement to my post #170.

I play every day with Steptronic's manual mode. This may have a cost; it no longer works at 38000 miles and they change my gear shift (selector mechanism). I am a bit pissed off right now.
__________________
2007 E90 AW 323i Step | Lowered 1.25"/1" | BMW Performance Exhaust | Debadged | Scangauge II | Style 162 18" & 161 17" wheels & rear 15mm spacers
Saintor is offline  
Appreciate 0
Reply With Quote
      08-01-2010, 02:19 PM   #174
karimz
0
Private
 
karimz's Avatar
 
Drives: 2007 e92 jetblack
Join Date: Mar 2010
Location: sacramento

Posts: 77
iTrader: (1)

Send a message via MSN to karimz
2007 328i

rattling drivers side windshield area closest to the dash. speeds vary 20-freeway speeds.

1) seat belt (arm replacement and seat belt replacement)
2) crappy interior pealings
3)
a. lifter tick (replaced lifter) @ 38k miles
b. lifter tick (replaced lifter) @ 39k mils
c. lifter tick still happens ( going to go to dealership to replace the exhaust cylinder heads) started ot happen at 39k miles (LOL)

4) replaced 2 lights at 45k miles
5)standard work
karimz is offline   United_States
Appreciate 0
Reply With Quote
      08-02-2010, 03:56 AM   #175
mikekilpatrick
3
First Lieutenant
 
Drives: 2008 BMW 328xi
Join Date: Mar 2010
Location: Philadelphia

Posts: 306
iTrader: (4)

Garage List
2008 BMW 328 XI  [0.00]
Model: 328i
Country: USA
Automatic transmission (yes/no): yes
I-Drive (yes/no): Yes
Active Steering (yes/no): no
Comfort Access (yes/no): no

Well, I have already had the lifters replaced in the engine (then the mechanics broke the cowl retaining clips, so new piece was ordered. Of course THEY did not notice this, I had to point it out to them)

What is really bothering me is that my Bluetooth is intermitently broadcasting GARBLED talk from my Verizon Droid phone. I can hear people just fine, but everyone says I sound like I am in a tunnel and garbled. I had this happen today and recorded a message on my home answering machine. The dealership did not believe me last time I was in for service.
mikekilpatrick is offline   United_States
Appreciate 0
Reply With Quote
      09-07-2010, 03:54 PM   #176
Akula
0
Registered
 
Drives: BMW e90 325i 2009
Join Date: Sep 2010
Location: South Africa

Posts: 1
iTrader: (0)

Cool Fuel Consumption

Model: BMW e90 325i Steptronic 2009 Model with 25000Kms on the ODO
Country: South Africa
Automatic transmission (yes/no):Yes
I-Drive (yes/no):No
Active Steering (yes/no):No
Comfort Access (yes/no):No

Problem description:

-------------------------------------------------------------

No matter how i drive my car, i can't get the fuel consumption below 13.3L/100Kms

I have tried driving with a light foot and heavy foot in normal mode and in Drive Sport mode. Any advice would be welcomed.

BMW told me i would get around 600-650Kms on a tank but i'm only getting between 460-480Kms
Akula is offline  
Appreciate 0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST