E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Next GEN I-DRIVE Retrofit



Reply
 
Thread Tools Search this Thread
      09-09-2009, 07:12 PM   #287
Technic
Lieutenant General
Technic's Avatar
United_States
316
Rep
11,847
Posts

Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Quote:
Originally Posted by longtran View Post
they said 2 weeks. even if i did VOR, speedy shipping, the cable there is no eta on it.
Try another dealer: I tried two and one got my cable in less than 2 weeks. The other dealer never received it after almost 2 months of ordering...
Appreciate 0
      09-09-2009, 10:42 PM   #288
dmurray14
The Stig
dmurray14's Avatar
United_States
18
Rep
1,232
Posts

Drives: Quickly
Join Date: Apr 2005
Location: US

iTrader: (1)

Quote:
Originally Posted by longtran View Post
the problem is, we are not sure if we can recode the system. i rather have nice idrive than nice sound.
Again, if you can get ISIS to see it and ISTA/P to recode it, it will read your FA, see the code for digital audio, and code the CIC accordingly. The question is just whether it will recognize the new CIC. You could also try adding the option codes for the CIC to the FA and recoding that way. You'd really have to play around, but I bet it's do-able.

Dan
__________________
Appreciate 0
      09-10-2009, 02:06 PM   #289
longtran
Moderator
longtran's Avatar
476
Rep
16,614
Posts

Drives: E90 M3
Join Date: Jul 2005
Location: CA

iTrader: (105)

Garage List
2006 325i  [0.00]
parts are here. no cable.
Appreciate 0
      09-11-2009, 12:48 PM   #290
longtran
Moderator
longtran's Avatar
476
Rep
16,614
Posts

Drives: E90 M3
Join Date: Jul 2005
Location: CA

iTrader: (105)

Garage List
2006 325i  [0.00]
we have alot of figuring out to do. i tried this last night on my car and it was no plug and play thats for sure. the cic did power up and was running. for some reason i could not get the monitor on. i solder the cable that was cut back together to test it out. its possible that the cable is damage and it wouldnt allow the monitor to power. here are some pics of the back.
Attached Images
   
Appreciate 0
      09-11-2009, 12:58 PM   #291
Technic
Lieutenant General
Technic's Avatar
United_States
316
Rep
11,847
Posts

Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Quote:
Originally Posted by longtran View Post
we have alot of figuring out to do. i tried this last night on my car and it was no plug and play thats for sure. the cic did power up and was running. for some reason i could not get the monitor on. i solder the cable that was cut back together to test it out. its possible that the cable is damage and it wouldnt allow the monitor to power. here are some pics of the back.
The monitor use two connectors, one for power/CAN bus and one for video. The monitor will not show anything if you do not have both connectors plugged in. I guess that the soldered video connector is no good... and I hope that the monitor still is fine.

Is the power connector the same between monitors?
Appreciate 0
      09-11-2009, 01:38 PM   #292
MuchMoore
Colonel
MuchMoore's Avatar
United_States
40
Rep
2,317
Posts

Drives: 08 E90 335i
Join Date: Jul 2008
Location: CenFla

iTrader: (28)

Send a message via AIM to MuchMoore
Technic, shoot me a call.
__________________
| Andrew | M Technik | BMW Performance | BBS | Forge | V1 | LUX | Bilstein | Precision-Sport |

Appreciate 0
      09-11-2009, 06:25 PM   #293
Booster4075
First Lieutenant
Booster4075's Avatar
United_States
14
Rep
389
Posts

Drives: E90, 335i
Join Date: Mar 2008
Location: Northern California

iTrader: (1)

Quote:
Originally Posted by longtran View Post
we have alot of figuring out to do. i tried this last night on my car and it was no plug and play thats for sure. the cic did power up and was running. for some reason i could not get the monitor on. i solder the cable that was cut back together to test it out. its possible that the cable is damage and it wouldnt allow the monitor to power. here are some pics of the back.

The CID will not power up unless it gets the power-up signal from the CAN bus...as said, BOTH connectors must be hooked up to get it to fire up..
Appreciate 0
      09-11-2009, 07:32 PM   #294
pmann
Driving Nirvana
pmann's Avatar
United_States
6
Rep
603
Posts

Drives: 2006 Dinan3
Join Date: Jul 2008
Location: Granite Bay, CA

iTrader: (1)

Garage List
2006 Dinan3  [4.50]
Send a message via AIM to pmann Send a message via MSN to pmann Send a message via Yahoo to pmann
Ok, I am nuts, and want to give this a shot in my 06 E90....



So, from what I am reading, I need a new CIC, Display, Control Knob, and harness to go from the CIC to display?
__________________

2006 BMW Dinan3| Jet Black | Black Dakota Leather | Light Poplar Trim | Euro Lights | Vorsteiner Aero Front Spoiler | Vorsteiner VRS Vented Race Hood | SSR Type C Wheels
Appreciate 0
      09-11-2009, 07:44 PM   #295
MuchMoore
Colonel
MuchMoore's Avatar
United_States
40
Rep
2,317
Posts

Drives: 08 E90 335i
Join Date: Jul 2008
Location: CenFla

iTrader: (28)

Send a message via AIM to MuchMoore
Quote:
Originally Posted by pmann View Post
Ok, I am nuts, and want to give this a shot in my 06 E90....



So, from what I am reading, I need a new CIC, Display, Control Knob, and harness to go from the CIC to display?
And the center console trim.
__________________
| Andrew | M Technik | BMW Performance | BBS | Forge | V1 | LUX | Bilstein | Precision-Sport |

Appreciate 0
      09-11-2009, 07:50 PM   #296
pmann
Driving Nirvana
pmann's Avatar
United_States
6
Rep
603
Posts

Drives: 2006 Dinan3
Join Date: Jul 2008
Location: Granite Bay, CA

iTrader: (1)

Garage List
2006 Dinan3  [4.50]
Send a message via AIM to pmann Send a message via MSN to pmann Send a message via Yahoo to pmann
Quote:
Originally Posted by MuchMoore View Post
And the center console trim.
Cool.
__________________

2006 BMW Dinan3| Jet Black | Black Dakota Leather | Light Poplar Trim | Euro Lights | Vorsteiner Aero Front Spoiler | Vorsteiner VRS Vented Race Hood | SSR Type C Wheels
Appreciate 0
      09-11-2009, 08:49 PM   #297
baltik
Lieutenant
8
Rep
419
Posts

Drives: porsche 944 turbo
Join Date: Dec 2006
Location: San Francisco

iTrader: (0)

Quote:
Originally Posted by pmann View Post
Cool.
+TCU as well I believe
Appreciate 0
      09-11-2009, 10:27 PM   #298
Technic
Lieutenant General
Technic's Avatar
United_States
316
Rep
11,847
Posts

Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Quote:
Originally Posted by baltik View Post
+TCU as well I believe
Not required but helpful...
Appreciate 0
      09-12-2009, 01:35 AM   #299
pmann
Driving Nirvana
pmann's Avatar
United_States
6
Rep
603
Posts

Drives: 2006 Dinan3
Join Date: Jul 2008
Location: Granite Bay, CA

iTrader: (1)

Garage List
2006 Dinan3  [4.50]
Send a message via AIM to pmann Send a message via MSN to pmann Send a message via Yahoo to pmann
I want to get the new iDrive going with sound and picture, then start attacking the problems associated with the peripherals.



I figure once the iDrive is in and working, we are over the biggest hurdle. From there it is baby steps forward.



I think I may have gone nuts....
__________________

2006 BMW Dinan3| Jet Black | Black Dakota Leather | Light Poplar Trim | Euro Lights | Vorsteiner Aero Front Spoiler | Vorsteiner VRS Vented Race Hood | SSR Type C Wheels
Appreciate 0
      09-12-2009, 01:37 AM   #300
pmann
Driving Nirvana
pmann's Avatar
United_States
6
Rep
603
Posts

Drives: 2006 Dinan3
Join Date: Jul 2008
Location: Granite Bay, CA

iTrader: (1)

Garage List
2006 Dinan3  [4.50]
Send a message via AIM to pmann Send a message via MSN to pmann Send a message via Yahoo to pmann
Quote:
Originally Posted by longtran View Post
we have alot of figuring out to do. i tried this last night on my car and it was no plug and play thats for sure. the cic did power up and was running. for some reason i could not get the monitor on. i solder the cable that was cut back together to test it out. its possible that the cable is damage and it wouldnt allow the monitor to power. here are some pics of the back.
Which unit is each of the units?
__________________

2006 BMW Dinan3| Jet Black | Black Dakota Leather | Light Poplar Trim | Euro Lights | Vorsteiner Aero Front Spoiler | Vorsteiner VRS Vented Race Hood | SSR Type C Wheels
Appreciate 0
      09-12-2009, 02:11 PM   #301
TheUltimateDrivingManiac
Freude am Fahren.
Kazakhstan
2
Rep
162
Posts

Drives: E92 335i, E70 X5 xDrive35i
Join Date: Jul 2009
Location: Almaty, Kazakhstan

iTrader: (0)

I've got an offer - for 2700 Euro guy is ready to fly in from Moscow and install CIC to the '08 car without Navi : )

I'm still looking for my e92 335, so may be I will get non-Navi car and upgrade it with CIC.

But Navi will not work because of FSC code, but I do not care much because Navi is not supported in my country anyway.
Appreciate 0
      09-12-2009, 06:24 PM   #302
poldim
Vroom Vrrooooom
poldim's Avatar
Russian Federation
98
Rep
3,144
Posts

Drives: 330i
Join Date: Oct 2005
Location: Bay Area, CA

iTrader: (2)

Garage List
2006 330i Sedan  [0.00]
2003 GSX-R 600  [0.00]
Send a message via AIM to poldim
Quote:
Originally Posted by TheUltimateDrivingManiac View Post
I've got an offer - for 2700 Euro guy is ready to fly in from Moscow and install CIC to the '08 car without Navi : )

I'm still looking for my e92 335, so may be I will get non-Navi car and upgrade it with CIC.

But Navi will not work because of FSC code, but I do not care much because Navi is not supported in my country anyway.

Arent the major upgrades to the iDrive done to the nav system? It seems it would be more expensive and potentially very problematic to do this over buying a car with iDrive from the factory...
Might not be worth the hassle.
__________________
-Dmitriy
06' BMW 330i & 03' Suzuki GSX-R600

SG | Beige Dakota | Poplar || iDrive w/MP3 | PP | SP | CWP | PDC | Comfort | Shades || 40% Tint
| Black Line Tail Lights | Hardwired V1
Appreciate 0
      09-13-2009, 10:47 PM   #303
youyou
Banned
youyou's Avatar
Canada
40
Rep
2,453
Posts

Drives: Porsche 997 C4S
Join Date: Oct 2006
Location: Montreal

iTrader: (0)

Hello!!! Longtran!!!
We need updates every 5 minutes!!
Appreciate 0
      09-13-2009, 11:52 PM   #304
longtran
Moderator
longtran's Avatar
476
Rep
16,614
Posts

Drives: E90 M3
Join Date: Jul 2005
Location: CA

iTrader: (105)

Garage List
2006 325i  [0.00]
Quote:
Originally Posted by youyou View Post
Hello!!! Longtran!!!
We need updates every 5 minutes!!
how did you know i was working on it? i actually got it to work. pics up in a bit.
Appreciate 0
      09-14-2009, 12:25 AM   #305
longtran
Moderator
longtran's Avatar
476
Rep
16,614
Posts

Drives: E90 M3
Join Date: Jul 2005
Location: CA

iTrader: (105)

Garage List
2006 325i  [0.00]
so i checked the wires and i wired it wrong. i called up a member with a LCI and he came out so i can check the wiring. big thanks to AmBiGuOuS for letting me take out monitor. here are the pics of it working. i have no sound like technic said. the other problem is that the navigation did not load up.

[u2b]<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/FMvc7_7jjc0&hl=en&fs=1&"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/FMvc7_7jjc0&hl=en&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>[/u2b]
Attached Images
    
Appreciate 0
      09-14-2009, 12:40 AM   #306
Hunter399
Major General
Hunter399's Avatar
115
Rep
7,760
Posts

Drives: F30 335i/F80 On the way
Join Date: Apr 2005
Location: Houston, TX

iTrader: (30)

Nice work!
Appreciate 0
      09-14-2009, 12:48 AM   #307
ianbiz
4th E90
ianbiz's Avatar
United_States
71
Rep
5,139
Posts

Drives: German
Join Date: Jul 2007
Location: Melbourne/Orlando, Florida

iTrader: (7)

Send a message via AIM to ianbiz
Massive probs on the project!!
__________________
Ian
06 325 06 330 06 330 07 335 11 335 Msport
Appreciate 0
      09-14-2009, 02:03 AM   #308
youyou
Banned
youyou's Avatar
Canada
40
Rep
2,453
Posts

Drives: Porsche 997 C4S
Join Date: Oct 2006
Location: Montreal

iTrader: (0)

Quote:
Originally Posted by longtran View Post
how did you know i was working on it? i actually got it to work. pics up in a bit.

Cause i've been watching this thread religiously since day 1!!
I seriously want to change my car just because i want the 09' Nav...
So imagine how happy i am to see you getting this close to fully functional.
Keep up the good work!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:50 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST